]> git.pld-linux.org Git - packages/gom.git/blob - gom.spec
- updated to 0.3.2
[packages/gom.git] / gom.spec
1 #
2 # Conditional build:
3 %bcond_without  python          # Python (3) binding
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        GObject Data Mapper library
7 Summary(pl.UTF-8):      Biblioteka GObject Data Mapper
8 Name:           gom
9 Version:        0.3.2
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gom/0.3/%{name}-%{version}.tar.xz
14 # Source0-md5:  4191f13d5ec1803a60c0e08330680d8f
15 URL:            https://github.com/GNOME/gom
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake
18 BuildRequires:  gdk-pixbuf2-devel >= 2.0
19 BuildRequires:  gettext-devel
20 BuildRequires:  gettext-tools
21 BuildRequires:  glib2-devel >= 1:2.36
22 BuildRequires:  gnome-common
23 BuildRequires:  gobject-introspection-devel >= 1.30.0
24 BuildRequires:  gtk-doc >= 1.14
25 BuildRequires:  intltool >= 0.40.0
26 BuildRequires:  libtool >= 2:2.2
27 BuildRequires:  pkgconfig
28 %{?with_python:BuildRequires:   python3-devel >= 1:3.4}
29 %{?with_python:BuildRequires:   python3-pygobject3-devel >= 3.16.0}
30 BuildRequires:  sqlite3-devel >= 3.7
31 Requires:       glib2 >= 1:2.36
32 Requires:       sqlite3 >= 3.7
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 GOM (GObject Data Mapper) is an attempt to make a DataMapper for
37 GObject.
38
39 %description -l pl.UTF-8
40 GOM (GObject Data Mapper) to próba stworzenia DataMappera dla obieków
41 biblioteki GObject.
42
43 %package devel
44 Summary:        Header files for GOM library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GOM
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       glib2-devel >= 1:2.36
49
50 %description devel
51 This is the package containing the header files for GOM.
52
53 %description devel -l pl.UTF-8
54 Ten pakiet zawiera pliki nagłówkowe GOM.
55
56 %package static
57 Summary:        Static GOM library
58 Summary(pl.UTF-8):      Statyczna biblioteka GOM
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static GOM library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka GOM.
67
68 %package apidocs
69 Summary:        GOM library API documentation
70 Summary(pl.UTF-8):      Dokumentacja API biblioteki GOM
71 Group:          Documentation
72 Requires:       gtk-doc-common
73 %if "%{_rpmversion}" >= "5"
74 BuildArch:      noarch
75 %endif
76
77 %description apidocs
78 GOM library API documentation.
79
80 %description apidocs -l pl.UTF-8
81 Dokumentacja API biblioteki GOM.
82
83 %package -n python3-gom
84 Summary:        Python 3 binding for GOM library
85 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki GOM
86 Group:          Libraries/Python
87 Requires:       %{name} = %{version}-%{release}
88 Requires:       python3-pygobject3 >= 3.16.0
89
90 %description -n python3-gom
91 Python 3 binding for GOM library.
92
93 %description -n python3-gom -l pl.UTF-8
94 Wiązanie Pythona 3 do biblioteki GOM.
95
96 %prep
97 %setup -q
98
99 %build
100 %{__gtkdocize}
101 %{__intltoolize}
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         %{!?with_python:--disable-python} \
109         --disable-silent-rules \
110         %{!?with_static_libs:--disable-static} \
111         --with-html-dir=%{_gtkdocdir}
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 # obsoleted by pkg-config
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
122
123 %find_lang %{name}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files -f %{name}.lang
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog NEWS README TODO
134 %attr(755,root,root) %{_libdir}/libgom-1.0.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libgom-1.0.so.0
136 %{_libdir}/girepository-1.0/Gom-1.0.typelib
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libgom-1.0.so
141 %{_includedir}/gom-1.0
142 %{_pkgconfigdir}/gom-1.0.pc
143 %{_datadir}/gir-1.0/Gom-1.0.gir
144
145 %if %{with static_libs}
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libgom-1.0.a
149 %endif
150
151 %files apidocs
152 %defattr(644,root,root,755)
153 %{_gtkdocdir}/gom
154
155 %if %{with python}
156 %files -n python3-gom
157 %defattr(644,root,root,755)
158 %{py3_sitedir}/gi/overrides/Gom.py
159 %{py3_sitedir}/gi/overrides/__pycache__/Gom.cpython-*.py[co]
160 %endif
This page took 0.109356 seconds and 3 git commands to generate.