]> git.pld-linux.org Git - packages/gom.git/blob - gom.spec
a1256876a21dfa2558e2546fd919d1dd59f74c95
[packages/gom.git] / gom.spec
1 #
2 # Conditional build:
3 %bcond_without  python          # Python (3) binding
4 #
5 Summary:        GObject Data Mapper library
6 Summary(pl.UTF-8):      Biblioteka GObject Data Mapper
7 Name:           gom
8 Version:        0.3.3
9 Release:        2
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gom/0.3/%{name}-%{version}.tar.xz
13 # Source0-md5:  e0372ce26af5034699c1e6b5ff589bf9
14 URL:            https://github.com/GNOME/gom
15 BuildRequires:  gdk-pixbuf2-devel >= 2.0
16 BuildRequires:  gettext-devel
17 BuildRequires:  gettext-tools
18 BuildRequires:  glib2-devel >= 1:2.36
19 BuildRequires:  gobject-introspection-devel >= 1.30.0
20 BuildRequires:  gtk-doc >= 1.14
21 BuildRequires:  intltool >= 0.40.0
22 BuildRequires:  meson >= 0.38.1
23 BuildRequires:  pkgconfig
24 %{?with_python:BuildRequires:   python3-devel >= 1:3.4}
25 %{?with_python:BuildRequires:   python3-pygobject3-devel >= 3.16.0}
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 BuildRequires:  sqlite3-devel >= 3.7
28 Requires:       glib2 >= 1:2.36
29 Requires:       sqlite3 >= 3.7
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 GOM (GObject Data Mapper) is an attempt to make a DataMapper for
34 GObject.
35
36 %description -l pl.UTF-8
37 GOM (GObject Data Mapper) to próba stworzenia DataMappera dla obieków
38 biblioteki GObject.
39
40 %package devel
41 Summary:        Header files for GOM library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GOM
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       glib2-devel >= 1:2.36
46 Obsoletes:      gom-static
47
48 %description devel
49 This is the package containing the header files for GOM.
50
51 %description devel -l pl.UTF-8
52 Ten pakiet zawiera pliki nagłówkowe GOM.
53
54 %package apidocs
55 Summary:        GOM library API documentation
56 Summary(pl.UTF-8):      Dokumentacja API biblioteki GOM
57 Group:          Documentation
58 Requires:       gtk-doc-common
59 %if "%{_rpmversion}" >= "5"
60 BuildArch:      noarch
61 %endif
62
63 %description apidocs
64 GOM library API documentation.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API biblioteki GOM.
68
69 %package -n python3-gom
70 Summary:        Python 3 binding for GOM library
71 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki GOM
72 Group:          Libraries/Python
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       python3-pygobject3 >= 3.16.0
75
76 %description -n python3-gom
77 Python 3 binding for GOM library.
78
79 %description -n python3-gom -l pl.UTF-8
80 Wiązanie Pythona 3 do biblioteki GOM.
81
82 %prep
83 %setup -q
84
85 %build
86 CC="%{__cc}" \
87 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
88 LDFLAGS="%{rpmldflags}" \
89 meson build \
90         --buildtype=plain \
91         --prefix=%{_prefix} \
92         --libdir=%{_libdir} \
93         -Denable-gtk-doc=true
94
95 ninja -C build -v
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 DESTDIR=$RPM_BUILD_ROOT \
101 ninja -C build -v install
102
103 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
104 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/* $RPM_BUILD_ROOT%{_gtkdocdir}
105
106 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
107 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS ChangeLog NEWS README TODO
118 %attr(755,root,root) %{_libdir}/libgom-1.0.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libgom-1.0.so.0
120 %{_libdir}/girepository-1.0/Gom-1.0.typelib
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/libgom-1.0.so
125 %{_includedir}/gom-1.0
126 %{_pkgconfigdir}/gom-1.0.pc
127 %{_datadir}/gir-1.0/Gom-1.0.gir
128
129 %files apidocs
130 %defattr(644,root,root,755)
131 %{_gtkdocdir}/gom
132
133 %if %{with python}
134 %files -n python3-gom
135 %defattr(644,root,root,755)
136 %{py3_sitedir}/gi/overrides/Gom.py
137 %{py3_sitedir}/gi/overrides/__pycache__/Gom.cpython-*.py[co]
138 %endif
This page took 0.063254 seconds and 2 git commands to generate.