]> git.pld-linux.org Git - packages/go-md2man.git/blob - go-md2man.spec
feb80b1f3196cf65acf21d8da1db2ff8934b9823
[packages/go-md2man.git] / go-md2man.spec
1 Summary:        Process markdown into manpages
2 Name:           go-md2man
3 Version:        1.0.5
4 Release:        1
5 License:        MIT
6 Group:          Development/Tools
7 Source0:        https://github.com/cpuguy83/go-md2man/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  b334c263e113280ec1e9420801b3d452
9 URL:            https://github.com/cpuguy83/go-md2man
10 BuildRequires:  golang
11 BuildRequires:  golang-github-russross-blackfriday-devel
12 ExclusiveArch:  %{ix86} %{x8664} %{arm} aarch64 mips64 mips64le ppc64 ppc64le s390x
13
14 %define         _enable_debug_packages 0
15 %define         gobuild(o:) go build -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n')" -a -v -x %{?**};
16
17 %description
18 go-md2man is a golang tool using blackfriday to process markdown into
19 manpages.
20
21 %prep
22 %setup -q
23
24 mkdir -p src/github.com/cpuguy83
25 ln -s ../../../ src/github.com/cpuguy83/go-md2man
26
27 %build
28 export GOPATH=$(pwd)
29
30 %gobuild -o bin/go-md2man github.com/cpuguy83/go-md2man
31
32 bin/go-md2man -in=go-md2man.1.md -out=go-md2man.1
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
37 cp -p bin/go-md2man $RPM_BUILD_ROOT%{_bindir}
38 install -p go-md2man.1 $RPM_BUILD_ROOT%{_mandir}/man1
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(644,root,root,755)
45 %doc README.md LICENSE.md
46 %attr(755,root,root) %{_bindir}/go-md2man
47 %{_mandir}/man1/*.1*
This page took 0.019568 seconds and 2 git commands to generate.