]> git.pld-linux.org Git - packages/go-md2man.git/blob - go-md2man.spec
f23d9123ca3834e2cec79fcad02a835cc39f1da5
[packages/go-md2man.git] / go-md2man.spec
1 Summary:        Process markdown into manpages
2 Name:           go-md2man
3 Version:        1.0.10
4 Release:        1
5 License:        MIT
6 Group:          Development/Tools
7 Source0:        https://github.com/cpuguy83/go-md2man/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  2f2ab80cbee456548790449a26cc2edc
9 URL:            https://github.com/cpuguy83/go-md2man
10 BuildRequires:  golang
11 BuildRequires:  golang-github-russross-blackfriday-devel
12 BuildRequires:  rpmbuild(macros) >= 2.009
13 ExclusiveArch:  %go_arches
14
15 %define         _enable_debug_packages 0
16 %define         gobuild(o:) %__go build -mod=vendor -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n')" -a -v -x %{?**};
17
18 %description
19 go-md2man is a golang tool using blackfriday to process markdown into
20 manpages.
21
22 %prep
23 %setup -q
24
25 mkdir -p src/github.com/cpuguy83
26 ln -s ../../../ src/github.com/cpuguy83/go-md2man
27
28 %build
29 export GOCACHE=$(pwd)/.go-cache
30
31 %gobuild -o bin/go-md2man github.com/cpuguy83/go-md2man
32
33 bin/go-md2man -in=go-md2man.1.md -out=go-md2man.1
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
38 cp -p bin/go-md2man $RPM_BUILD_ROOT%{_bindir}
39 install -p go-md2man.1 $RPM_BUILD_ROOT%{_mandir}/man1
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc README.md LICENSE.md
47 %attr(755,root,root) %{_bindir}/go-md2man
48 %{_mandir}/man1/*.1*
This page took 0.019688 seconds and 2 git commands to generate.