]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
- updated to 3.2.1
[packages/gnutls.git] / gnutls.spec
1 #
2 # Conditional build:
3 %bcond_with     gcrypt  # use gcrypt crypto backend instead of nettle (withdrawn?)
4 %bcond_without  dane    # libdane (DANE with DNSSEC certificate verification)
5 %bcond_with     tpm     # TPM support in gnutls (cannot be used with GPL programs)
6 #
7 Summary:        The GNU Transport Layer Security Library
8 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
9 Name:           gnutls
10 Version:        3.2.1
11 Release:        1
12 License:        LGPL v3+ (libgnutls), GPL v3+ (openssl library and tools)
13 Group:          Libraries
14 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.2/%{name}-%{version}.tar.lz
15 # Source0-md5:  157386119a90f458fecf8303584f9417
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-link.patch
18 Patch2:         %{name}-pl.po-update.patch
19 URL:            http://www.gnutls.org/
20 BuildRequires:  autoconf >= 2.61
21 BuildRequires:  automake >= 1:1.11.3
22 BuildRequires:  gettext-devel >= 0.18
23 BuildRequires:  gtk-doc >= 1.1
24 BuildRequires:  guile-devel >= 5:2.0
25 BuildRequires:  libcfg+-devel
26 %{?with_gcrypt:BuildRequires:   libgcrypt-devel >= 1.4.0}
27 BuildRequires:  libidn-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtasn1-devel >= 2.14
30 BuildRequires:  libtool >= 2:1.5
31 BuildRequires:  lzip
32 %{!?with_gcrypt:BuildRequires:  nettle-devel >= 2.7}
33 # miniopencdk is included in sources and currently maintained
34 # as part of gnutls, not external package
35 #BuildRequires: opencdk-devel >= 0.6.6
36 BuildRequires:  p11-kit-devel >= 0.11
37 BuildRequires:  pkgconfig
38 BuildRequires:  readline-devel
39 BuildRequires:  rpmbuild(macros) >= 1.383
40 BuildRequires:  sed >= 4.0
41 BuildRequires:  tar >= 1:1.22
42 BuildRequires:  texinfo >= 4.8
43 %{?with_tpm:BuildRequires:      trousers-devel}
44 %{?with_dane:BuildRequires:     unbound-devel}
45 BuildRequires:  zlib-devel
46 Requires:       %{name}-libs = %{version}-%{release}
47 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 GnuTLS is a project that aims to develop a library which provides a
52 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
53 the gnuTLS library implements the proposed standards by the IETF's TLS
54 working group.
55
56 %description -l pl.UTF-8
57 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
58 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
59 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
60 grupę roboczą IETF TLS.
61
62 %package libs
63 Summary:        GnuTLS shared libraries
64 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
65 Group:          Libraries
66 %{?with_gcrypt:Requires:        libgcrypt >= 1.4.0}
67 Requires:       libtasn1 >= 2.14
68 %{!?with_gcrypt:Requires:       nettle >= 2.7}
69 #Requires:      opencdk >= 0.6.6
70 Requires:       p11-kit >= 0.11
71 Conflicts:      gnutls < 3.2.0
72
73 %description libs
74 GnuTLS shared libraries.
75
76 %description libs -l pl.UTF-8
77 Biblioteki współdzielone GnuTLS.
78
79 %package devel
80 Summary:        Header files etc to develop gnutls applications
81 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
82 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
83 Group:          Development/Libraries
84 Requires:       %{name}-libs = %{version}-%{release}
85 %{?with_gcrypt:Requires:        libgcrypt-devel >= 1.4.0}
86 Requires:       libtasn1-devel >= 2.14
87 %{!?with_gcrypt:Requires:       nettle-devel >= 2.7}
88 #Requires:      opencdk-devel >= 0.6.6
89 Requires:       p11-kit-devel >= 0.11
90 %{?with_tpm:Requires:   trousers-devel}
91 Requires:       zlib-devel
92
93 %description devel
94 Header files etc to develop gnutls applications.
95
96 %description devel -l pl.UTF-8
97 Pliki nagłówkowe i inne do gnutls.
98
99 %package static
100 Summary:        Static gnutls library
101 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
102 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
103 Group:          Development/Libraries
104 Requires:       %{name}-devel = %{version}-%{release}
105
106 %description static
107 Static gnutls library.
108
109 %description static -l pl.UTF-8
110 Biblioteka statyczna gnutls.
111
112 %package c++
113 Summary:        libgnutlsxx - C++ interface to gnutls library
114 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
115 License:        LGPL v2.1+
116 Group:          Libraries
117 Requires:       %{name}-libs = %{version}-%{release}
118
119 %description c++
120 libgnutlsxx - C++ interface to gnutls library.
121
122 %description c++ -l pl.UTF-8
123 libgnutlsxx - interfejs C++ do biblioteki gnutls.
124
125 %package c++-devel
126 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
127 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
128 License:        LGPL v2.1+
129 Group:          Development/Libraries
130 Requires:       %{name}-c++ = %{version}-%{release}
131 Requires:       %{name}-devel = %{version}-%{release}
132 Requires:       libstdc++-devel
133
134 %description c++-devel
135 Header files for libgnutlsxx, a C++ interface to gnutls library.
136
137 %description c++-devel -l pl.UTF-8
138 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
139
140 %package c++-static
141 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
142 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
143 License:        LGPL v2.1+
144 Group:          Development/Libraries
145 Requires:       %{name}-c++-devel = %{version}-%{release}
146
147 %description c++-static
148 Static version of libgnutlsxx, a C++ interface to gnutls library.
149
150 %description c++-static -l pl.UTF-8
151 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
152
153 %package dane
154 Summary:        DANE security library
155 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
156 Group:          Libraries
157 Requires:       %{name}-libs = %{version}-%{release}
158
159 %description dane
160 DANE security library.
161
162 %description dane -l pl.UTF-8
163 Biblioteka bezpieczeństwa DANE.
164
165 %package dane-devel
166 Summary:        Header file for DANE security library
167 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
168 Group:          Development/Libraries
169 Requires:       %{name}-dane = %{version}-%{release}
170 Requires:       %{name}-devel = %{version}-%{release}
171 Requires:       unbound-devel
172
173 %description dane-devel
174 Header file for DANE security library.
175
176 %description dane-devel -l pl.UTF-8
177 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
178
179 %package dane-static
180 Summary:        Static DANE security library
181 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
182 Group:          Development/Libraries
183 Requires:       %{name}-dane-devel = %{version}-%{release}
184
185 %description dane-static
186 Static DANE security library.
187
188 %description dane-static -l pl.UTF-8
189 Statyczna biblioteka bezpieczeństwa DANE.
190
191 %package -n guile-gnutls
192 Summary:        Guile bindings for GnuTLS
193 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
194 License:        LGPL v2.1+
195 Group:          Development/Languages
196 Requires:       %{name}-libs = %{version}-%{release}
197 Requires:       guile >= 5:2.0
198
199 %description -n guile-gnutls
200 Guile bindings for GnuTLS.
201
202 %description -n guile-gnutls -l pl.UTF-8
203 Wiązania Guile do GnuTLS.
204
205 %prep
206 %setup -q
207 %patch0 -p1
208 %patch1 -p1
209 %patch2 -p1
210
211 %{__rm} po/stamp-po
212
213 # remove it when "linking libtool libraries using a non-POSIX archiver ..." warning is gone
214 # (after gnutls or libtool change)
215 %{__sed} -i -e '/AM_INIT_AUTOMAKE/s/-Werror//' configure.ac
216
217 %build
218 %{__libtoolize}
219 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4
220 %{__autoconf}
221 %{__autoheader}
222 %{__automake}
223 %configure \
224         --disable-silent-rules \
225         --enable-heartbeat-support \
226         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
227         %{?with_gcrypt:--with-libgcrypt} \
228         %{?with_tpm:--with-tpm}
229
230 # docs build is broken with -jN
231 %{__make} -j1
232
233 %install
234 rm -rf $RPM_BUILD_ROOT
235
236 %{__make} install \
237         DESTDIR=$RPM_BUILD_ROOT
238
239 # although libgnutls.la is obsoleted by pkg-config, there is
240 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
241
242 # guile module - dynamic only
243 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.{la,a}
244
245 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
246
247 %find_lang %{name}
248
249 %clean
250 rm -rf $RPM_BUILD_ROOT
251
252 %post
253 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
254
255 %postun
256 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
257
258 %post   libs -p /sbin/ldconfig
259 %postun libs -p /sbin/ldconfig
260
261 %post   c++ -p /sbin/ldconfig
262 %postun c++ -p /sbin/ldconfig
263
264 %post   -n guile-gnutls -p /sbin/ldconfig
265 %postun -n guile-gnutls -p /sbin/ldconfig
266
267 %files -f %{name}.lang
268 %defattr(644,root,root,755)
269 %doc AUTHORS ChangeLog NEWS README THANKS
270 %attr(755,root,root) %{_bindir}/certtool
271 %attr(755,root,root) %{_bindir}/crywrap
272 %attr(755,root,root) %{_bindir}/gnutls-*
273 %attr(755,root,root) %{_bindir}/ocsptool
274 %attr(755,root,root) %{_bindir}/p11tool
275 %attr(755,root,root) %{_bindir}/psktool
276 %attr(755,root,root) %{_bindir}/srptool
277 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
278 %{_mandir}/man1/certtool.1*
279 %{_mandir}/man1/gnutls-*.1*
280 %{_mandir}/man1/ocsptool.1*
281 %{_mandir}/man1/p11tool.1*
282 %{_mandir}/man1/psktool.1*
283 %{_mandir}/man1/srptool.1*
284 %{_mandir}/man1/tpmtool.1*
285 %{_infodir}/gnutls.info*
286 %{_infodir}/gnutls-*.png
287 %{_infodir}/pkcs11-vision.png
288
289 %files libs
290 %defattr(644,root,root,755)
291 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
292 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.28
293 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
294 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
295 %attr(755,root,root) %{_libdir}/libgnutls-xssl.so.*.*.*
296 %attr(755,root,root) %ghost %{_libdir}/libgnutls-xssl.so.0
297
298 %files devel
299 %defattr(644,root,root,755)
300 %attr(755,root,root) %{_libdir}/libgnutls.so
301 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
302 %attr(755,root,root) %{_libdir}/libgnutls-xssl.so
303 %{_libdir}/libgnutls.la
304 %{_libdir}/libgnutls-openssl.la
305 %{_libdir}/libgnutls-xssl.la
306 %{_includedir}/gnutls
307 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
308 %exclude %{_includedir}/gnutls/gnutlsxx.h
309 %{_pkgconfigdir}/gnutls.pc
310 %{_mandir}/man3/gnutls_*.3*
311
312 %files static
313 %defattr(644,root,root,755)
314 %{_libdir}/libgnutls.a
315 %{_libdir}/libgnutls-openssl.a
316 %{_libdir}/libgnutls-xssl.a
317
318 %files c++
319 %defattr(644,root,root,755)
320 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
321 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
322
323 %files c++-devel
324 %defattr(644,root,root,755)
325 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
326 %{_libdir}/libgnutlsxx.la
327 %{_includedir}/gnutls/gnutlsxx.h
328
329 %files c++-static
330 %defattr(644,root,root,755)
331 %{_libdir}/libgnutlsxx.a
332
333 %if %{with dane}
334 %files dane
335 %defattr(644,root,root,755)
336 %attr(755,root,root) %{_bindir}/danetool
337 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
338 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
339 %{_mandir}/man1/danetool.1*
340
341 %files dane-devel
342 %defattr(644,root,root,755)
343 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
344 %{_libdir}/libgnutls-dane.la
345 %{_includedir}/gnutls/dane.h
346 %{_pkgconfigdir}/gnutls-dane.pc
347
348 %files dane-static
349 %defattr(644,root,root,755)
350 %{_libdir}/libgnutls-dane.a
351 %endif
352
353 %files -n guile-gnutls
354 %defattr(644,root,root,755)
355 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
356 %{_datadir}/guile/site/gnutls.scm
357 %{_datadir}/guile/site/gnutls
358 %{_infodir}/gnutls-guile.info*
This page took 0.087665 seconds and 4 git commands to generate.