]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
- updated to 3.2.0 (3.1.x left on gnutls-3.1 branch)
[packages/gnutls.git] / gnutls.spec
1 #
2 # Conditional build:
3 %bcond_with     gcrypt  # use gcrypt crypto backend instead of nettle (withdrawn?)
4 %bcond_without  dane    # libdane (DANE with DNSSEC certificate verification)
5 %bcond_with     tpm     # TPM support in gnutls (cannot be used with GPL programs)
6 #
7 Summary:        The GNU Transport Layer Security Library
8 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
9 Name:           gnutls
10 Version:        3.2.0
11 Release:        1
12 License:        LGPL v3+ (libgnutls), GPL v3+ (openssl library and tools)
13 Group:          Libraries
14 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.2/%{name}-%{version}.tar.lz
15 # Source0-md5:  746cacdc1a1f64b74699109dad4ce47a
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-link.patch
18 Patch2:         %{name}-pl.po-update.patch
19 URL:            http://www.gnutls.org/
20 BuildRequires:  autoconf >= 2.61
21 BuildRequires:  automake >= 1:1.11.3
22 BuildRequires:  gettext-devel >= 0.18
23 BuildRequires:  gtk-doc >= 1.1
24 BuildRequires:  guile-devel >= 5:2.0
25 BuildRequires:  libcfg+-devel
26 %{?with_gcrypt:BuildRequires:   libgcrypt-devel >= 1.4.0}
27 BuildRequires:  libidn-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtasn1-devel >= 2.14
30 BuildRequires:  libtool >= 2:1.5
31 BuildRequires:  lzip
32 %{!?with_gcrypt:BuildRequires:  nettle-devel >= 2.7}
33 # miniopencdk is included in sources and currently maintained
34 # as part of gnutls, not external package
35 #BuildRequires: opencdk-devel >= 0.6.6
36 BuildRequires:  p11-kit-devel >= 0.11
37 BuildRequires:  pkgconfig
38 BuildRequires:  readline-devel
39 BuildRequires:  rpmbuild(macros) >= 1.383
40 BuildRequires:  sed >= 4.0
41 BuildRequires:  tar >= 1:1.22
42 BuildRequires:  texinfo >= 4.8
43 %{?with_tpm:BuildRequires:      trousers-devel}
44 %{?with_dane:BuildRequires:     unbound-devel}
45 BuildRequires:  zlib-devel
46 Requires(post,postun):  /sbin/ldconfig
47 %{?with_gcrypt:Requires:        libgcrypt >= 1.4.0}
48 Requires:       libtasn1 >= 2.14
49 %{!?with_gcrypt:Requires:       nettle >= 2.7}
50 #Requires:      opencdk >= 0.6.6
51 Requires:       p11-kit >= 0.11
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 GnuTLS is a project that aims to develop a library which provides a
56 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
57 the gnuTLS library implements the proposed standards by the IETF's TLS
58 working group.
59
60 %description -l pl.UTF-8
61 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
62 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
63 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
64 grupę roboczą IETF TLS.
65
66 %package devel
67 Summary:        Header files etc to develop gnutls applications
68 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
69 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 %{?with_gcrypt:Requires:        libgcrypt-devel >= 1.4.0}
73 Requires:       libtasn1-devel >= 2.14
74 %{!?with_gcrypt:Requires:       nettle-devel >= 2.7}
75 #Requires:      opencdk-devel >= 0.6.6
76 Requires:       p11-kit-devel >= 0.11
77 %{?with_tpm:Requires:   trousers-devel}
78 Requires:       zlib-devel
79
80 %description devel
81 Header files etc to develop gnutls applications.
82
83 %description devel -l pl.UTF-8
84 Pliki nagłówkowe i inne do gnutls.
85
86 %package static
87 Summary:        Static gnutls library
88 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
89 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Static gnutls library.
95
96 %description static -l pl.UTF-8
97 Biblioteka statyczna gnutls.
98
99 %package c++
100 Summary:        libgnutlsxx - C++ interface to gnutls library
101 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
102 License:        LGPL v2.1+
103 Group:          Libraries
104 Requires:       %{name} = %{version}-%{release}
105
106 %description c++
107 libgnutlsxx - C++ interface to gnutls library.
108
109 %description c++ -l pl.UTF-8
110 libgnutlsxx - interfejs C++ do biblioteki gnutls.
111
112 %package c++-devel
113 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
114 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
115 License:        LGPL v2.1+
116 Group:          Development/Libraries
117 Requires:       %{name}-c++ = %{version}-%{release}
118 Requires:       %{name}-devel = %{version}-%{release}
119 Requires:       libstdc++-devel
120
121 %description c++-devel
122 Header files for libgnutlsxx, a C++ interface to gnutls library.
123
124 %description c++-devel -l pl.UTF-8
125 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
126
127 %package c++-static
128 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
129 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
130 License:        LGPL v2.1+
131 Group:          Development/Libraries
132 Requires:       %{name}-c++-devel = %{version}-%{release}
133
134 %description c++-static
135 Static version of libgnutlsxx, a C++ interface to gnutls library.
136
137 %description c++-static -l pl.UTF-8
138 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
139
140 %package dane
141 Summary:        DANE security library
142 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
143 Group:          Libraries
144 Requires:       %{name} = %{version}-%{release}
145
146 %description dane
147 DANE security library.
148
149 %description dane -l pl.UTF-8
150 Biblioteka bezpieczeństwa DANE.
151
152 %package dane-devel
153 Summary:        Header file for DANE security library
154 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
155 Group:          Development/Libraries
156 Requires:       %{name}-dane = %{version}-%{release}
157 Requires:       %{name}-devel = %{version}-%{release}
158 Requires:       unbound-devel
159
160 %description dane-devel
161 Header file for DANE security library.
162
163 %description dane-devel -l pl.UTF-8
164 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
165
166 %package dane-static
167 Summary:        Static DANE security library
168 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
169 Group:          Development/Libraries
170 Requires:       %{name}-dane-devel = %{version}-%{release}
171
172 %description dane-static
173 Static DANE security library.
174
175 %description dane-static -l pl.UTF-8
176 Statyczna biblioteka bezpieczeństwa DANE.
177
178 %package -n guile-gnutls
179 Summary:        Guile bindings for GnuTLS
180 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
181 License:        LGPL v2.1+
182 Group:          Development/Languages
183 Requires:       %{name} = %{version}-%{release}
184 Requires:       guile >= 5:2.0
185
186 %description -n guile-gnutls
187 Guile bindings for GnuTLS.
188
189 %description -n guile-gnutls -l pl.UTF-8
190 Wiązania Guile do GnuTLS.
191
192 %prep
193 %setup -q
194 %patch0 -p1
195 %patch1 -p1
196 %patch2 -p1
197
198 %{__rm} po/stamp-po
199
200 # remove it when "linking libtool libraries using a non-POSIX archiver ..." warning is gone
201 # (after gnutls or libtool change)
202 %{__sed} -i -e '/AM_INIT_AUTOMAKE/s/-Werror//' configure.ac
203
204 %build
205 %{__libtoolize}
206 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4
207 %{__autoconf}
208 %{__autoheader}
209 %{__automake}
210 %configure \
211         --disable-silent-rules \
212         --enable-heartbeat-support \
213         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
214         %{?with_gcrypt:--with-libgcrypt} \
215         %{?with_tpm:--with-tpm}
216
217 # docs build is broken with -jN
218 %{__make} -j1
219
220 %install
221 rm -rf $RPM_BUILD_ROOT
222
223 %{__make} install \
224         DESTDIR=$RPM_BUILD_ROOT
225
226 # although libgnutls.la is obsoleted by pkg-config, there is
227 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
228
229 # guile module - dynamic only
230 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.{la,a}
231
232 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
233
234 %find_lang %{name}
235
236 %clean
237 rm -rf $RPM_BUILD_ROOT
238
239 %post
240 /sbin/ldconfig
241 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
242
243 %postun
244 /sbin/ldconfig
245 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
246
247 %post   c++ -p /sbin/ldconfig
248 %postun c++ -p /sbin/ldconfig
249
250 %post   -n guile-gnutls -p /sbin/ldconfig
251 %postun -n guile-gnutls -p /sbin/ldconfig
252
253 %files -f %{name}.lang
254 %defattr(644,root,root,755)
255 %doc AUTHORS ChangeLog NEWS README THANKS
256 %attr(755,root,root) %{_bindir}/certtool
257 %attr(755,root,root) %{_bindir}/crywrap
258 %attr(755,root,root) %{_bindir}/gnutls-*
259 %attr(755,root,root) %{_bindir}/ocsptool
260 %attr(755,root,root) %{_bindir}/p11tool
261 %attr(755,root,root) %{_bindir}/psktool
262 %attr(755,root,root) %{_bindir}/srptool
263 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
264 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
265 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.28
266 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
267 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
268 %attr(755,root,root) %{_libdir}/libgnutls-xssl.so.*.*.*
269 %attr(755,root,root) %ghost %{_libdir}/libgnutls-xssl.so.0
270 %{_mandir}/man1/certtool.1*
271 %{_mandir}/man1/gnutls-*.1*
272 %{_mandir}/man1/ocsptool.1*
273 %{_mandir}/man1/p11tool.1*
274 %{_mandir}/man1/psktool.1*
275 %{_mandir}/man1/srptool.1*
276 %{_mandir}/man1/tpmtool.1*
277 %{_infodir}/gnutls.info*
278 %{_infodir}/gnutls-*.png
279 %{_infodir}/pkcs11-vision.png
280
281 %files devel
282 %defattr(644,root,root,755)
283 %attr(755,root,root) %{_libdir}/libgnutls.so
284 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
285 %attr(755,root,root) %{_libdir}/libgnutls-xssl.so
286 %{_libdir}/libgnutls.la
287 %{_libdir}/libgnutls-openssl.la
288 %{_libdir}/libgnutls-xssl.la
289 %{_includedir}/gnutls
290 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
291 %exclude %{_includedir}/gnutls/gnutlsxx.h
292 %{_pkgconfigdir}/gnutls.pc
293 %{_mandir}/man3/gnutls_*.3*
294
295 %files static
296 %defattr(644,root,root,755)
297 %{_libdir}/libgnutls.a
298 %{_libdir}/libgnutls-openssl.a
299 %{_libdir}/libgnutls-xssl.a
300
301 %files c++
302 %defattr(644,root,root,755)
303 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
304 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
305
306 %files c++-devel
307 %defattr(644,root,root,755)
308 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
309 %{_libdir}/libgnutlsxx.la
310 %{_includedir}/gnutls/gnutlsxx.h
311
312 %files c++-static
313 %defattr(644,root,root,755)
314 %{_libdir}/libgnutlsxx.a
315
316 %if %{with dane}
317 %files dane
318 %defattr(644,root,root,755)
319 %attr(755,root,root) %{_bindir}/danetool
320 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
321 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
322 %{_mandir}/man1/danetool.1*
323
324 %files dane-devel
325 %defattr(644,root,root,755)
326 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
327 %{_libdir}/libgnutls-dane.la
328 %{_includedir}/gnutls/dane.h
329 %{_pkgconfigdir}/gnutls-dane.pc
330
331 %files dane-static
332 %defattr(644,root,root,755)
333 %{_libdir}/libgnutls-dane.a
334 %endif
335
336 %files -n guile-gnutls
337 %defattr(644,root,root,755)
338 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
339 %{_datadir}/guile/site/gnutls.scm
340 %{_datadir}/guile/site/gnutls
341 %{_infodir}/gnutls-guile.info*
This page took 0.057035 seconds and 4 git commands to generate.