]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
- separated openssl compatibility library
[packages/gnutls.git] / gnutls.spec
1 # NOTE: 3.3.x is previous-stable line
2 # - for 3.5.x (current stable) see DEVEL branch (requires DEVEL p11-kit)
3 #
4 # Conditional build:
5 %bcond_without  dane            # libdane (DANE with DNSSEC certificate verification)
6 %bcond_without  openssl         # libgnutls-openssl compatibility library
7 %bcond_without  tpm             # TPM support in gnutls
8 %bcond_without  static_libs     # static libraries
9 %bcond_without  doc             # do not generate documentation
10 #
11 Summary:        The GNU Transport Layer Security Library
12 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
13 Name:           gnutls
14 Version:        3.4.0
15 Release:        1
16 License:        LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
17 Group:          Libraries
18 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.4/%{name}-%{version}.tar.lz
19 # Source0-md5:  604362fb57bae7e6deba63c4e4a07a69
20 Patch0:         %{name}-info.patch
21 Patch1:         %{name}-link.patch
22 Patch2:         %{name}-install.patch
23 URL:            http://www.gnutls.org/
24 BuildRequires:  autoconf >= 2.61
25 BuildRequires:  autogen
26 BuildRequires:  autogen-devel
27 BuildRequires:  automake >= 1:1.12.2
28 BuildRequires:  gettext-tools >= 0.18
29 BuildRequires:  gmp-devel
30 %{?with_doc:BuildRequires:      gtk-doc >= 1.1}
31 BuildRequires:  guile-devel >= 5:2.0
32 BuildRequires:  libcfg+-devel
33 BuildRequires:  libidn-devel >= 0.5.6
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  libtasn1-devel >= 4.3
36 BuildRequires:  libtool >= 2:2
37 BuildRequires:  lzip
38 BuildRequires:  nettle-devel >= 3.1
39 # miniopencdk is included in sources and currently maintained
40 # as part of gnutls, not external package
41 #BuildRequires: opencdk-devel >= 0.6.6
42 BuildRequires:  p11-kit-devel >= 0.23.1
43 BuildRequires:  pkgconfig
44 BuildRequires:  readline-devel
45 BuildRequires:  rpmbuild(macros) >= 1.383
46 BuildRequires:  sed >= 4.0
47 BuildRequires:  tar >= 1:1.22
48 %{?with_doc:BuildRequires:      texinfo >= 4.8}
49 %{?with_tpm:BuildRequires:      trousers-devel >= 0.3.11}
50 %{?with_dane:BuildRequires:     unbound-devel}
51 BuildRequires:  xz
52 BuildRequires:  zlib-devel
53 Requires:       %{name}-libs = %{version}-%{release}
54 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 GnuTLS is a project that aims to develop a library which provides a
59 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
60 the gnuTLS library implements the proposed standards by the IETF's TLS
61 working group.
62
63 %description -l pl.UTF-8
64 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
65 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
66 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
67 grupę roboczą IETF TLS.
68
69 %package libs
70 Summary:        GnuTLS shared libraries
71 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
72 Group:          Libraries
73 Requires:       libidn >= 0.5.6
74 Requires:       libtasn1 >= 4.3
75 Requires:       nettle >= 3.1
76 #Requires:      opencdk >= 0.6.6
77 Requires:       p11-kit >= 0.23.1
78 %{?with_tpm:Requires:   trousers-libs >= 0.3.11}
79 Conflicts:      gnutls < 3.2.0
80
81 %description libs
82 GnuTLS shared libraries.
83
84 %description libs -l pl.UTF-8
85 Biblioteki współdzielone GnuTLS.
86
87 %package devel
88 Summary:        Header files etc to develop gnutls applications
89 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
90 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
91 Group:          Development/Libraries
92 Requires:       %{name}-libs = %{version}-%{release}
93 Requires:       libidn-devel >= 0.5.6
94 Requires:       libtasn1-devel >= 4.3
95 Requires:       nettle-devel >= 3.1
96 #Requires:      opencdk-devel >= 0.6.6
97 Requires:       p11-kit-devel >= 0.23.1
98 %{?with_tpm:Requires:   trousers-devel >= 0.3.11}
99 Requires:       zlib-devel
100
101 %description devel
102 Header files etc to develop gnutls applications.
103
104 %description devel -l pl.UTF-8
105 Pliki nagłówkowe i inne do gnutls.
106
107 %package static
108 Summary:        Static gnutls library
109 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
110 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
111 Group:          Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113
114 %description static
115 Static gnutls library.
116
117 %description static -l pl.UTF-8
118 Biblioteka statyczna gnutls.
119
120 %package c++
121 Summary:        libgnutlsxx - C++ interface to gnutls library
122 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
123 License:        LGPL v2.1+
124 Group:          Libraries
125 Requires:       %{name}-libs = %{version}-%{release}
126
127 %description c++
128 libgnutlsxx - C++ interface to gnutls library.
129
130 %description c++ -l pl.UTF-8
131 libgnutlsxx - interfejs C++ do biblioteki gnutls.
132
133 %package c++-devel
134 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
135 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
136 License:        LGPL v2.1+
137 Group:          Development/Libraries
138 Requires:       %{name}-c++ = %{version}-%{release}
139 Requires:       %{name}-devel = %{version}-%{release}
140 Requires:       libstdc++-devel
141
142 %description c++-devel
143 Header files for libgnutlsxx, a C++ interface to gnutls library.
144
145 %description c++-devel -l pl.UTF-8
146 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
147
148 %package c++-static
149 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
150 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
151 License:        LGPL v2.1+
152 Group:          Development/Libraries
153 Requires:       %{name}-c++-devel = %{version}-%{release}
154
155 %description c++-static
156 Static version of libgnutlsxx, a C++ interface to gnutls library.
157
158 %description c++-static -l pl.UTF-8
159 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
160
161 %package dane
162 Summary:        DANE security library
163 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
164 Group:          Libraries
165 Requires:       %{name}-libs = %{version}-%{release}
166
167 %description dane
168 DANE security library.
169
170 %description dane -l pl.UTF-8
171 Biblioteka bezpieczeństwa DANE.
172
173 %package dane-devel
174 Summary:        Header file for DANE security library
175 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
176 Group:          Development/Libraries
177 Requires:       %{name}-dane = %{version}-%{release}
178 Requires:       %{name}-devel = %{version}-%{release}
179 Requires:       unbound-devel
180
181 %description dane-devel
182 Header file for DANE security library.
183
184 %description dane-devel -l pl.UTF-8
185 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
186
187 %package dane-static
188 Summary:        Static DANE security library
189 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
190 Group:          Development/Libraries
191 Requires:       %{name}-dane-devel = %{version}-%{release}
192
193 %description dane-static
194 Static DANE security library.
195
196 %description dane-static -l pl.UTF-8
197 Statyczna biblioteka bezpieczeństwa DANE.
198
199 %package openssl
200 Summary:        OpenSSL compatibility library for GnuTLS
201 Summary(pl.UTF-8):      Biblioteka zgodności z OpenSSL dla GnuTLS
202 Group:          Libraries
203 Requires:       %{name}-libs = %{version}-%{release}
204
205 %description openssl
206 OpenSSL compatibility library for GnuTLS.
207
208 %description openssl -l pl.UTF-8
209 Biblioteka zgodności z OpenSSL dla GnuTLS.
210
211 %package openssl-devel
212 Summary:        Header file for gnutls-openssl library
213 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki gnutls-openssl
214 Group:          Development/Libraries
215 Requires:       %{name}-devel = %{version}-%{release}
216 Requires:       %{name}-openssl = %{version}-%{release}
217
218 %description openssl-devel
219 Header file for gnutls-openssl library.
220
221 %description openssl-devel -l pl.UTF-8
222 Plik nagłówkowy biblioteki gnutls-openssl.
223
224 %package openssl-static
225 Summary:        Static gnutls-openssl library
226 Summary(pl.UTF-8):      Statyczna biblioteka gnutls-openssl
227 Group:          Development/Libraries
228 Requires:       %{name}-openssl-devel = %{version}-%{release}
229
230 %description openssl-static
231 Static gnutls-openssl library.
232
233 %description openssl-static -l pl.UTF-8
234 Statyczna biblioteka gnutls-openssl.
235
236 %package -n guile-gnutls
237 Summary:        Guile bindings for GnuTLS
238 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
239 License:        LGPL v2.1+
240 Group:          Development/Languages
241 Requires:       %{name}-libs = %{version}-%{release}
242 Requires:       guile >= 5:2.0
243
244 %description -n guile-gnutls
245 Guile bindings for GnuTLS.
246
247 %description -n guile-gnutls -l pl.UTF-8
248 Wiązania Guile do GnuTLS.
249
250 %prep
251 %setup -q
252 %patch0 -p1
253 %patch1 -p1
254 %patch2 -p1
255
256 %{__rm} po/stamp-po
257
258 %build
259 %{__mv} build-aux/snippet{,.save}
260 %{__libtoolize}
261 %{__mv} build-aux/snippet{.save,}
262 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4 -I src/gl/m4
263 %{__autoconf}
264 %{__autoheader}
265 %{__automake}
266 %configure \
267         %{?with_openssl:--enable-openssl-compatibility} \
268         --disable-silent-rules \
269         %{?with_static_libs:--enable-static} \
270         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
271         %{!?with_tpm:--without-tpm} \
272         --with-trousers-lib=%{_libdir}/libtspi.so.1 \
273         %{!?with_doc:--disable-doc}
274
275 # docs build is broken with -jN
276 %{__make} -j1
277
278 %install
279 rm -rf $RPM_BUILD_ROOT
280
281 %{__make} install \
282         DESTDIR=$RPM_BUILD_ROOT
283
284 # although libgnutls.la is obsoleted by pkg-config, there is
285 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
286
287 # guile module - dynamic only
288 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.la
289 %if %{with static_libs}
290 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.a
291 %endif
292
293 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
294
295 %find_lang %{name}
296
297 %clean
298 rm -rf $RPM_BUILD_ROOT
299
300 %post
301 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
302
303 %postun
304 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
305
306 %post   libs -p /sbin/ldconfig
307 %postun libs -p /sbin/ldconfig
308
309 %post   c++ -p /sbin/ldconfig
310 %postun c++ -p /sbin/ldconfig
311
312 %post   dane -p /sbin/ldconfig
313 %postun dane -p /sbin/ldconfig
314
315 %post   openssl -p /sbin/ldconfig
316 %postun openssl -p /sbin/ldconfig
317
318 %post   -n guile-gnutls -p /sbin/ldconfig
319 %postun -n guile-gnutls -p /sbin/ldconfig
320
321 %files -f %{name}.lang
322 %defattr(644,root,root,755)
323 %doc AUTHORS ChangeLog NEWS README THANKS
324 %attr(755,root,root) %{_bindir}/certtool
325 %attr(755,root,root) %{_bindir}/crywrap
326 %attr(755,root,root) %{_bindir}/gnutls-*
327 %attr(755,root,root) %{_bindir}/ocsptool
328 %attr(755,root,root) %{_bindir}/p11tool
329 %attr(755,root,root) %{_bindir}/psktool
330 %attr(755,root,root) %{_bindir}/srptool
331 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
332 %if %{with doc}
333 %{_mandir}/man1/certtool.1*
334 %{_mandir}/man1/gnutls-*.1*
335 %{_mandir}/man1/ocsptool.1*
336 %{_mandir}/man1/p11tool.1*
337 %{_mandir}/man1/psktool.1*
338 %{_mandir}/man1/srptool.1*
339 %{_mandir}/man1/tpmtool.1*
340 %{_infodir}/gnutls.info*
341 %{_infodir}/gnutls-*.png
342 %{_infodir}/pkcs11-vision.png
343 %endif
344
345 %files libs
346 %defattr(644,root,root,755)
347 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
348 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.30
349
350 %files devel
351 %defattr(644,root,root,755)
352 %attr(755,root,root) %{_libdir}/libgnutls.so
353 %{_libdir}/libgnutls.la
354 %{_includedir}/gnutls
355 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
356 %exclude %{_includedir}/gnutls/gnutlsxx.h
357 %{?with_openssl:%exclude %{_includedir}/gnutls/openssl.h}
358 %{_pkgconfigdir}/gnutls.pc
359 %{?with_doc:%{_mandir}/man3/gnutls_*.3*}
360
361 %if %{with static_libs}
362 %files static
363 %defattr(644,root,root,755)
364 %{_libdir}/libgnutls.a
365 %endif
366
367 %files c++
368 %defattr(644,root,root,755)
369 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
370 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
371
372 %files c++-devel
373 %defattr(644,root,root,755)
374 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
375 %{_libdir}/libgnutlsxx.la
376 %{_includedir}/gnutls/gnutlsxx.h
377
378 %if %{with static_libs}
379 %files c++-static
380 %defattr(644,root,root,755)
381 %{_libdir}/libgnutlsxx.a
382 %endif
383
384 %if %{with dane}
385 %files dane
386 %defattr(644,root,root,755)
387 %attr(755,root,root) %{_bindir}/danetool
388 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
389 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
390 %{?with_doc:%{_mandir}/man1/danetool.1*}
391
392 %files dane-devel
393 %defattr(644,root,root,755)
394 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
395 %{_libdir}/libgnutls-dane.la
396 %{_includedir}/gnutls/dane.h
397 %{_pkgconfigdir}/gnutls-dane.pc
398
399 %if %{with static_libs}
400 %files dane-static
401 %defattr(644,root,root,755)
402 %{_libdir}/libgnutls-dane.a
403 %endif
404 %endif
405
406 %if %{with openssl}
407 %files openssl
408 %defattr(644,root,root,755)
409 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
410 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
411
412 %files openssl-devel
413 %defattr(644,root,root,755)
414 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
415 %{_libdir}/libgnutls-openssl.la
416 %{_includedir}/gnutls/openssl.h
417
418 %files openssl-static
419 %defattr(644,root,root,755)
420 %{_libdir}/libgnutls-openssl.a
421 %endif
422
423 %files -n guile-gnutls
424 %defattr(644,root,root,755)
425 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
426 %{_datadir}/guile/site/gnutls.scm
427 %{_datadir}/guile/site/gnutls
428 %{?with_doc:%{_infodir}/gnutls-guile.info*}
This page took 0.056053 seconds and 4 git commands to generate.