]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
- pass --with-trousers-lib to fix build on x32; release 2
[packages/gnutls.git] / gnutls.spec
1 # NOTE: 3.3.x is previous-stable line
2 # - for 3.5.x (current stable) see DEVEL branch (requires DEVEL p11-kit)
3 #
4 # Conditional build:
5 %bcond_without  dane            # libdane (DANE with DNSSEC certificate verification)
6 %bcond_without  openssl         # libgnutls-openssl compatibility library
7 %bcond_without  tpm             # TPM support in gnutls
8 %bcond_without  static_libs     # static libraries
9 %bcond_without  doc             # do not generate documentation
10 #
11 Summary:        The GNU Transport Layer Security Library
12 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
13 Name:           gnutls
14 Version:        3.3.26
15 Release:        2
16 License:        LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
17 Group:          Libraries
18 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/%{name}-%{version}.tar.xz
19 # Source0-md5:  9840c06019bfa7db07ed8fd5e63106d5
20 Patch0:         %{name}-info.patch
21 Patch1:         %{name}-link.patch
22 URL:            http://www.gnutls.org/
23 BuildRequires:  autoconf >= 2.61
24 BuildRequires:  autogen
25 BuildRequires:  autogen-devel
26 BuildRequires:  automake >= 1:1.12.2
27 BuildRequires:  gettext-tools >= 0.18
28 BuildRequires:  gmp-devel
29 %{?with_doc:BuildRequires:      gtk-doc >= 1.1}
30 BuildRequires:  guile-devel >= 5:2.0
31 BuildRequires:  libcfg+-devel
32 BuildRequires:  libidn-devel
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtasn1-devel >= 3.9
35 BuildRequires:  libtool >= 2:2
36 BuildRequires:  nettle-devel >= 2.7.1
37 # miniopencdk is included in sources and currently maintained
38 # as part of gnutls, not external package
39 #BuildRequires: opencdk-devel >= 0.6.6
40 BuildRequires:  p11-kit-devel >= 0.20.7
41 BuildRequires:  pkgconfig
42 BuildRequires:  readline-devel
43 BuildRequires:  rpmbuild(macros) >= 1.383
44 BuildRequires:  sed >= 4.0
45 BuildRequires:  tar >= 1:1.22
46 %{?with_doc:BuildRequires:      texinfo >= 4.8}
47 %{?with_tpm:BuildRequires:      trousers-devel >= 0.3.11}
48 %{?with_dane:BuildRequires:     unbound-devel}
49 BuildRequires:  xz
50 BuildRequires:  zlib-devel
51 Requires:       %{name}-libs = %{version}-%{release}
52 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 GnuTLS is a project that aims to develop a library which provides a
57 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
58 the gnuTLS library implements the proposed standards by the IETF's TLS
59 working group.
60
61 %description -l pl.UTF-8
62 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
63 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
64 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
65 grupę roboczą IETF TLS.
66
67 %package libs
68 Summary:        GnuTLS shared libraries
69 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
70 Group:          Libraries
71 Requires:       libtasn1 >= 3.9
72 Requires:       nettle >= 2.7.1
73 #Requires:      opencdk >= 0.6.6
74 Requires:       p11-kit >= 0.20.7
75 %{?with_tpm:Requires:   trousers-libs >= 0.3.11}
76 Conflicts:      gnutls < 3.2.0
77
78 %description libs
79 GnuTLS shared libraries.
80
81 %description libs -l pl.UTF-8
82 Biblioteki współdzielone GnuTLS.
83
84 %package devel
85 Summary:        Header files etc to develop gnutls applications
86 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
87 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
88 Group:          Development/Libraries
89 Requires:       %{name}-libs = %{version}-%{release}
90 Requires:       libtasn1-devel >= 3.9
91 Requires:       nettle-devel >= 2.7.1
92 #Requires:      opencdk-devel >= 0.6.6
93 Requires:       p11-kit-devel >= 0.20.7
94 %{?with_tpm:Requires:   trousers-devel >= 0.3.11}
95 Requires:       zlib-devel
96
97 %description devel
98 Header files etc to develop gnutls applications.
99
100 %description devel -l pl.UTF-8
101 Pliki nagłówkowe i inne do gnutls.
102
103 %package static
104 Summary:        Static gnutls library
105 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
106 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109
110 %description static
111 Static gnutls library.
112
113 %description static -l pl.UTF-8
114 Biblioteka statyczna gnutls.
115
116 %package c++
117 Summary:        libgnutlsxx - C++ interface to gnutls library
118 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
119 License:        LGPL v2.1+
120 Group:          Libraries
121 Requires:       %{name}-libs = %{version}-%{release}
122
123 %description c++
124 libgnutlsxx - C++ interface to gnutls library.
125
126 %description c++ -l pl.UTF-8
127 libgnutlsxx - interfejs C++ do biblioteki gnutls.
128
129 %package c++-devel
130 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
131 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
132 License:        LGPL v2.1+
133 Group:          Development/Libraries
134 Requires:       %{name}-c++ = %{version}-%{release}
135 Requires:       %{name}-devel = %{version}-%{release}
136 Requires:       libstdc++-devel
137
138 %description c++-devel
139 Header files for libgnutlsxx, a C++ interface to gnutls library.
140
141 %description c++-devel -l pl.UTF-8
142 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
143
144 %package c++-static
145 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
146 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
147 License:        LGPL v2.1+
148 Group:          Development/Libraries
149 Requires:       %{name}-c++-devel = %{version}-%{release}
150
151 %description c++-static
152 Static version of libgnutlsxx, a C++ interface to gnutls library.
153
154 %description c++-static -l pl.UTF-8
155 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
156
157 %package dane
158 Summary:        DANE security library
159 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
160 Group:          Libraries
161 Requires:       %{name}-libs = %{version}-%{release}
162
163 %description dane
164 DANE security library.
165
166 %description dane -l pl.UTF-8
167 Biblioteka bezpieczeństwa DANE.
168
169 %package dane-devel
170 Summary:        Header file for DANE security library
171 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
172 Group:          Development/Libraries
173 Requires:       %{name}-dane = %{version}-%{release}
174 Requires:       %{name}-devel = %{version}-%{release}
175 Requires:       unbound-devel
176
177 %description dane-devel
178 Header file for DANE security library.
179
180 %description dane-devel -l pl.UTF-8
181 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
182
183 %package dane-static
184 Summary:        Static DANE security library
185 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
186 Group:          Development/Libraries
187 Requires:       %{name}-dane-devel = %{version}-%{release}
188
189 %description dane-static
190 Static DANE security library.
191
192 %description dane-static -l pl.UTF-8
193 Statyczna biblioteka bezpieczeństwa DANE.
194
195 %package openssl
196 Summary:        OpenSSL compatibility library for GnuTLS
197 Summary(pl.UTF-8):      Biblioteka zgodności z OpenSSL dla GnuTLS
198 Group:          Libraries
199 Requires:       %{name}-libs = %{version}-%{release}
200
201 %description openssl
202 OpenSSL compatibility library for GnuTLS.
203
204 %description openssl -l pl.UTF-8
205 Biblioteka zgodności z OpenSSL dla GnuTLS.
206
207 %package openssl-devel
208 Summary:        Header file for gnutls-openssl library
209 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki gnutls-openssl
210 Group:          Development/Libraries
211 Requires:       %{name}-devel = %{version}-%{release}
212 Requires:       %{name}-openssl = %{version}-%{release}
213
214 %description openssl-devel
215 Header file for gnutls-openssl library.
216
217 %description openssl-devel -l pl.UTF-8
218 Plik nagłówkowy biblioteki gnutls-openssl.
219
220 %package openssl-static
221 Summary:        Static gnutls-openssl library
222 Summary(pl.UTF-8):      Statyczna biblioteka gnutls-openssl
223 Group:          Development/Libraries
224 Requires:       %{name}-openssl-devel = %{version}-%{release}
225
226 %description openssl-static
227 Static gnutls-openssl library.
228
229 %description openssl-static -l pl.UTF-8
230 Statyczna biblioteka gnutls-openssl.
231
232 %package -n guile-gnutls
233 Summary:        Guile bindings for GnuTLS
234 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
235 License:        LGPL v2.1+
236 Group:          Development/Languages
237 Requires:       %{name}-libs = %{version}-%{release}
238 Requires:       guile >= 5:2.0
239
240 %description -n guile-gnutls
241 Guile bindings for GnuTLS.
242
243 %description -n guile-gnutls -l pl.UTF-8
244 Wiązania Guile do GnuTLS.
245
246 %prep
247 %setup -q
248 %patch0 -p1
249 %patch1 -p1
250
251 %{__rm} po/stamp-po
252
253 %build
254 %{__mv} build-aux/snippet{,.save}
255 %{__libtoolize}
256 %{__mv} build-aux/snippet{.save,}
257 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4 -I src/gl/m4
258 %{__autoconf}
259 %{__autoheader}
260 %{__automake}
261 %configure \
262         %{!?with_openssl:--disable-openssl-compatibility} \
263         --disable-silent-rules \
264         %{?with_static_libs:--enable-static} \
265         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
266         %{!?with_tpm:--without-tpm} \
267         --with-trousers-lib=%{_libdir}/libtspi.so.1 \
268         %{!?with_doc:--disable-doc}
269
270 # docs build is broken with -jN
271 %{__make} -j1
272
273 %install
274 rm -rf $RPM_BUILD_ROOT
275
276 %{__make} install \
277         DESTDIR=$RPM_BUILD_ROOT
278
279 # although libgnutls.la is obsoleted by pkg-config, there is
280 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
281
282 # guile module - dynamic only
283 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.la
284 %if %{with static_libs}
285 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.a
286 %endif
287
288 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
289
290 %find_lang %{name}
291
292 %clean
293 rm -rf $RPM_BUILD_ROOT
294
295 %post
296 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
297
298 %postun
299 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
300
301 %post   libs -p /sbin/ldconfig
302 %postun libs -p /sbin/ldconfig
303
304 %post   c++ -p /sbin/ldconfig
305 %postun c++ -p /sbin/ldconfig
306
307 %post   dane -p /sbin/ldconfig
308 %postun dane -p /sbin/ldconfig
309
310 %post   openssl -p /sbin/ldconfig
311 %postun openssl -p /sbin/ldconfig
312
313 %post   -n guile-gnutls -p /sbin/ldconfig
314 %postun -n guile-gnutls -p /sbin/ldconfig
315
316 %files -f %{name}.lang
317 %defattr(644,root,root,755)
318 %doc AUTHORS ChangeLog NEWS README THANKS
319 %attr(755,root,root) %{_bindir}/certtool
320 %attr(755,root,root) %{_bindir}/crywrap
321 %attr(755,root,root) %{_bindir}/gnutls-*
322 %attr(755,root,root) %{_bindir}/ocsptool
323 %attr(755,root,root) %{_bindir}/p11tool
324 %attr(755,root,root) %{_bindir}/psktool
325 %attr(755,root,root) %{_bindir}/srptool
326 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
327 %if %{with doc}
328 %{_mandir}/man1/certtool.1*
329 %{_mandir}/man1/gnutls-*.1*
330 %{_mandir}/man1/ocsptool.1*
331 %{_mandir}/man1/p11tool.1*
332 %{_mandir}/man1/psktool.1*
333 %{_mandir}/man1/srptool.1*
334 %{_mandir}/man1/tpmtool.1*
335 %{_infodir}/gnutls.info*
336 %{_infodir}/gnutls-*.png
337 %{_infodir}/pkcs11-vision.png
338 %endif
339
340 %files libs
341 %defattr(644,root,root,755)
342 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
343 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.28
344
345 %files devel
346 %defattr(644,root,root,755)
347 %attr(755,root,root) %{_libdir}/libgnutls.so
348 %{_libdir}/libgnutls.la
349 %{_includedir}/gnutls
350 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
351 %exclude %{_includedir}/gnutls/gnutlsxx.h
352 %{?with_openssl:%exclude %{_includedir}/gnutls/openssl.h}
353 %{_pkgconfigdir}/gnutls.pc
354 %{?with_doc:%{_mandir}/man3/gnutls_*.3*}
355
356 %if %{with static_libs}
357 %files static
358 %defattr(644,root,root,755)
359 %{_libdir}/libgnutls.a
360 %endif
361
362 %files c++
363 %defattr(644,root,root,755)
364 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
365 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
366
367 %files c++-devel
368 %defattr(644,root,root,755)
369 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
370 %{_libdir}/libgnutlsxx.la
371 %{_includedir}/gnutls/gnutlsxx.h
372
373 %if %{with static_libs}
374 %files c++-static
375 %defattr(644,root,root,755)
376 %{_libdir}/libgnutlsxx.a
377 %endif
378
379 %if %{with dane}
380 %files dane
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_bindir}/danetool
383 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
384 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
385 %{?with_doc:%{_mandir}/man1/danetool.1*}
386
387 %files dane-devel
388 %defattr(644,root,root,755)
389 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
390 %{_libdir}/libgnutls-dane.la
391 %{_includedir}/gnutls/dane.h
392 %{_pkgconfigdir}/gnutls-dane.pc
393
394 %if %{with static_libs}
395 %files dane-static
396 %defattr(644,root,root,755)
397 %{_libdir}/libgnutls-dane.a
398 %endif
399 %endif
400
401 %if %{with openssl}
402 %files openssl
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
405 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
406
407 %files openssl-devel
408 %defattr(644,root,root,755)
409 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
410 %{_libdir}/libgnutls-openssl.la
411 %{_includedir}/gnutls/openssl.h
412
413 %files openssl-static
414 %defattr(644,root,root,755)
415 %{_libdir}/libgnutls-openssl.a
416 %endif
417
418 %files -n guile-gnutls
419 %defattr(644,root,root,755)
420 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
421 %{_datadir}/guile/site/gnutls.scm
422 %{_datadir}/guile/site/gnutls
423 %{?with_doc:%{_infodir}/gnutls-guile.info*}
This page took 0.085248 seconds and 4 git commands to generate.