]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
- -libs R: trousers-libs
[packages/gnutls.git] / gnutls.spec
1 #
2 # Conditional build:
3 %bcond_with     gcrypt  # use gcrypt crypto backend instead of nettle (withdrawn?)
4 %bcond_without  dane    # libdane (DANE with DNSSEC certificate verification)
5 %bcond_without  tpm     # TPM support in gnutls
6 #
7 Summary:        The GNU Transport Layer Security Library
8 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
9 Name:           gnutls
10 Version:        3.2.6
11 Release:        2
12 License:        LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
13 Group:          Libraries
14 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.2/%{name}-%{version}.tar.lz
15 # Source0-md5:  9195a4435892ef740b140325e56ae6bd
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-link.patch
18 URL:            http://www.gnutls.org/
19 BuildRequires:  autoconf >= 2.61
20 BuildRequires:  automake >= 1:1.12.2
21 BuildRequires:  gettext-devel >= 0.18
22 BuildRequires:  gtk-doc >= 1.1
23 BuildRequires:  guile-devel >= 5:2.0
24 BuildRequires:  libcfg+-devel
25 %{?with_gcrypt:BuildRequires:   libgcrypt-devel >= 1.4.0}
26 BuildRequires:  libidn-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtasn1-devel >= 2.14
29 BuildRequires:  libtool >= 2:1.5
30 BuildRequires:  lzip
31 %{!?with_gcrypt:BuildRequires:  nettle-devel >= 2.7}
32 # miniopencdk is included in sources and currently maintained
33 # as part of gnutls, not external package
34 #BuildRequires: opencdk-devel >= 0.6.6
35 BuildRequires:  p11-kit-devel >= 0.11
36 BuildRequires:  pkgconfig
37 BuildRequires:  readline-devel
38 BuildRequires:  rpmbuild(macros) >= 1.383
39 BuildRequires:  sed >= 4.0
40 BuildRequires:  tar >= 1:1.22
41 BuildRequires:  texinfo >= 4.8
42 %{?with_tpm:BuildRequires:      trousers-devel >= 0.3.11}
43 %{?with_dane:BuildRequires:     unbound-devel}
44 BuildRequires:  zlib-devel
45 Requires:       %{name}-libs = %{version}-%{release}
46 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 GnuTLS is a project that aims to develop a library which provides a
51 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
52 the gnuTLS library implements the proposed standards by the IETF's TLS
53 working group.
54
55 %description -l pl.UTF-8
56 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
57 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
58 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
59 grupę roboczą IETF TLS.
60
61 %package libs
62 Summary:        GnuTLS shared libraries
63 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
64 Group:          Libraries
65 %{?with_gcrypt:Requires:        libgcrypt >= 1.4.0}
66 Requires:       libtasn1 >= 2.14
67 %{!?with_gcrypt:Requires:       nettle >= 2.7}
68 #Requires:      opencdk >= 0.6.6
69 Requires:       p11-kit >= 0.11
70 %{?with_tpm:Requires:   trousers-libs >= 0.3.11}
71 Conflicts:      gnutls < 3.2.0
72
73 %description libs
74 GnuTLS shared libraries.
75
76 %description libs -l pl.UTF-8
77 Biblioteki współdzielone GnuTLS.
78
79 %package devel
80 Summary:        Header files etc to develop gnutls applications
81 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
82 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
83 Group:          Development/Libraries
84 Requires:       %{name}-libs = %{version}-%{release}
85 %{?with_gcrypt:Requires:        libgcrypt-devel >= 1.4.0}
86 Requires:       libtasn1-devel >= 2.14
87 %{!?with_gcrypt:Requires:       nettle-devel >= 2.7}
88 #Requires:      opencdk-devel >= 0.6.6
89 Requires:       p11-kit-devel >= 0.11
90 %{?with_tpm:Requires:   trousers-devel >= 0.3.11}
91 Requires:       zlib-devel
92
93 %description devel
94 Header files etc to develop gnutls applications.
95
96 %description devel -l pl.UTF-8
97 Pliki nagłówkowe i inne do gnutls.
98
99 %package static
100 Summary:        Static gnutls library
101 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
102 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
103 Group:          Development/Libraries
104 Requires:       %{name}-devel = %{version}-%{release}
105
106 %description static
107 Static gnutls library.
108
109 %description static -l pl.UTF-8
110 Biblioteka statyczna gnutls.
111
112 %package c++
113 Summary:        libgnutlsxx - C++ interface to gnutls library
114 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
115 License:        LGPL v2.1+
116 Group:          Libraries
117 Requires:       %{name}-libs = %{version}-%{release}
118
119 %description c++
120 libgnutlsxx - C++ interface to gnutls library.
121
122 %description c++ -l pl.UTF-8
123 libgnutlsxx - interfejs C++ do biblioteki gnutls.
124
125 %package c++-devel
126 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
127 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
128 License:        LGPL v2.1+
129 Group:          Development/Libraries
130 Requires:       %{name}-c++ = %{version}-%{release}
131 Requires:       %{name}-devel = %{version}-%{release}
132 Requires:       libstdc++-devel
133
134 %description c++-devel
135 Header files for libgnutlsxx, a C++ interface to gnutls library.
136
137 %description c++-devel -l pl.UTF-8
138 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
139
140 %package c++-static
141 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
142 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
143 License:        LGPL v2.1+
144 Group:          Development/Libraries
145 Requires:       %{name}-c++-devel = %{version}-%{release}
146
147 %description c++-static
148 Static version of libgnutlsxx, a C++ interface to gnutls library.
149
150 %description c++-static -l pl.UTF-8
151 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
152
153 %package dane
154 Summary:        DANE security library
155 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
156 Group:          Libraries
157 Requires:       %{name}-libs = %{version}-%{release}
158
159 %description dane
160 DANE security library.
161
162 %description dane -l pl.UTF-8
163 Biblioteka bezpieczeństwa DANE.
164
165 %package dane-devel
166 Summary:        Header file for DANE security library
167 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
168 Group:          Development/Libraries
169 Requires:       %{name}-dane = %{version}-%{release}
170 Requires:       %{name}-devel = %{version}-%{release}
171 Requires:       unbound-devel
172
173 %description dane-devel
174 Header file for DANE security library.
175
176 %description dane-devel -l pl.UTF-8
177 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
178
179 %package dane-static
180 Summary:        Static DANE security library
181 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
182 Group:          Development/Libraries
183 Requires:       %{name}-dane-devel = %{version}-%{release}
184
185 %description dane-static
186 Static DANE security library.
187
188 %description dane-static -l pl.UTF-8
189 Statyczna biblioteka bezpieczeństwa DANE.
190
191 %package -n guile-gnutls
192 Summary:        Guile bindings for GnuTLS
193 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
194 License:        LGPL v2.1+
195 Group:          Development/Languages
196 Requires:       %{name}-libs = %{version}-%{release}
197 Requires:       guile >= 5:2.0
198
199 %description -n guile-gnutls
200 Guile bindings for GnuTLS.
201
202 %description -n guile-gnutls -l pl.UTF-8
203 Wiązania Guile do GnuTLS.
204
205 %prep
206 %setup -q
207 %patch0 -p1
208 %patch1 -p1
209
210 %{__rm} po/stamp-po
211
212 # remove it when "linking libtool libraries using a non-POSIX archiver ..." warning is gone
213 # (after gnutls or libtool change)
214 %{__sed} -i -e '/AM_INIT_AUTOMAKE/s/-Werror//' configure.ac
215
216 %build
217 %{__libtoolize}
218 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4
219 %{__autoconf}
220 %{__autoheader}
221 %{__automake}
222 %configure \
223         --disable-silent-rules \
224         --enable-heartbeat-support \
225         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
226         %{?with_gcrypt:--with-libgcrypt} \
227         %{!?with_tpm:--without-tpm}
228
229 # docs build is broken with -jN
230 %{__make} -j1
231
232 %install
233 rm -rf $RPM_BUILD_ROOT
234
235 %{__make} install \
236         DESTDIR=$RPM_BUILD_ROOT
237
238 # although libgnutls.la is obsoleted by pkg-config, there is
239 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
240
241 # guile module - dynamic only
242 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.{la,a}
243
244 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
245
246 %find_lang %{name}
247
248 %clean
249 rm -rf $RPM_BUILD_ROOT
250
251 %post
252 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
253
254 %postun
255 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
256
257 %post   libs -p /sbin/ldconfig
258 %postun libs -p /sbin/ldconfig
259
260 %post   c++ -p /sbin/ldconfig
261 %postun c++ -p /sbin/ldconfig
262
263 %post   -n guile-gnutls -p /sbin/ldconfig
264 %postun -n guile-gnutls -p /sbin/ldconfig
265
266 %files -f %{name}.lang
267 %defattr(644,root,root,755)
268 %doc AUTHORS ChangeLog NEWS README THANKS
269 %attr(755,root,root) %{_bindir}/certtool
270 %attr(755,root,root) %{_bindir}/crywrap
271 %attr(755,root,root) %{_bindir}/gnutls-*
272 %attr(755,root,root) %{_bindir}/ocsptool
273 %attr(755,root,root) %{_bindir}/p11tool
274 %attr(755,root,root) %{_bindir}/psktool
275 %attr(755,root,root) %{_bindir}/srptool
276 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
277 %{_mandir}/man1/certtool.1*
278 %{_mandir}/man1/gnutls-*.1*
279 %{_mandir}/man1/ocsptool.1*
280 %{_mandir}/man1/p11tool.1*
281 %{_mandir}/man1/psktool.1*
282 %{_mandir}/man1/srptool.1*
283 %{_mandir}/man1/tpmtool.1*
284 %{_infodir}/gnutls.info*
285 %{_infodir}/gnutls-*.png
286 %{_infodir}/pkcs11-vision.png
287
288 %files libs
289 %defattr(644,root,root,755)
290 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
291 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.28
292 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
293 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
294 %attr(755,root,root) %{_libdir}/libgnutls-xssl.so.*.*.*
295 %attr(755,root,root) %ghost %{_libdir}/libgnutls-xssl.so.0
296
297 %files devel
298 %defattr(644,root,root,755)
299 %attr(755,root,root) %{_libdir}/libgnutls.so
300 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
301 %attr(755,root,root) %{_libdir}/libgnutls-xssl.so
302 %{_libdir}/libgnutls.la
303 %{_libdir}/libgnutls-openssl.la
304 %{_libdir}/libgnutls-xssl.la
305 %{_includedir}/gnutls
306 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
307 %exclude %{_includedir}/gnutls/gnutlsxx.h
308 %{_pkgconfigdir}/gnutls.pc
309 %{_mandir}/man3/gnutls_*.3*
310
311 %files static
312 %defattr(644,root,root,755)
313 %{_libdir}/libgnutls.a
314 %{_libdir}/libgnutls-openssl.a
315 %{_libdir}/libgnutls-xssl.a
316
317 %files c++
318 %defattr(644,root,root,755)
319 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
320 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
321
322 %files c++-devel
323 %defattr(644,root,root,755)
324 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
325 %{_libdir}/libgnutlsxx.la
326 %{_includedir}/gnutls/gnutlsxx.h
327
328 %files c++-static
329 %defattr(644,root,root,755)
330 %{_libdir}/libgnutlsxx.a
331
332 %if %{with dane}
333 %files dane
334 %defattr(644,root,root,755)
335 %attr(755,root,root) %{_bindir}/danetool
336 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
337 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
338 %{_mandir}/man1/danetool.1*
339
340 %files dane-devel
341 %defattr(644,root,root,755)
342 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
343 %{_libdir}/libgnutls-dane.la
344 %{_includedir}/gnutls/dane.h
345 %{_pkgconfigdir}/gnutls-dane.pc
346
347 %files dane-static
348 %defattr(644,root,root,755)
349 %{_libdir}/libgnutls-dane.a
350 %endif
351
352 %files -n guile-gnutls
353 %defattr(644,root,root,755)
354 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
355 %{_datadir}/guile/site/gnutls.scm
356 %{_datadir}/guile/site/gnutls
357 %{_infodir}/gnutls-guile.info*
This page took 0.04978 seconds and 4 git commands to generate.