]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
- updated to 3.2.8.1
[packages/gnutls.git] / gnutls.spec
1 #
2 # Conditional build:
3 %bcond_with     gcrypt  # use gcrypt crypto backend instead of nettle (withdrawn?)
4 %bcond_without  dane    # libdane (DANE with DNSSEC certificate verification)
5 %bcond_without  tpm     # TPM support in gnutls
6 #
7 Summary:        The GNU Transport Layer Security Library
8 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
9 Name:           gnutls
10 Version:        3.2.8.1
11 Release:        1
12 License:        LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
13 Group:          Libraries
14 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.2/%{name}-%{version}.tar.lz
15 # Source0-md5:  7602bf9a5cc3fa1836d5c35cde38c815
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-link.patch
18 URL:            http://www.gnutls.org/
19 BuildRequires:  autoconf >= 2.61
20 BuildRequires:  automake >= 1:1.12.2
21 BuildRequires:  gettext-devel >= 0.18
22 BuildRequires:  gtk-doc >= 1.1
23 BuildRequires:  guile-devel >= 5:2.0
24 BuildRequires:  libcfg+-devel
25 %{?with_gcrypt:BuildRequires:   libgcrypt-devel >= 1.4.0}
26 BuildRequires:  libidn-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtasn1-devel >= 2.14
29 BuildRequires:  libtool >= 2:1.5
30 BuildRequires:  lzip
31 %{!?with_gcrypt:BuildRequires:  nettle-devel >= 2.7}
32 # miniopencdk is included in sources and currently maintained
33 # as part of gnutls, not external package
34 #BuildRequires: opencdk-devel >= 0.6.6
35 BuildRequires:  p11-kit-devel >= 0.11
36 BuildRequires:  pkgconfig
37 BuildRequires:  readline-devel
38 BuildRequires:  rpmbuild(macros) >= 1.383
39 BuildRequires:  sed >= 4.0
40 BuildRequires:  tar >= 1:1.22
41 BuildRequires:  texinfo >= 4.8
42 %{?with_tpm:BuildRequires:      trousers-devel >= 0.3.11}
43 %{?with_dane:BuildRequires:     unbound-devel}
44 BuildRequires:  zlib-devel
45 Requires:       %{name}-libs = %{version}-%{release}
46 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 GnuTLS is a project that aims to develop a library which provides a
51 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
52 the gnuTLS library implements the proposed standards by the IETF's TLS
53 working group.
54
55 %description -l pl.UTF-8
56 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
57 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
58 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
59 grupę roboczą IETF TLS.
60
61 %package libs
62 Summary:        GnuTLS shared libraries
63 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
64 Group:          Libraries
65 %{?with_gcrypt:Requires:        libgcrypt >= 1.4.0}
66 Requires:       libtasn1 >= 2.14
67 %{!?with_gcrypt:Requires:       nettle >= 2.7}
68 #Requires:      opencdk >= 0.6.6
69 Requires:       p11-kit >= 0.11
70 %{?with_tpm:Requires:   trousers-libs >= 0.3.11}
71 Conflicts:      gnutls < 3.2.0
72
73 %description libs
74 GnuTLS shared libraries.
75
76 %description libs -l pl.UTF-8
77 Biblioteki współdzielone GnuTLS.
78
79 %package devel
80 Summary:        Header files etc to develop gnutls applications
81 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
82 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
83 Group:          Development/Libraries
84 Requires:       %{name}-libs = %{version}-%{release}
85 %{?with_gcrypt:Requires:        libgcrypt-devel >= 1.4.0}
86 Requires:       libtasn1-devel >= 2.14
87 %{!?with_gcrypt:Requires:       nettle-devel >= 2.7}
88 #Requires:      opencdk-devel >= 0.6.6
89 Requires:       p11-kit-devel >= 0.11
90 %{?with_tpm:Requires:   trousers-devel >= 0.3.11}
91 Requires:       zlib-devel
92
93 %description devel
94 Header files etc to develop gnutls applications.
95
96 %description devel -l pl.UTF-8
97 Pliki nagłówkowe i inne do gnutls.
98
99 %package static
100 Summary:        Static gnutls library
101 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
102 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
103 Group:          Development/Libraries
104 Requires:       %{name}-devel = %{version}-%{release}
105
106 %description static
107 Static gnutls library.
108
109 %description static -l pl.UTF-8
110 Biblioteka statyczna gnutls.
111
112 %package c++
113 Summary:        libgnutlsxx - C++ interface to gnutls library
114 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
115 License:        LGPL v2.1+
116 Group:          Libraries
117 Requires:       %{name}-libs = %{version}-%{release}
118
119 %description c++
120 libgnutlsxx - C++ interface to gnutls library.
121
122 %description c++ -l pl.UTF-8
123 libgnutlsxx - interfejs C++ do biblioteki gnutls.
124
125 %package c++-devel
126 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
127 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
128 License:        LGPL v2.1+
129 Group:          Development/Libraries
130 Requires:       %{name}-c++ = %{version}-%{release}
131 Requires:       %{name}-devel = %{version}-%{release}
132 Requires:       libstdc++-devel
133
134 %description c++-devel
135 Header files for libgnutlsxx, a C++ interface to gnutls library.
136
137 %description c++-devel -l pl.UTF-8
138 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
139
140 %package c++-static
141 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
142 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
143 License:        LGPL v2.1+
144 Group:          Development/Libraries
145 Requires:       %{name}-c++-devel = %{version}-%{release}
146
147 %description c++-static
148 Static version of libgnutlsxx, a C++ interface to gnutls library.
149
150 %description c++-static -l pl.UTF-8
151 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
152
153 %package dane
154 Summary:        DANE security library
155 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
156 Group:          Libraries
157 Requires:       %{name}-libs = %{version}-%{release}
158
159 %description dane
160 DANE security library.
161
162 %description dane -l pl.UTF-8
163 Biblioteka bezpieczeństwa DANE.
164
165 %package dane-devel
166 Summary:        Header file for DANE security library
167 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
168 Group:          Development/Libraries
169 Requires:       %{name}-dane = %{version}-%{release}
170 Requires:       %{name}-devel = %{version}-%{release}
171 Requires:       unbound-devel
172
173 %description dane-devel
174 Header file for DANE security library.
175
176 %description dane-devel -l pl.UTF-8
177 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
178
179 %package dane-static
180 Summary:        Static DANE security library
181 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
182 Group:          Development/Libraries
183 Requires:       %{name}-dane-devel = %{version}-%{release}
184
185 %description dane-static
186 Static DANE security library.
187
188 %description dane-static -l pl.UTF-8
189 Statyczna biblioteka bezpieczeństwa DANE.
190
191 %package -n guile-gnutls
192 Summary:        Guile bindings for GnuTLS
193 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
194 License:        LGPL v2.1+
195 Group:          Development/Languages
196 Requires:       %{name}-libs = %{version}-%{release}
197 Requires:       guile >= 5:2.0
198
199 %description -n guile-gnutls
200 Guile bindings for GnuTLS.
201
202 %description -n guile-gnutls -l pl.UTF-8
203 Wiązania Guile do GnuTLS.
204
205 %prep
206 %setup -q -n %{name}-3.2.8
207 %patch0 -p1
208 %patch1 -p1
209
210 %{__rm} po/stamp-po
211
212 %build
213 %{__libtoolize}
214 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4
215 %{__autoconf}
216 %{__autoheader}
217 %{__automake}
218 %configure \
219         --disable-silent-rules \
220         --enable-heartbeat-support \
221         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
222         %{?with_gcrypt:--with-libgcrypt} \
223         %{!?with_tpm:--without-tpm}
224
225 # docs build is broken with -jN
226 %{__make} -j1
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230
231 %{__make} install \
232         DESTDIR=$RPM_BUILD_ROOT
233
234 # although libgnutls.la is obsoleted by pkg-config, there is
235 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
236
237 # guile module - dynamic only
238 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.{la,a}
239
240 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
241
242 %find_lang %{name}
243
244 %clean
245 rm -rf $RPM_BUILD_ROOT
246
247 %post
248 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
249
250 %postun
251 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
252
253 %post   libs -p /sbin/ldconfig
254 %postun libs -p /sbin/ldconfig
255
256 %post   c++ -p /sbin/ldconfig
257 %postun c++ -p /sbin/ldconfig
258
259 %post   -n guile-gnutls -p /sbin/ldconfig
260 %postun -n guile-gnutls -p /sbin/ldconfig
261
262 %files -f %{name}.lang
263 %defattr(644,root,root,755)
264 %doc AUTHORS ChangeLog NEWS README THANKS
265 %attr(755,root,root) %{_bindir}/certtool
266 %attr(755,root,root) %{_bindir}/crywrap
267 %attr(755,root,root) %{_bindir}/gnutls-*
268 %attr(755,root,root) %{_bindir}/ocsptool
269 %attr(755,root,root) %{_bindir}/p11tool
270 %attr(755,root,root) %{_bindir}/psktool
271 %attr(755,root,root) %{_bindir}/srptool
272 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
273 %{_mandir}/man1/certtool.1*
274 %{_mandir}/man1/gnutls-*.1*
275 %{_mandir}/man1/ocsptool.1*
276 %{_mandir}/man1/p11tool.1*
277 %{_mandir}/man1/psktool.1*
278 %{_mandir}/man1/srptool.1*
279 %{_mandir}/man1/tpmtool.1*
280 %{_infodir}/gnutls.info*
281 %{_infodir}/gnutls-*.png
282 %{_infodir}/pkcs11-vision.png
283
284 %files libs
285 %defattr(644,root,root,755)
286 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
287 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.28
288 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
289 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
290 %attr(755,root,root) %{_libdir}/libgnutls-xssl.so.*.*.*
291 %attr(755,root,root) %ghost %{_libdir}/libgnutls-xssl.so.0
292
293 %files devel
294 %defattr(644,root,root,755)
295 %attr(755,root,root) %{_libdir}/libgnutls.so
296 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
297 %attr(755,root,root) %{_libdir}/libgnutls-xssl.so
298 %{_libdir}/libgnutls.la
299 %{_libdir}/libgnutls-openssl.la
300 %{_libdir}/libgnutls-xssl.la
301 %{_includedir}/gnutls
302 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
303 %exclude %{_includedir}/gnutls/gnutlsxx.h
304 %{_pkgconfigdir}/gnutls.pc
305 %{_mandir}/man3/gnutls_*.3*
306 %{_mandir}/man3/xssl_*.3*
307
308 %files static
309 %defattr(644,root,root,755)
310 %{_libdir}/libgnutls.a
311 %{_libdir}/libgnutls-openssl.a
312 %{_libdir}/libgnutls-xssl.a
313
314 %files c++
315 %defattr(644,root,root,755)
316 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
317 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
318
319 %files c++-devel
320 %defattr(644,root,root,755)
321 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
322 %{_libdir}/libgnutlsxx.la
323 %{_includedir}/gnutls/gnutlsxx.h
324
325 %files c++-static
326 %defattr(644,root,root,755)
327 %{_libdir}/libgnutlsxx.a
328
329 %if %{with dane}
330 %files dane
331 %defattr(644,root,root,755)
332 %attr(755,root,root) %{_bindir}/danetool
333 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
334 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
335 %{_mandir}/man1/danetool.1*
336
337 %files dane-devel
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
340 %{_libdir}/libgnutls-dane.la
341 %{_includedir}/gnutls/dane.h
342 %{_pkgconfigdir}/gnutls-dane.pc
343
344 %files dane-static
345 %defattr(644,root,root,755)
346 %{_libdir}/libgnutls-dane.a
347 %endif
348
349 %files -n guile-gnutls
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
352 %{_datadir}/guile/site/gnutls.scm
353 %{_datadir}/guile/site/gnutls
354 %{_infodir}/gnutls-guile.info*
This page took 0.095542 seconds and 4 git commands to generate.