]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
- updated to 3.2.5
[packages/gnutls.git] / gnutls.spec
1 #
2 # Conditional build:
3 %bcond_with     gcrypt  # use gcrypt crypto backend instead of nettle (withdrawn?)
4 %bcond_without  dane    # libdane (DANE with DNSSEC certificate verification)
5 %bcond_with     tpm     # TPM support in gnutls (cannot be used with GPL programs)
6 #
7 Summary:        The GNU Transport Layer Security Library
8 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
9 Name:           gnutls
10 Version:        3.2.5
11 Release:        1
12 License:        LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
13 Group:          Libraries
14 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.2/%{name}-%{version}.tar.lz
15 # Source0-md5:  667a9e8d7a9a6cc02d16bd348f25e914
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-link.patch
18 URL:            http://www.gnutls.org/
19 BuildRequires:  autoconf >= 2.61
20 BuildRequires:  automake >= 1:1.12.2
21 BuildRequires:  gettext-devel >= 0.18
22 BuildRequires:  gtk-doc >= 1.1
23 BuildRequires:  guile-devel >= 5:2.0
24 BuildRequires:  libcfg+-devel
25 %{?with_gcrypt:BuildRequires:   libgcrypt-devel >= 1.4.0}
26 BuildRequires:  libidn-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtasn1-devel >= 2.14
29 BuildRequires:  libtool >= 2:1.5
30 BuildRequires:  lzip
31 %{!?with_gcrypt:BuildRequires:  nettle-devel >= 2.7}
32 # miniopencdk is included in sources and currently maintained
33 # as part of gnutls, not external package
34 #BuildRequires: opencdk-devel >= 0.6.6
35 BuildRequires:  p11-kit-devel >= 0.11
36 BuildRequires:  pkgconfig
37 BuildRequires:  readline-devel
38 BuildRequires:  rpmbuild(macros) >= 1.383
39 BuildRequires:  sed >= 4.0
40 BuildRequires:  tar >= 1:1.22
41 BuildRequires:  texinfo >= 4.8
42 %{?with_tpm:BuildRequires:      trousers-devel}
43 %{?with_dane:BuildRequires:     unbound-devel}
44 BuildRequires:  zlib-devel
45 Requires:       %{name}-libs = %{version}-%{release}
46 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 GnuTLS is a project that aims to develop a library which provides a
51 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
52 the gnuTLS library implements the proposed standards by the IETF's TLS
53 working group.
54
55 %description -l pl.UTF-8
56 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
57 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
58 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
59 grupę roboczą IETF TLS.
60
61 %package libs
62 Summary:        GnuTLS shared libraries
63 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
64 Group:          Libraries
65 %{?with_gcrypt:Requires:        libgcrypt >= 1.4.0}
66 Requires:       libtasn1 >= 2.14
67 %{!?with_gcrypt:Requires:       nettle >= 2.7}
68 #Requires:      opencdk >= 0.6.6
69 Requires:       p11-kit >= 0.11
70 Conflicts:      gnutls < 3.2.0
71
72 %description libs
73 GnuTLS shared libraries.
74
75 %description libs -l pl.UTF-8
76 Biblioteki współdzielone GnuTLS.
77
78 %package devel
79 Summary:        Header files etc to develop gnutls applications
80 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
81 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
82 Group:          Development/Libraries
83 Requires:       %{name}-libs = %{version}-%{release}
84 %{?with_gcrypt:Requires:        libgcrypt-devel >= 1.4.0}
85 Requires:       libtasn1-devel >= 2.14
86 %{!?with_gcrypt:Requires:       nettle-devel >= 2.7}
87 #Requires:      opencdk-devel >= 0.6.6
88 Requires:       p11-kit-devel >= 0.11
89 %{?with_tpm:Requires:   trousers-devel}
90 Requires:       zlib-devel
91
92 %description devel
93 Header files etc to develop gnutls applications.
94
95 %description devel -l pl.UTF-8
96 Pliki nagłówkowe i inne do gnutls.
97
98 %package static
99 Summary:        Static gnutls library
100 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
101 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
102 Group:          Development/Libraries
103 Requires:       %{name}-devel = %{version}-%{release}
104
105 %description static
106 Static gnutls library.
107
108 %description static -l pl.UTF-8
109 Biblioteka statyczna gnutls.
110
111 %package c++
112 Summary:        libgnutlsxx - C++ interface to gnutls library
113 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
114 License:        LGPL v2.1+
115 Group:          Libraries
116 Requires:       %{name}-libs = %{version}-%{release}
117
118 %description c++
119 libgnutlsxx - C++ interface to gnutls library.
120
121 %description c++ -l pl.UTF-8
122 libgnutlsxx - interfejs C++ do biblioteki gnutls.
123
124 %package c++-devel
125 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
126 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
127 License:        LGPL v2.1+
128 Group:          Development/Libraries
129 Requires:       %{name}-c++ = %{version}-%{release}
130 Requires:       %{name}-devel = %{version}-%{release}
131 Requires:       libstdc++-devel
132
133 %description c++-devel
134 Header files for libgnutlsxx, a C++ interface to gnutls library.
135
136 %description c++-devel -l pl.UTF-8
137 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
138
139 %package c++-static
140 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
141 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
142 License:        LGPL v2.1+
143 Group:          Development/Libraries
144 Requires:       %{name}-c++-devel = %{version}-%{release}
145
146 %description c++-static
147 Static version of libgnutlsxx, a C++ interface to gnutls library.
148
149 %description c++-static -l pl.UTF-8
150 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
151
152 %package dane
153 Summary:        DANE security library
154 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
155 Group:          Libraries
156 Requires:       %{name}-libs = %{version}-%{release}
157
158 %description dane
159 DANE security library.
160
161 %description dane -l pl.UTF-8
162 Biblioteka bezpieczeństwa DANE.
163
164 %package dane-devel
165 Summary:        Header file for DANE security library
166 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
167 Group:          Development/Libraries
168 Requires:       %{name}-dane = %{version}-%{release}
169 Requires:       %{name}-devel = %{version}-%{release}
170 Requires:       unbound-devel
171
172 %description dane-devel
173 Header file for DANE security library.
174
175 %description dane-devel -l pl.UTF-8
176 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
177
178 %package dane-static
179 Summary:        Static DANE security library
180 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
181 Group:          Development/Libraries
182 Requires:       %{name}-dane-devel = %{version}-%{release}
183
184 %description dane-static
185 Static DANE security library.
186
187 %description dane-static -l pl.UTF-8
188 Statyczna biblioteka bezpieczeństwa DANE.
189
190 %package -n guile-gnutls
191 Summary:        Guile bindings for GnuTLS
192 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
193 License:        LGPL v2.1+
194 Group:          Development/Languages
195 Requires:       %{name}-libs = %{version}-%{release}
196 Requires:       guile >= 5:2.0
197
198 %description -n guile-gnutls
199 Guile bindings for GnuTLS.
200
201 %description -n guile-gnutls -l pl.UTF-8
202 Wiązania Guile do GnuTLS.
203
204 %prep
205 %setup -q
206 %patch0 -p1
207 %patch1 -p1
208
209 %{__rm} po/stamp-po
210
211 # remove it when "linking libtool libraries using a non-POSIX archiver ..." warning is gone
212 # (after gnutls or libtool change)
213 %{__sed} -i -e '/AM_INIT_AUTOMAKE/s/-Werror//' configure.ac
214
215 %build
216 %{__libtoolize}
217 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4
218 %{__autoconf}
219 %{__autoheader}
220 %{__automake}
221 %configure \
222         --disable-silent-rules \
223         --enable-heartbeat-support \
224         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
225         %{?with_gcrypt:--with-libgcrypt} \
226         %{?with_tpm:--with-tpm}
227
228 # docs build is broken with -jN
229 %{__make} -j1
230
231 %install
232 rm -rf $RPM_BUILD_ROOT
233
234 %{__make} install \
235         DESTDIR=$RPM_BUILD_ROOT
236
237 # although libgnutls.la is obsoleted by pkg-config, there is
238 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
239
240 # guile module - dynamic only
241 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.{la,a}
242
243 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
244
245 %find_lang %{name}
246
247 %clean
248 rm -rf $RPM_BUILD_ROOT
249
250 %post
251 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
252
253 %postun
254 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
255
256 %post   libs -p /sbin/ldconfig
257 %postun libs -p /sbin/ldconfig
258
259 %post   c++ -p /sbin/ldconfig
260 %postun c++ -p /sbin/ldconfig
261
262 %post   -n guile-gnutls -p /sbin/ldconfig
263 %postun -n guile-gnutls -p /sbin/ldconfig
264
265 %files -f %{name}.lang
266 %defattr(644,root,root,755)
267 %doc AUTHORS ChangeLog NEWS README THANKS
268 %attr(755,root,root) %{_bindir}/certtool
269 %attr(755,root,root) %{_bindir}/crywrap
270 %attr(755,root,root) %{_bindir}/gnutls-*
271 %attr(755,root,root) %{_bindir}/ocsptool
272 %attr(755,root,root) %{_bindir}/p11tool
273 %attr(755,root,root) %{_bindir}/psktool
274 %attr(755,root,root) %{_bindir}/srptool
275 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
276 %{_mandir}/man1/certtool.1*
277 %{_mandir}/man1/gnutls-*.1*
278 %{_mandir}/man1/ocsptool.1*
279 %{_mandir}/man1/p11tool.1*
280 %{_mandir}/man1/psktool.1*
281 %{_mandir}/man1/srptool.1*
282 %{_mandir}/man1/tpmtool.1*
283 %{_infodir}/gnutls.info*
284 %{_infodir}/gnutls-*.png
285 %{_infodir}/pkcs11-vision.png
286
287 %files libs
288 %defattr(644,root,root,755)
289 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
290 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.28
291 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
292 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
293 %attr(755,root,root) %{_libdir}/libgnutls-xssl.so.*.*.*
294 %attr(755,root,root) %ghost %{_libdir}/libgnutls-xssl.so.0
295
296 %files devel
297 %defattr(644,root,root,755)
298 %attr(755,root,root) %{_libdir}/libgnutls.so
299 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
300 %attr(755,root,root) %{_libdir}/libgnutls-xssl.so
301 %{_libdir}/libgnutls.la
302 %{_libdir}/libgnutls-openssl.la
303 %{_libdir}/libgnutls-xssl.la
304 %{_includedir}/gnutls
305 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
306 %exclude %{_includedir}/gnutls/gnutlsxx.h
307 %{_pkgconfigdir}/gnutls.pc
308 %{_mandir}/man3/gnutls_*.3*
309
310 %files static
311 %defattr(644,root,root,755)
312 %{_libdir}/libgnutls.a
313 %{_libdir}/libgnutls-openssl.a
314 %{_libdir}/libgnutls-xssl.a
315
316 %files c++
317 %defattr(644,root,root,755)
318 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
319 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
320
321 %files c++-devel
322 %defattr(644,root,root,755)
323 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
324 %{_libdir}/libgnutlsxx.la
325 %{_includedir}/gnutls/gnutlsxx.h
326
327 %files c++-static
328 %defattr(644,root,root,755)
329 %{_libdir}/libgnutlsxx.a
330
331 %if %{with dane}
332 %files dane
333 %defattr(644,root,root,755)
334 %attr(755,root,root) %{_bindir}/danetool
335 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
336 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
337 %{_mandir}/man1/danetool.1*
338
339 %files dane-devel
340 %defattr(644,root,root,755)
341 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
342 %{_libdir}/libgnutls-dane.la
343 %{_includedir}/gnutls/dane.h
344 %{_pkgconfigdir}/gnutls-dane.pc
345
346 %files dane-static
347 %defattr(644,root,root,755)
348 %{_libdir}/libgnutls-dane.a
349 %endif
350
351 %files -n guile-gnutls
352 %defattr(644,root,root,755)
353 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
354 %{_datadir}/guile/site/gnutls.scm
355 %{_datadir}/guile/site/gnutls
356 %{_infodir}/gnutls-guile.info*
This page took 0.054666 seconds and 4 git commands to generate.