]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
- note on 3.4.x
[packages/gnutls.git] / gnutls.spec
1 # NOTE: for 3.4.x see DEVEL branch
2 #
3 # Conditional build:
4 %bcond_without  dane            # libdane (DANE with DNSSEC certificate verification)
5 %bcond_without  openssl         # libgnutls-openssl compatibility library
6 %bcond_without  tpm             # TPM support in gnutls
7 %bcond_without  static_libs     # static libraries
8 %bcond_without  doc             # do not generate documentation
9 #
10 Summary:        The GNU Transport Layer Security Library
11 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
12 Name:           gnutls
13 Version:        3.3.22
14 Release:        1
15 License:        LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
16 Group:          Libraries
17 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/%{name}-%{version}.tar.xz
18 # Source0-md5:  7e12ab5a9de0741fac4606c979fd2eb7
19 Patch0:         %{name}-info.patch
20 Patch1:         %{name}-link.patch
21 URL:            http://www.gnutls.org/
22 BuildRequires:  autoconf >= 2.61
23 BuildRequires:  autogen
24 BuildRequires:  autogen-devel
25 BuildRequires:  automake >= 1:1.12.2
26 BuildRequires:  gettext-tools >= 0.18
27 BuildRequires:  gmp-devel
28 %{?with_doc:BuildRequires:      gtk-doc >= 1.1}
29 BuildRequires:  guile-devel >= 5:2.0
30 BuildRequires:  libcfg+-devel
31 BuildRequires:  libidn-devel
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtasn1-devel >= 3.9
34 BuildRequires:  libtool >= 2:2
35 BuildRequires:  nettle-devel >= 2.7.1
36 # miniopencdk is included in sources and currently maintained
37 # as part of gnutls, not external package
38 #BuildRequires: opencdk-devel >= 0.6.6
39 BuildRequires:  p11-kit-devel >= 0.20.7
40 BuildRequires:  pkgconfig
41 BuildRequires:  readline-devel
42 BuildRequires:  rpmbuild(macros) >= 1.383
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  tar >= 1:1.22
45 %{?with_doc:BuildRequires:      texinfo >= 4.8}
46 %{?with_tpm:BuildRequires:      trousers-devel >= 0.3.11}
47 %{?with_dane:BuildRequires:     unbound-devel}
48 BuildRequires:  xz
49 BuildRequires:  zlib-devel
50 Requires:       %{name}-libs = %{version}-%{release}
51 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 GnuTLS is a project that aims to develop a library which provides a
56 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
57 the gnuTLS library implements the proposed standards by the IETF's TLS
58 working group.
59
60 %description -l pl.UTF-8
61 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
62 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
63 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
64 grupę roboczą IETF TLS.
65
66 %package libs
67 Summary:        GnuTLS shared libraries
68 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
69 Group:          Libraries
70 Requires:       libtasn1 >= 3.9
71 Requires:       nettle >= 2.7.1
72 #Requires:      opencdk >= 0.6.6
73 Requires:       p11-kit >= 0.20.7
74 %{?with_tpm:Requires:   trousers-libs >= 0.3.11}
75 Conflicts:      gnutls < 3.2.0
76
77 %description libs
78 GnuTLS shared libraries.
79
80 %description libs -l pl.UTF-8
81 Biblioteki współdzielone GnuTLS.
82
83 %package devel
84 Summary:        Header files etc to develop gnutls applications
85 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
86 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
87 Group:          Development/Libraries
88 Requires:       %{name}-libs = %{version}-%{release}
89 Requires:       libtasn1-devel >= 3.9
90 Requires:       nettle-devel >= 2.7.1
91 #Requires:      opencdk-devel >= 0.6.6
92 Requires:       p11-kit-devel >= 0.20.7
93 %{?with_tpm:Requires:   trousers-devel >= 0.3.11}
94 Requires:       zlib-devel
95
96 %description devel
97 Header files etc to develop gnutls applications.
98
99 %description devel -l pl.UTF-8
100 Pliki nagłówkowe i inne do gnutls.
101
102 %package static
103 Summary:        Static gnutls library
104 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
105 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
106 Group:          Development/Libraries
107 Requires:       %{name}-devel = %{version}-%{release}
108
109 %description static
110 Static gnutls library.
111
112 %description static -l pl.UTF-8
113 Biblioteka statyczna gnutls.
114
115 %package c++
116 Summary:        libgnutlsxx - C++ interface to gnutls library
117 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
118 License:        LGPL v2.1+
119 Group:          Libraries
120 Requires:       %{name}-libs = %{version}-%{release}
121
122 %description c++
123 libgnutlsxx - C++ interface to gnutls library.
124
125 %description c++ -l pl.UTF-8
126 libgnutlsxx - interfejs C++ do biblioteki gnutls.
127
128 %package c++-devel
129 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
130 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
131 License:        LGPL v2.1+
132 Group:          Development/Libraries
133 Requires:       %{name}-c++ = %{version}-%{release}
134 Requires:       %{name}-devel = %{version}-%{release}
135 Requires:       libstdc++-devel
136
137 %description c++-devel
138 Header files for libgnutlsxx, a C++ interface to gnutls library.
139
140 %description c++-devel -l pl.UTF-8
141 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
142
143 %package c++-static
144 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
145 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
146 License:        LGPL v2.1+
147 Group:          Development/Libraries
148 Requires:       %{name}-c++-devel = %{version}-%{release}
149
150 %description c++-static
151 Static version of libgnutlsxx, a C++ interface to gnutls library.
152
153 %description c++-static -l pl.UTF-8
154 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
155
156 %package dane
157 Summary:        DANE security library
158 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
159 Group:          Libraries
160 Requires:       %{name}-libs = %{version}-%{release}
161
162 %description dane
163 DANE security library.
164
165 %description dane -l pl.UTF-8
166 Biblioteka bezpieczeństwa DANE.
167
168 %package dane-devel
169 Summary:        Header file for DANE security library
170 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
171 Group:          Development/Libraries
172 Requires:       %{name}-dane = %{version}-%{release}
173 Requires:       %{name}-devel = %{version}-%{release}
174 Requires:       unbound-devel
175
176 %description dane-devel
177 Header file for DANE security library.
178
179 %description dane-devel -l pl.UTF-8
180 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
181
182 %package dane-static
183 Summary:        Static DANE security library
184 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
185 Group:          Development/Libraries
186 Requires:       %{name}-dane-devel = %{version}-%{release}
187
188 %description dane-static
189 Static DANE security library.
190
191 %description dane-static -l pl.UTF-8
192 Statyczna biblioteka bezpieczeństwa DANE.
193
194 %package openssl
195 Summary:        OpenSSL compatibility library for GnuTLS
196 Summary(pl.UTF-8):      Biblioteka zgodności z OpenSSL dla GnuTLS
197 Group:          Libraries
198 Requires:       %{name}-libs = %{version}-%{release}
199
200 %description openssl
201 OpenSSL compatibility library for GnuTLS.
202
203 %description openssl -l pl.UTF-8
204 Biblioteka zgodności z OpenSSL dla GnuTLS.
205
206 %package openssl-devel
207 Summary:        Header file for gnutls-openssl library
208 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki gnutls-openssl
209 Group:          Development/Libraries
210 Requires:       %{name}-devel = %{version}-%{release}
211 Requires:       %{name}-openssl = %{version}-%{release}
212
213 %description openssl-devel
214 Header file for gnutls-openssl library.
215
216 %description openssl-devel -l pl.UTF-8
217 Plik nagłówkowy biblioteki gnutls-openssl.
218
219 %package openssl-static
220 Summary:        Static gnutls-openssl library
221 Summary(pl.UTF-8):      Statyczna biblioteka gnutls-openssl
222 Group:          Development/Libraries
223 Requires:       %{name}-openssl-devel = %{version}-%{release}
224
225 %description openssl-static
226 Static gnutls-openssl library.
227
228 %description openssl-static -l pl.UTF-8
229 Statyczna biblioteka gnutls-openssl.
230
231 %package -n guile-gnutls
232 Summary:        Guile bindings for GnuTLS
233 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
234 License:        LGPL v2.1+
235 Group:          Development/Languages
236 Requires:       %{name}-libs = %{version}-%{release}
237 Requires:       guile >= 5:2.0
238
239 %description -n guile-gnutls
240 Guile bindings for GnuTLS.
241
242 %description -n guile-gnutls -l pl.UTF-8
243 Wiązania Guile do GnuTLS.
244
245 %prep
246 %setup -q
247 %patch0 -p1
248 %patch1 -p1
249
250 %{__rm} po/stamp-po
251
252 %build
253 %{__mv} build-aux/snippet{,.save}
254 %{__libtoolize}
255 %{__mv} build-aux/snippet{.save,}
256 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4 -I src/gl/m4
257 %{__autoconf}
258 %{__autoheader}
259 %{__automake}
260 %configure \
261         %{!?with_openssl:--disable-openssl-compatibility} \
262         --disable-silent-rules \
263         %{?with_static_libs:--enable-static} \
264         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
265         %{!?with_tpm:--without-tpm} \
266         %{!?with_doc:--disable-doc}
267
268 # docs build is broken with -jN
269 %{__make} -j1
270
271 %install
272 rm -rf $RPM_BUILD_ROOT
273
274 %{__make} install \
275         DESTDIR=$RPM_BUILD_ROOT
276
277 # although libgnutls.la is obsoleted by pkg-config, there is
278 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
279
280 # guile module - dynamic only
281 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.la
282 %if %{with static_libs}
283 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.a
284 %endif
285
286 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
287
288 %find_lang %{name}
289
290 %clean
291 rm -rf $RPM_BUILD_ROOT
292
293 %post
294 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
295
296 %postun
297 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
298
299 %post   libs -p /sbin/ldconfig
300 %postun libs -p /sbin/ldconfig
301
302 %post   c++ -p /sbin/ldconfig
303 %postun c++ -p /sbin/ldconfig
304
305 %post   dane -p /sbin/ldconfig
306 %postun dane -p /sbin/ldconfig
307
308 %post   openssl -p /sbin/ldconfig
309 %postun openssl -p /sbin/ldconfig
310
311 %post   -n guile-gnutls -p /sbin/ldconfig
312 %postun -n guile-gnutls -p /sbin/ldconfig
313
314 %files -f %{name}.lang
315 %defattr(644,root,root,755)
316 %doc AUTHORS ChangeLog NEWS README THANKS
317 %attr(755,root,root) %{_bindir}/certtool
318 %attr(755,root,root) %{_bindir}/crywrap
319 %attr(755,root,root) %{_bindir}/gnutls-*
320 %attr(755,root,root) %{_bindir}/ocsptool
321 %attr(755,root,root) %{_bindir}/p11tool
322 %attr(755,root,root) %{_bindir}/psktool
323 %attr(755,root,root) %{_bindir}/srptool
324 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
325 %if %{with doc}
326 %{_mandir}/man1/certtool.1*
327 %{_mandir}/man1/gnutls-*.1*
328 %{_mandir}/man1/ocsptool.1*
329 %{_mandir}/man1/p11tool.1*
330 %{_mandir}/man1/psktool.1*
331 %{_mandir}/man1/srptool.1*
332 %{_mandir}/man1/tpmtool.1*
333 %{_infodir}/gnutls.info*
334 %{_infodir}/gnutls-*.png
335 %{_infodir}/pkcs11-vision.png
336 %endif
337
338 %files libs
339 %defattr(644,root,root,755)
340 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
341 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.28
342
343 %files devel
344 %defattr(644,root,root,755)
345 %attr(755,root,root) %{_libdir}/libgnutls.so
346 %{_libdir}/libgnutls.la
347 %{_includedir}/gnutls
348 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
349 %exclude %{_includedir}/gnutls/gnutlsxx.h
350 %{?with_openssl:%exclude %{_includedir}/gnutls/openssl.h}
351 %{_pkgconfigdir}/gnutls.pc
352 %{?with_doc:%{_mandir}/man3/gnutls_*.3*}
353
354 %if %{with static_libs}
355 %files static
356 %defattr(644,root,root,755)
357 %{_libdir}/libgnutls.a
358 %endif
359
360 %files c++
361 %defattr(644,root,root,755)
362 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
363 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
364
365 %files c++-devel
366 %defattr(644,root,root,755)
367 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
368 %{_libdir}/libgnutlsxx.la
369 %{_includedir}/gnutls/gnutlsxx.h
370
371 %if %{with static_libs}
372 %files c++-static
373 %defattr(644,root,root,755)
374 %{_libdir}/libgnutlsxx.a
375 %endif
376
377 %if %{with dane}
378 %files dane
379 %defattr(644,root,root,755)
380 %attr(755,root,root) %{_bindir}/danetool
381 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
382 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
383 %{?with_doc:%{_mandir}/man1/danetool.1*}
384
385 %files dane-devel
386 %defattr(644,root,root,755)
387 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
388 %{_libdir}/libgnutls-dane.la
389 %{_includedir}/gnutls/dane.h
390 %{_pkgconfigdir}/gnutls-dane.pc
391
392 %if %{with static_libs}
393 %files dane-static
394 %defattr(644,root,root,755)
395 %{_libdir}/libgnutls-dane.a
396 %endif
397 %endif
398
399 %if %{with openssl}
400 %files openssl
401 %defattr(644,root,root,755)
402 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
403 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
404
405 %files openssl-devel
406 %defattr(644,root,root,755)
407 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
408 %{_libdir}/libgnutls-openssl.la
409 %{_includedir}/gnutls/openssl.h
410
411 %files openssl-static
412 %defattr(644,root,root,755)
413 %{_libdir}/libgnutls-openssl.a
414 %endif
415
416 %files -n guile-gnutls
417 %defattr(644,root,root,755)
418 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
419 %{_datadir}/guile/site/gnutls.scm
420 %{_datadir}/guile/site/gnutls
421 %{?with_doc:%{_infodir}/gnutls-guile.info*}
This page took 0.065745 seconds and 4 git commands to generate.