]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
c26a05f786512ef8e537736e1dfa92d7da0aca7f
[packages/gnutls.git] / gnutls.spec
1 #
2 # Conditional build:
3 %bcond_without  dane            # libdane (DANE with DNSSEC certificate verification)
4 %bcond_without  openssl         # libgnutls-openssl compatibility library
5 %bcond_without  tpm             # TPM support in gnutls
6 %bcond_without  static_libs     # static libraries
7 %bcond_without  doc             # do not generate documentation
8 #
9 Summary:        The GNU Transport Layer Security Library
10 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
11 Name:           gnutls
12 Version:        3.6.5
13 Release:        3
14 License:        LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
15 Group:          Libraries
16 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.6/%{name}-%{version}.tar.xz
17 # Source0-md5:  3474849e1bbd4d16403b82ab2579000b
18 Patch0:         %{name}-info.patch
19 Patch1:         %{name}-link.patch
20 URL:            http://www.gnutls.org/
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  autogen
23 BuildRequires:  autogen-devel
24 BuildRequires:  automake >= 1:1.12.2
25 BuildRequires:  gettext-tools >= 0.19
26 BuildRequires:  gmp-devel
27 %{?with_doc:BuildRequires:      gtk-doc >= 1.1}
28 BuildRequires:  guile-devel >= 5:2.0
29 BuildRequires:  libidn2-devel
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtasn1-devel >= 4.11
32 BuildRequires:  libunistring-devel
33 BuildRequires:  libtool >= 2:2
34 BuildRequires:  nettle-devel >= 3.3
35 # miniopencdk is included in sources and currently maintained
36 # as part of gnutls, not external package
37 #BuildRequires: opencdk-devel >= 0.6.6
38 BuildRequires:  p11-kit-devel >= 0.23.1
39 BuildRequires:  pkgconfig
40 BuildRequires:  readline-devel
41 BuildRequires:  rpmbuild(macros) >= 1.383
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  tar >= 1:1.22
44 %{?with_doc:BuildRequires:      texinfo >= 4.8}
45 %{?with_tpm:BuildRequires:      trousers-devel >= 0.3.11}
46 %{?with_dane:BuildRequires:     unbound-devel}
47 BuildRequires:  xz
48 BuildRequires:  zlib-devel
49 Requires:       %{name}-libs = %{version}-%{release}
50 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 GnuTLS is a project that aims to develop a library which provides a
55 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
56 the gnuTLS library implements the proposed standards by the IETF's TLS
57 working group.
58
59 %description -l pl.UTF-8
60 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
61 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
62 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
63 grupę roboczą IETF TLS.
64
65 %package libs
66 Summary:        GnuTLS shared libraries
67 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
68 Group:          Libraries
69 Requires:       libtasn1 >= 4.11
70 Requires:       nettle >= 3.3
71 #Requires:      opencdk >= 0.6.6
72 Requires:       p11-kit >= 0.23.1
73 %{?with_tpm:Requires:   trousers-libs >= 0.3.11}
74 Conflicts:      gnutls < 3.2.0
75
76 %description libs
77 GnuTLS shared libraries.
78
79 %description libs -l pl.UTF-8
80 Biblioteki współdzielone GnuTLS.
81
82 %package devel
83 Summary:        Header files etc to develop gnutls applications
84 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
85 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
86 Group:          Development/Libraries
87 Requires:       %{name}-libs = %{version}-%{release}
88 Requires:       libidn2-devel
89 Requires:       libtasn1-devel >= 4.11
90 Requires:       libunistring-devel
91 Requires:       nettle-devel >= 3.3
92 #Requires:      opencdk-devel >= 0.6.6
93 Requires:       p11-kit-devel >= 0.23.1
94 %{?with_tpm:Requires:   trousers-devel >= 0.3.11}
95 Requires:       zlib-devel
96
97 %description devel
98 Header files etc to develop gnutls applications.
99
100 %description devel -l pl.UTF-8
101 Pliki nagłówkowe i inne do gnutls.
102
103 %package static
104 Summary:        Static gnutls library
105 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
106 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109
110 %description static
111 Static gnutls library.
112
113 %description static -l pl.UTF-8
114 Biblioteka statyczna gnutls.
115
116 %package c++
117 Summary:        libgnutlsxx - C++ interface to gnutls library
118 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
119 License:        LGPL v2.1+
120 Group:          Libraries
121 Requires:       %{name}-libs = %{version}-%{release}
122
123 %description c++
124 libgnutlsxx - C++ interface to gnutls library.
125
126 %description c++ -l pl.UTF-8
127 libgnutlsxx - interfejs C++ do biblioteki gnutls.
128
129 %package c++-devel
130 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
131 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
132 License:        LGPL v2.1+
133 Group:          Development/Libraries
134 Requires:       %{name}-c++ = %{version}-%{release}
135 Requires:       %{name}-devel = %{version}-%{release}
136 Requires:       libstdc++-devel
137
138 %description c++-devel
139 Header files for libgnutlsxx, a C++ interface to gnutls library.
140
141 %description c++-devel -l pl.UTF-8
142 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
143
144 %package c++-static
145 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
146 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
147 License:        LGPL v2.1+
148 Group:          Development/Libraries
149 Requires:       %{name}-c++-devel = %{version}-%{release}
150
151 %description c++-static
152 Static version of libgnutlsxx, a C++ interface to gnutls library.
153
154 %description c++-static -l pl.UTF-8
155 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
156
157 %package dane
158 Summary:        DANE security library
159 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
160 Group:          Libraries
161 Requires:       %{name}-libs = %{version}-%{release}
162
163 %description dane
164 DANE security library.
165
166 %description dane -l pl.UTF-8
167 Biblioteka bezpieczeństwa DANE.
168
169 %package dane-devel
170 Summary:        Header file for DANE security library
171 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
172 Group:          Development/Libraries
173 Requires:       %{name}-dane = %{version}-%{release}
174 Requires:       %{name}-devel = %{version}-%{release}
175 Requires:       unbound-devel
176
177 %description dane-devel
178 Header file for DANE security library.
179
180 %description dane-devel -l pl.UTF-8
181 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
182
183 %package dane-static
184 Summary:        Static DANE security library
185 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
186 Group:          Development/Libraries
187 Requires:       %{name}-dane-devel = %{version}-%{release}
188
189 %description dane-static
190 Static DANE security library.
191
192 %description dane-static -l pl.UTF-8
193 Statyczna biblioteka bezpieczeństwa DANE.
194
195 %package openssl
196 Summary:        OpenSSL compatibility library for GnuTLS
197 Summary(pl.UTF-8):      Biblioteka zgodności z OpenSSL dla GnuTLS
198 Group:          Libraries
199 Requires:       %{name}-libs = %{version}-%{release}
200
201 %description openssl
202 OpenSSL compatibility library for GnuTLS.
203
204 %description openssl -l pl.UTF-8
205 Biblioteka zgodności z OpenSSL dla GnuTLS.
206
207 %package openssl-devel
208 Summary:        Header file for gnutls-openssl library
209 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki gnutls-openssl
210 Group:          Development/Libraries
211 Requires:       %{name}-devel = %{version}-%{release}
212 Requires:       %{name}-openssl = %{version}-%{release}
213
214 %description openssl-devel
215 Header file for gnutls-openssl library.
216
217 %description openssl-devel -l pl.UTF-8
218 Plik nagłówkowy biblioteki gnutls-openssl.
219
220 %package openssl-static
221 Summary:        Static gnutls-openssl library
222 Summary(pl.UTF-8):      Statyczna biblioteka gnutls-openssl
223 Group:          Development/Libraries
224 Requires:       %{name}-openssl-devel = %{version}-%{release}
225
226 %description openssl-static
227 Static gnutls-openssl library.
228
229 %description openssl-static -l pl.UTF-8
230 Statyczna biblioteka gnutls-openssl.
231
232 %package -n guile-gnutls
233 Summary:        Guile bindings for GnuTLS
234 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
235 License:        LGPL v2.1+
236 Group:          Development/Languages
237 Requires:       %{name}-libs = %{version}-%{release}
238 Requires:       guile >= 5:2.0
239
240 %description -n guile-gnutls
241 Guile bindings for GnuTLS.
242
243 %description -n guile-gnutls -l pl.UTF-8
244 Wiązania Guile do GnuTLS.
245
246 %prep
247 %setup -q
248 %patch0 -p1
249 %patch1 -p1
250
251 %{__rm} po/stamp-po
252
253 %build
254 %{__mv} build-aux/snippet{,.save}
255 %{__libtoolize}
256 %{__mv} build-aux/snippet{.save,}
257 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4 -I src/gl/m4 -I lib/unistring/m4
258 %{__autoconf}
259 %{__autoheader}
260 %{__automake}
261 %configure \
262         %{?with_openssl:--enable-openssl-compatibility} \
263         --disable-silent-rules \
264         %{?with_static_libs:--enable-static} \
265         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
266         %{!?with_tpm:--without-tpm} \
267         --with-trousers-lib=%{_libdir}/libtspi.so.1 \
268         %{!?with_doc:--disable-doc}
269
270 # docs build is broken with -jN
271 %{__make} -j1
272
273 %install
274 rm -rf $RPM_BUILD_ROOT
275
276 %{__make} install \
277         DESTDIR=$RPM_BUILD_ROOT
278
279 # although libgnutls.la is obsoleted by pkg-config, there is
280 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
281
282 # guile module - dynamic only
283 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.la
284 %if %{with static_libs}
285 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.a
286 %endif
287
288 # images for (not installed) htmlized infos - already packaged with infos
289 %{__rm} $RPM_BUILD_ROOT%{_docdir}/gnutls/*.png
290
291 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
292
293 %find_lang %{name}
294
295 %clean
296 rm -rf $RPM_BUILD_ROOT
297
298 %post
299 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
300
301 %postun
302 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
303
304 %post   libs -p /sbin/ldconfig
305 %postun libs -p /sbin/ldconfig
306
307 %post   c++ -p /sbin/ldconfig
308 %postun c++ -p /sbin/ldconfig
309
310 %post   dane -p /sbin/ldconfig
311 %postun dane -p /sbin/ldconfig
312
313 %post   openssl -p /sbin/ldconfig
314 %postun openssl -p /sbin/ldconfig
315
316 %post   -n guile-gnutls -p /sbin/ldconfig
317 %postun -n guile-gnutls -p /sbin/ldconfig
318
319 %files -f %{name}.lang
320 %defattr(644,root,root,755)
321 %doc AUTHORS ChangeLog NEWS README.md THANKS
322 %attr(755,root,root) %{_bindir}/certtool
323 %attr(755,root,root) %{_bindir}/gnutls-*
324 %attr(755,root,root) %{_bindir}/ocsptool
325 %attr(755,root,root) %{_bindir}/p11tool
326 %attr(755,root,root) %{_bindir}/psktool
327 %attr(755,root,root) %{_bindir}/srptool
328 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
329 %if %{with doc}
330 %{_mandir}/man1/certtool.1*
331 %{_mandir}/man1/gnutls-*.1*
332 %{_mandir}/man1/ocsptool.1*
333 %{_mandir}/man1/p11tool.1*
334 %{_mandir}/man1/psktool.1*
335 %{_mandir}/man1/srptool.1*
336 %{_mandir}/man1/tpmtool.1*
337 %{_infodir}/gnutls.info*
338 %{_infodir}/gnutls-*.png
339 %{_infodir}/pkcs11-vision.png
340 %endif
341
342 %files libs
343 %defattr(644,root,root,755)
344 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
345 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.30
346
347 %files devel
348 %defattr(644,root,root,755)
349 %attr(755,root,root) %{_libdir}/libgnutls.so
350 %{_libdir}/libgnutls.la
351 %{_includedir}/gnutls
352 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
353 %exclude %{_includedir}/gnutls/gnutlsxx.h
354 %{?with_openssl:%exclude %{_includedir}/gnutls/openssl.h}
355 %{_pkgconfigdir}/gnutls.pc
356 %{?with_doc:%{_mandir}/man3/gnutls_*.3*}
357
358 %if %{with static_libs}
359 %files static
360 %defattr(644,root,root,755)
361 %{_libdir}/libgnutls.a
362 %endif
363
364 %files c++
365 %defattr(644,root,root,755)
366 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
367 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
368
369 %files c++-devel
370 %defattr(644,root,root,755)
371 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
372 %{_libdir}/libgnutlsxx.la
373 %{_includedir}/gnutls/gnutlsxx.h
374
375 %if %{with static_libs}
376 %files c++-static
377 %defattr(644,root,root,755)
378 %{_libdir}/libgnutlsxx.a
379 %endif
380
381 %if %{with dane}
382 %files dane
383 %defattr(644,root,root,755)
384 %attr(755,root,root) %{_bindir}/danetool
385 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
386 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
387 %{?with_doc:%{_mandir}/man1/danetool.1*}
388
389 %files dane-devel
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
392 %{_libdir}/libgnutls-dane.la
393 %{_includedir}/gnutls/dane.h
394 %{_pkgconfigdir}/gnutls-dane.pc
395 %{_mandir}/man3/dane_*.3*
396
397 %if %{with static_libs}
398 %files dane-static
399 %defattr(644,root,root,755)
400 %{_libdir}/libgnutls-dane.a
401 %endif
402 %endif
403
404 %if %{with openssl}
405 %files openssl
406 %defattr(644,root,root,755)
407 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
408 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
409
410 %files openssl-devel
411 %defattr(644,root,root,755)
412 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
413 %{_libdir}/libgnutls-openssl.la
414 %{_includedir}/gnutls/openssl.h
415
416 %files openssl-static
417 %defattr(644,root,root,755)
418 %{_libdir}/libgnutls-openssl.a
419 %endif
420
421 %files -n guile-gnutls
422 %defattr(644,root,root,755)
423 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
424 %{_libdir}/guile/2.0/site-ccache/gnutls.go
425 %{_libdir}/guile/2.0/site-ccache/gnutls
426 %{_datadir}/guile/site/2.0/gnutls.scm
427 %{_datadir}/guile/site/2.0/gnutls
428 %{_infodir}/gnutls-guile.info*
This page took 0.043501 seconds and 2 git commands to generate.