]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
- separated openssl compatibility library
[packages/gnutls.git] / gnutls.spec
1 #
2 # Conditional build:
3 %bcond_without  dane            # libdane (DANE with DNSSEC certificate verification)
4 %bcond_without  openssl         # libgnutls-openssl compatibility library
5 %bcond_without  tpm             # TPM support in gnutls
6 %bcond_without  static_libs     # static libraries
7 #
8 Summary:        The GNU Transport Layer Security Library
9 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
10 Name:           gnutls
11 Version:        3.4.0
12 Release:        1
13 License:        LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
14 Group:          Libraries
15 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.4/%{name}-%{version}.tar.lz
16 # Source0-md5:  604362fb57bae7e6deba63c4e4a07a69
17 Patch0:         %{name}-info.patch
18 Patch1:         %{name}-link.patch
19 Patch2:         %{name}-install.patch
20 URL:            http://www.gnutls.org/
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  autogen
23 BuildRequires:  autogen-devel
24 BuildRequires:  automake >= 1:1.12.2
25 BuildRequires:  gettext-tools >= 0.18
26 BuildRequires:  gmp-devel
27 BuildRequires:  gtk-doc >= 1.1
28 BuildRequires:  guile-devel >= 5:2.0
29 BuildRequires:  libcfg+-devel
30 BuildRequires:  libidn-devel >= 0.5.6
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtasn1-devel >= 4.3
33 BuildRequires:  libtool >= 2:2
34 BuildRequires:  lzip
35 BuildRequires:  nettle-devel >= 3.1
36 # miniopencdk is included in sources and currently maintained
37 # as part of gnutls, not external package
38 #BuildRequires: opencdk-devel >= 0.6.6
39 BuildRequires:  p11-kit-devel >= 0.23.1
40 BuildRequires:  pkgconfig
41 BuildRequires:  readline-devel
42 BuildRequires:  rpmbuild(macros) >= 1.383
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  texinfo >= 4.8
46 %{?with_tpm:BuildRequires:      trousers-devel >= 0.3.11}
47 %{?with_dane:BuildRequires:     unbound-devel}
48 BuildRequires:  zlib-devel
49 Requires:       %{name}-libs = %{version}-%{release}
50 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 GnuTLS is a project that aims to develop a library which provides a
55 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
56 the gnuTLS library implements the proposed standards by the IETF's TLS
57 working group.
58
59 %description -l pl.UTF-8
60 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
61 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
62 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
63 grupę roboczą IETF TLS.
64
65 %package libs
66 Summary:        GnuTLS shared libraries
67 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
68 Group:          Libraries
69 Requires:       libidn >= 0.5.6
70 Requires:       libtasn1 >= 4.3
71 Requires:       nettle >= 3.1
72 #Requires:      opencdk >= 0.6.6
73 Requires:       p11-kit >= 0.23.1
74 %{?with_tpm:Requires:   trousers-libs >= 0.3.11}
75 Conflicts:      gnutls < 3.2.0
76
77 %description libs
78 GnuTLS shared libraries.
79
80 %description libs -l pl.UTF-8
81 Biblioteki współdzielone GnuTLS.
82
83 %package devel
84 Summary:        Header files etc to develop gnutls applications
85 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
86 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
87 Group:          Development/Libraries
88 Requires:       %{name}-libs = %{version}-%{release}
89 Requires:       libidn-devel >= 0.5.6
90 Requires:       libtasn1-devel >= 4.3
91 Requires:       nettle-devel >= 3.1
92 #Requires:      opencdk-devel >= 0.6.6
93 Requires:       p11-kit-devel >= 0.23.1
94 %{?with_tpm:Requires:   trousers-devel >= 0.3.11}
95 Requires:       zlib-devel
96
97 %description devel
98 Header files etc to develop gnutls applications.
99
100 %description devel -l pl.UTF-8
101 Pliki nagłówkowe i inne do gnutls.
102
103 %package static
104 Summary:        Static gnutls library
105 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
106 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109
110 %description static
111 Static gnutls library.
112
113 %description static -l pl.UTF-8
114 Biblioteka statyczna gnutls.
115
116 %package c++
117 Summary:        libgnutlsxx - C++ interface to gnutls library
118 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
119 License:        LGPL v2.1+
120 Group:          Libraries
121 Requires:       %{name}-libs = %{version}-%{release}
122
123 %description c++
124 libgnutlsxx - C++ interface to gnutls library.
125
126 %description c++ -l pl.UTF-8
127 libgnutlsxx - interfejs C++ do biblioteki gnutls.
128
129 %package c++-devel
130 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
131 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
132 License:        LGPL v2.1+
133 Group:          Development/Libraries
134 Requires:       %{name}-c++ = %{version}-%{release}
135 Requires:       %{name}-devel = %{version}-%{release}
136 Requires:       libstdc++-devel
137
138 %description c++-devel
139 Header files for libgnutlsxx, a C++ interface to gnutls library.
140
141 %description c++-devel -l pl.UTF-8
142 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
143
144 %package c++-static
145 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
146 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
147 License:        LGPL v2.1+
148 Group:          Development/Libraries
149 Requires:       %{name}-c++-devel = %{version}-%{release}
150
151 %description c++-static
152 Static version of libgnutlsxx, a C++ interface to gnutls library.
153
154 %description c++-static -l pl.UTF-8
155 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
156
157 %package dane
158 Summary:        DANE security library
159 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
160 Group:          Libraries
161 Requires:       %{name}-libs = %{version}-%{release}
162
163 %description dane
164 DANE security library.
165
166 %description dane -l pl.UTF-8
167 Biblioteka bezpieczeństwa DANE.
168
169 %package dane-devel
170 Summary:        Header file for DANE security library
171 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
172 Group:          Development/Libraries
173 Requires:       %{name}-dane = %{version}-%{release}
174 Requires:       %{name}-devel = %{version}-%{release}
175 Requires:       unbound-devel
176
177 %description dane-devel
178 Header file for DANE security library.
179
180 %description dane-devel -l pl.UTF-8
181 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
182
183 %package dane-static
184 Summary:        Static DANE security library
185 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
186 Group:          Development/Libraries
187 Requires:       %{name}-dane-devel = %{version}-%{release}
188
189 %description dane-static
190 Static DANE security library.
191
192 %description dane-static -l pl.UTF-8
193 Statyczna biblioteka bezpieczeństwa DANE.
194
195 %package openssl
196 Summary:        OpenSSL compatibility library for GnuTLS
197 Summary(pl.UTF-8):      Biblioteka zgodności z OpenSSL dla GnuTLS
198 Group:          Libraries
199 Requires:       %{name}-libs = %{version}-%{release}
200
201 %description openssl
202 OpenSSL compatibility library for GnuTLS.
203
204 %description openssl -l pl.UTF-8
205 Biblioteka zgodności z OpenSSL dla GnuTLS.
206
207 %package openssl-devel
208 Summary:        Header file for gnutls-openssl library
209 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki gnutls-openssl
210 Group:          Development/Libraries
211 Requires:       %{name}-devel = %{version}-%{release}
212 Requires:       %{name}-openssl = %{version}-%{release}
213
214 %description openssl-devel
215 Header file for gnutls-openssl library.
216
217 %description openssl-devel -l pl.UTF-8
218 Plik nagłówkowy biblioteki gnutls-openssl.
219
220 %package openssl-static
221 Summary:        Static gnutls-openssl library
222 Summary(pl.UTF-8):      Statyczna biblioteka gnutls-openssl
223 Group:          Development/Libraries
224 Requires:       %{name}-openssl-devel = %{version}-%{release}
225
226 %description openssl-static
227 Static gnutls-openssl library.
228
229 %description openssl-static -l pl.UTF-8
230 Statyczna biblioteka gnutls-openssl.
231
232 %package -n guile-gnutls
233 Summary:        Guile bindings for GnuTLS
234 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
235 License:        LGPL v2.1+
236 Group:          Development/Languages
237 Requires:       %{name}-libs = %{version}-%{release}
238 Requires:       guile >= 5:2.0
239
240 %description -n guile-gnutls
241 Guile bindings for GnuTLS.
242
243 %description -n guile-gnutls -l pl.UTF-8
244 Wiązania Guile do GnuTLS.
245
246 %prep
247 %setup -q
248 %patch0 -p1
249 %patch1 -p1
250 %patch2 -p1
251
252 %{__rm} po/stamp-po
253
254 %build
255 %{__mv} build-aux/snippet{,.save}
256 %{__libtoolize}
257 %{__mv} build-aux/snippet{.save,}
258 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4 -I src/gl/m4
259 %{__autoconf}
260 %{__autoheader}
261 %{__automake}
262 %configure \
263         %{?with_openssl:--enable-openssl-compatibility} \
264         --disable-silent-rules \
265         %{?with_static_libs:--enable-static} \
266         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
267         %{!?with_tpm:--without-tpm}
268
269 # docs build is broken with -jN
270 %{__make} -j1
271
272 %install
273 rm -rf $RPM_BUILD_ROOT
274
275 %{__make} install \
276         DESTDIR=$RPM_BUILD_ROOT
277
278 # although libgnutls.la is obsoleted by pkg-config, there is
279 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
280
281 # guile module - dynamic only
282 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.la
283 %if %{with static_libs}
284 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.a
285 %endif
286
287 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
288
289 %find_lang %{name}
290
291 %clean
292 rm -rf $RPM_BUILD_ROOT
293
294 %post
295 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
296
297 %postun
298 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
299
300 %post   libs -p /sbin/ldconfig
301 %postun libs -p /sbin/ldconfig
302
303 %post   c++ -p /sbin/ldconfig
304 %postun c++ -p /sbin/ldconfig
305
306 %post   dane -p /sbin/ldconfig
307 %postun dane -p /sbin/ldconfig
308
309 %post   openssl -p /sbin/ldconfig
310 %postun openssl -p /sbin/ldconfig
311
312 %post   -n guile-gnutls -p /sbin/ldconfig
313 %postun -n guile-gnutls -p /sbin/ldconfig
314
315 %files -f %{name}.lang
316 %defattr(644,root,root,755)
317 %doc AUTHORS ChangeLog NEWS README THANKS
318 %attr(755,root,root) %{_bindir}/certtool
319 %attr(755,root,root) %{_bindir}/crywrap
320 %attr(755,root,root) %{_bindir}/gnutls-*
321 %attr(755,root,root) %{_bindir}/ocsptool
322 %attr(755,root,root) %{_bindir}/p11tool
323 %attr(755,root,root) %{_bindir}/psktool
324 %attr(755,root,root) %{_bindir}/srptool
325 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
326 %{_mandir}/man1/certtool.1*
327 %{_mandir}/man1/gnutls-*.1*
328 %{_mandir}/man1/ocsptool.1*
329 %{_mandir}/man1/p11tool.1*
330 %{_mandir}/man1/psktool.1*
331 %{_mandir}/man1/srptool.1*
332 %{_mandir}/man1/tpmtool.1*
333 %{_infodir}/gnutls.info*
334 %{_infodir}/gnutls-*.png
335 %{_infodir}/pkcs11-vision.png
336
337 %files libs
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
340 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.30
341
342 %files devel
343 %defattr(644,root,root,755)
344 %attr(755,root,root) %{_libdir}/libgnutls.so
345 %{_libdir}/libgnutls.la
346 %{_includedir}/gnutls
347 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
348 %exclude %{_includedir}/gnutls/gnutlsxx.h
349 %{?with_openssl:%exclude %{_includedir}/gnutls/openssl.h}
350 %{_pkgconfigdir}/gnutls.pc
351 %{_mandir}/man3/gnutls_*.3*
352
353 %if %{with static_libs}
354 %files static
355 %defattr(644,root,root,755)
356 %{_libdir}/libgnutls.a
357 %endif
358
359 %files c++
360 %defattr(644,root,root,755)
361 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
362 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
363
364 %files c++-devel
365 %defattr(644,root,root,755)
366 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
367 %{_libdir}/libgnutlsxx.la
368 %{_includedir}/gnutls/gnutlsxx.h
369
370 %if %{with static_libs}
371 %files c++-static
372 %defattr(644,root,root,755)
373 %{_libdir}/libgnutlsxx.a
374 %endif
375
376 %if %{with dane}
377 %files dane
378 %defattr(644,root,root,755)
379 %attr(755,root,root) %{_bindir}/danetool
380 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
381 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
382 %{_mandir}/man1/danetool.1*
383
384 %files dane-devel
385 %defattr(644,root,root,755)
386 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
387 %{_libdir}/libgnutls-dane.la
388 %{_includedir}/gnutls/dane.h
389 %{_pkgconfigdir}/gnutls-dane.pc
390
391 %if %{with static_libs}
392 %files dane-static
393 %defattr(644,root,root,755)
394 %{_libdir}/libgnutls-dane.a
395 %endif
396 %endif
397
398 %if %{with openssl}
399 %files openssl
400 %defattr(644,root,root,755)
401 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
402 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
403
404 %files openssl-devel
405 %defattr(644,root,root,755)
406 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
407 %{_libdir}/libgnutls-openssl.la
408 %{_includedir}/gnutls/openssl.h
409
410 %files openssl-static
411 %defattr(644,root,root,755)
412 %{_libdir}/libgnutls-openssl.a
413 %endif
414
415 %files -n guile-gnutls
416 %defattr(644,root,root,755)
417 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
418 %{_datadir}/guile/site/gnutls.scm
419 %{_datadir}/guile/site/gnutls
420 %{_infodir}/gnutls-guile.info*
This page took 0.084502 seconds and 3 git commands to generate.