]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
444557fa93e27455372fb5b0e9d5722a42c01210
[packages/gnutls.git] / gnutls.spec
1 #
2 # Conditional build:
3 %bcond_without  dane            # libdane (DANE with DNSSEC certificate verification)
4 %bcond_without  tpm             # TPM support in gnutls
5 %bcond_without  static_libs     # static libraries
6 #
7 Summary:        The GNU Transport Layer Security Library
8 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
9 Name:           gnutls
10 Version:        3.4.0
11 Release:        1
12 License:        LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
13 Group:          Libraries
14 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.4/%{name}-%{version}.tar.lz
15 # Source0-md5:  604362fb57bae7e6deba63c4e4a07a69
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-link.patch
18 Patch2:         %{name}-install.patch
19 URL:            http://www.gnutls.org/
20 BuildRequires:  autoconf >= 2.61
21 BuildRequires:  autogen
22 BuildRequires:  autogen-devel
23 BuildRequires:  automake >= 1:1.12.2
24 BuildRequires:  gettext-tools >= 0.18
25 BuildRequires:  gmp-devel
26 BuildRequires:  gtk-doc >= 1.1
27 BuildRequires:  guile-devel >= 5:2.0
28 BuildRequires:  libcfg+-devel
29 BuildRequires:  libidn-devel >= 0.5.6
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtasn1-devel >= 4.3
32 BuildRequires:  libtool >= 2:2
33 BuildRequires:  lzip
34 BuildRequires:  nettle-devel >= 3.1
35 # miniopencdk is included in sources and currently maintained
36 # as part of gnutls, not external package
37 #BuildRequires: opencdk-devel >= 0.6.6
38 BuildRequires:  p11-kit-devel >= 0.23.1
39 BuildRequires:  pkgconfig
40 BuildRequires:  readline-devel
41 BuildRequires:  rpmbuild(macros) >= 1.383
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  tar >= 1:1.22
44 BuildRequires:  texinfo >= 4.8
45 %{?with_tpm:BuildRequires:      trousers-devel >= 0.3.11}
46 %{?with_dane:BuildRequires:     unbound-devel}
47 BuildRequires:  zlib-devel
48 Requires:       %{name}-libs = %{version}-%{release}
49 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 GnuTLS is a project that aims to develop a library which provides a
54 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
55 the gnuTLS library implements the proposed standards by the IETF's TLS
56 working group.
57
58 %description -l pl.UTF-8
59 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
60 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
61 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
62 grupę roboczą IETF TLS.
63
64 %package libs
65 Summary:        GnuTLS shared libraries
66 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
67 Group:          Libraries
68 Requires:       libidn >= 0.5.6
69 Requires:       libtasn1 >= 4.3
70 Requires:       nettle >= 3.1
71 #Requires:      opencdk >= 0.6.6
72 Requires:       p11-kit >= 0.23.1
73 %{?with_tpm:Requires:   trousers-libs >= 0.3.11}
74 Conflicts:      gnutls < 3.2.0
75
76 %description libs
77 GnuTLS shared libraries.
78
79 %description libs -l pl.UTF-8
80 Biblioteki współdzielone GnuTLS.
81
82 %package devel
83 Summary:        Header files etc to develop gnutls applications
84 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
85 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
86 Group:          Development/Libraries
87 Requires:       %{name}-libs = %{version}-%{release}
88 Requires:       libidn-devel >= 0.5.6
89 Requires:       libtasn1-devel >= 4.3
90 Requires:       nettle-devel >= 3.1
91 #Requires:      opencdk-devel >= 0.6.6
92 Requires:       p11-kit-devel >= 0.23.1
93 %{?with_tpm:Requires:   trousers-devel >= 0.3.11}
94 Requires:       zlib-devel
95
96 %description devel
97 Header files etc to develop gnutls applications.
98
99 %description devel -l pl.UTF-8
100 Pliki nagłówkowe i inne do gnutls.
101
102 %package static
103 Summary:        Static gnutls library
104 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
105 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
106 Group:          Development/Libraries
107 Requires:       %{name}-devel = %{version}-%{release}
108
109 %description static
110 Static gnutls library.
111
112 %description static -l pl.UTF-8
113 Biblioteka statyczna gnutls.
114
115 %package c++
116 Summary:        libgnutlsxx - C++ interface to gnutls library
117 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
118 License:        LGPL v2.1+
119 Group:          Libraries
120 Requires:       %{name}-libs = %{version}-%{release}
121
122 %description c++
123 libgnutlsxx - C++ interface to gnutls library.
124
125 %description c++ -l pl.UTF-8
126 libgnutlsxx - interfejs C++ do biblioteki gnutls.
127
128 %package c++-devel
129 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
130 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
131 License:        LGPL v2.1+
132 Group:          Development/Libraries
133 Requires:       %{name}-c++ = %{version}-%{release}
134 Requires:       %{name}-devel = %{version}-%{release}
135 Requires:       libstdc++-devel
136
137 %description c++-devel
138 Header files for libgnutlsxx, a C++ interface to gnutls library.
139
140 %description c++-devel -l pl.UTF-8
141 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
142
143 %package c++-static
144 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
145 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
146 License:        LGPL v2.1+
147 Group:          Development/Libraries
148 Requires:       %{name}-c++-devel = %{version}-%{release}
149
150 %description c++-static
151 Static version of libgnutlsxx, a C++ interface to gnutls library.
152
153 %description c++-static -l pl.UTF-8
154 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
155
156 %package dane
157 Summary:        DANE security library
158 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
159 Group:          Libraries
160 Requires:       %{name}-libs = %{version}-%{release}
161
162 %description dane
163 DANE security library.
164
165 %description dane -l pl.UTF-8
166 Biblioteka bezpieczeństwa DANE.
167
168 %package dane-devel
169 Summary:        Header file for DANE security library
170 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
171 Group:          Development/Libraries
172 Requires:       %{name}-dane = %{version}-%{release}
173 Requires:       %{name}-devel = %{version}-%{release}
174 Requires:       unbound-devel
175
176 %description dane-devel
177 Header file for DANE security library.
178
179 %description dane-devel -l pl.UTF-8
180 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
181
182 %package dane-static
183 Summary:        Static DANE security library
184 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
185 Group:          Development/Libraries
186 Requires:       %{name}-dane-devel = %{version}-%{release}
187
188 %description dane-static
189 Static DANE security library.
190
191 %description dane-static -l pl.UTF-8
192 Statyczna biblioteka bezpieczeństwa DANE.
193
194 %package -n guile-gnutls
195 Summary:        Guile bindings for GnuTLS
196 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
197 License:        LGPL v2.1+
198 Group:          Development/Languages
199 Requires:       %{name}-libs = %{version}-%{release}
200 Requires:       guile >= 5:2.0
201
202 %description -n guile-gnutls
203 Guile bindings for GnuTLS.
204
205 %description -n guile-gnutls -l pl.UTF-8
206 Wiązania Guile do GnuTLS.
207
208 %prep
209 %setup -q
210 %patch0 -p1
211 %patch1 -p1
212 %patch2 -p1
213
214 %{__rm} po/stamp-po
215
216 %build
217 %{__mv} build-aux/snippet{,.save}
218 %{__libtoolize}
219 %{__mv} build-aux/snippet{.save,}
220 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4 -I src/gl/m4
221 %{__autoconf}
222 %{__autoheader}
223 %{__automake}
224 %configure \
225         --enable-openssl-compatibility \
226         --disable-silent-rules \
227         %{?with_static_libs:--enable-static} \
228         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
229         %{!?with_tpm:--without-tpm}
230
231 # docs build is broken with -jN
232 %{__make} -j1
233
234 %install
235 rm -rf $RPM_BUILD_ROOT
236
237 %{__make} install \
238         DESTDIR=$RPM_BUILD_ROOT
239
240 # although libgnutls.la is obsoleted by pkg-config, there is
241 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
242
243 # guile module - dynamic only
244 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.la
245 %if %{with static_libs}
246 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.a
247 %endif
248
249 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
250
251 %find_lang %{name}
252
253 %clean
254 rm -rf $RPM_BUILD_ROOT
255
256 %post
257 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
258
259 %postun
260 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
261
262 %post   libs -p /sbin/ldconfig
263 %postun libs -p /sbin/ldconfig
264
265 %post   c++ -p /sbin/ldconfig
266 %postun c++ -p /sbin/ldconfig
267
268 %post   -n guile-gnutls -p /sbin/ldconfig
269 %postun -n guile-gnutls -p /sbin/ldconfig
270
271 %files -f %{name}.lang
272 %defattr(644,root,root,755)
273 %doc AUTHORS ChangeLog NEWS README THANKS
274 %attr(755,root,root) %{_bindir}/certtool
275 %attr(755,root,root) %{_bindir}/crywrap
276 %attr(755,root,root) %{_bindir}/gnutls-*
277 %attr(755,root,root) %{_bindir}/ocsptool
278 %attr(755,root,root) %{_bindir}/p11tool
279 %attr(755,root,root) %{_bindir}/psktool
280 %attr(755,root,root) %{_bindir}/srptool
281 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
282 %{_mandir}/man1/certtool.1*
283 %{_mandir}/man1/gnutls-*.1*
284 %{_mandir}/man1/ocsptool.1*
285 %{_mandir}/man1/p11tool.1*
286 %{_mandir}/man1/psktool.1*
287 %{_mandir}/man1/srptool.1*
288 %{_mandir}/man1/tpmtool.1*
289 %{_infodir}/gnutls.info*
290 %{_infodir}/gnutls-*.png
291 %{_infodir}/pkcs11-vision.png
292
293 %files libs
294 %defattr(644,root,root,755)
295 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
296 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.30
297 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
298 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
299
300 %files devel
301 %defattr(644,root,root,755)
302 %attr(755,root,root) %{_libdir}/libgnutls.so
303 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
304 %{_libdir}/libgnutls.la
305 %{_libdir}/libgnutls-openssl.la
306 %{_includedir}/gnutls
307 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
308 %exclude %{_includedir}/gnutls/gnutlsxx.h
309 %{_pkgconfigdir}/gnutls.pc
310 %{_mandir}/man3/gnutls_*.3*
311
312 %if %{with static_libs}
313 %files static
314 %defattr(644,root,root,755)
315 %{_libdir}/libgnutls.a
316 %{_libdir}/libgnutls-openssl.a
317 %endif
318
319 %files c++
320 %defattr(644,root,root,755)
321 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
322 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
323
324 %files c++-devel
325 %defattr(644,root,root,755)
326 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
327 %{_libdir}/libgnutlsxx.la
328 %{_includedir}/gnutls/gnutlsxx.h
329
330 %if %{with static_libs}
331 %files c++-static
332 %defattr(644,root,root,755)
333 %{_libdir}/libgnutlsxx.a
334 %endif
335
336 %if %{with dane}
337 %files dane
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{_bindir}/danetool
340 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
341 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
342 %{_mandir}/man1/danetool.1*
343
344 %files dane-devel
345 %defattr(644,root,root,755)
346 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
347 %{_libdir}/libgnutls-dane.la
348 %{_includedir}/gnutls/dane.h
349 %{_pkgconfigdir}/gnutls-dane.pc
350
351 %if %{with static_libs}
352 %files dane-static
353 %defattr(644,root,root,755)
354 %{_libdir}/libgnutls-dane.a
355 %endif
356 %endif
357
358 %files -n guile-gnutls
359 %defattr(644,root,root,755)
360 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
361 %{_datadir}/guile/site/gnutls.scm
362 %{_datadir}/guile/site/gnutls
363 %{_infodir}/gnutls-guile.info*
This page took 0.046241 seconds and 2 git commands to generate.