]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
2ccc7e317d959af4fd721f92ae22b2f089f6fe53
[packages/gnustep-gui.git] / gnustep-gui.spec
1 #
2 # Conditional build:
3 %bcond_without  cups            # GSCUPS bundle
4 %bcond_without  magick          # ImageMagick support
5 %bcond_without  portaudio       # gsnd tool
6 #
7 Summary:        GNUstep GUI library package
8 Summary(pl.UTF-8):      Biblioteka GNUstep GUI
9 Name:           gnustep-gui
10 %define ver     0.24
11 Version:        %{ver}.0
12 Release:        7
13 License:        LGPL v2+ (library), GPL v3+ (applications)
14 Group:          Libraries
15 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
16 # Source0-md5:  bd289f0c7b2626d093ad92364069b9a7
17 Patch0:         %{name}-nocompressdocs.patch
18 Patch1:         %{name}-doc.patch
19 Patch2:         %{name}-giflib.patch
20 URL:            http://www.gnustep.org/
21 %{?with_magick:BuildRequires:   ImageMagick-devel}
22 BuildRequires:  aspell-devel
23 %{?with_cups:BuildRequires:     cups-devel}
24 BuildRequires:  flite-devel
25 BuildRequires:  gcc-objc
26 BuildRequires:  giflib-devel
27 BuildRequires:  gnustep-base-devel >= 1.13.0
28 BuildRequires:  gnustep-make-devel
29 BuildRequires:  libao-devel
30 BuildRequires:  libicns-devel
31 BuildRequires:  libicu-devel >= 4.0
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  libpng-devel
34 BuildRequires:  libsndfile-devel
35 BuildRequires:  libtiff-devel
36 BuildRequires:  pkgconfig
37 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
38 BuildRequires:  zlib-devel
39 Requires:       gnustep-base >= 1.13.0
40 Conflicts:      gnustep-core
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 It is a library of graphical user interface classes written completely
45 in the Objective-C language; the classes are based upon the OpenStep
46 specification as release by NeXT Software, Inc. The library does not
47 completely conform to the specification and has been enhanced in a
48 number of ways to take advantage of the GNU system. These classes
49 include graphical objects such as buttons, text fields, popup lists,
50 browser lists, and windows; there are also many associated classes for
51 handling events, colors, fonts, pasteboards and images.
52
53 %description -l pl.UTF-8
54 To jest biblioteka klas graficznego interfejsu użytkownika napisana w
55 Objective-C. Klasy bazują na specyfikacji OpenStep wypuszczonej przez
56 NeXT Software. Biblioteka nie jest całkowicie zgodna ze specyfikacją i
57 została rozszerzona, aby wykorzystać możliwości systemu GNU. Klasy
58 zawierają graficzne obiekty takie jak przyciski, pola tekstowe, listy
59 rozwijane, listy przewijane i okienka; jest także wiele klas do
60 obsługi zdarzeń, kolorów, fontów i obrazków.
61
62 %package devel
63 Summary:        GNUstep GUI headers and libs
64 Summary(pl.UTF-8):      Pliki nagłówkowe GNUstep GUI
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       gnustep-base-devel >= 1.13.0
68 Conflicts:      gnustep-core
69
70 %description devel
71 Header files required to build applications against the GNUstep GUI
72 library.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe potrzebne do budowania aplikacji korzystających z
76 biblioteki GNUstep GUI.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81 %patch1 -p1
82 %patch2 -p1
83
84 %build
85 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
86 export GNUSTEP_FLATTENED=yes
87 # disable gsnd - not ready for current portaudio
88 %configure \
89         %{!?with_cups:--disable-cups} \
90         %{!?with_portaudio:--disable-gsnd} \
91         %{?with_magick:--enable-imagemagick} \
92         --enable-libgif \
93         --disable-ungif
94
95 # with __make -jN we can got non-deterministic errors
96 %{__make} -j1 \
97         messages=yes
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
102 export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
103 export GNUSTEP_FLATTENED=yes
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 %{__make} install -C Documentation \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
112         -type f -name .cvsignore | xargs rm -f
113
114 # not (yet?) supported by rpm-compress-doc
115 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
116         -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc ChangeLog
127 %docdir %{_datadir}/GNUstep/Documentation
128 %dir %{_datadir}/GNUstep/Documentation/Developer
129 %dir %{_datadir}/GNUstep/Documentation/Developer/Gui
130 %{_datadir}/GNUstep/Documentation/Developer/Gui/ReleaseNotes
131 %{_datadir}/GNUstep/Documentation/User
132
133 %{_mandir}/man1/gclose.1*
134 %{_mandir}/man1/gcloseall.1*
135 %{_mandir}/man1/gopen.1*
136 %{_mandir}/man1/make_services.1*
137 %{_mandir}/man1/set_show_service.1*
138
139 %attr(755,root,root) %{_bindir}/GSSpeechServer
140 %attr(755,root,root) %{_bindir}/gclose
141 %attr(755,root,root) %{_bindir}/gcloseall
142 %attr(755,root,root) %{_bindir}/gopen
143 %attr(755,root,root) %{_bindir}/make_services
144 %attr(755,root,root) %{_bindir}/say
145 %attr(755,root,root) %{_bindir}/set_show_service
146 %attr(755,root,root) %{_libdir}/libgnustep-gui.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libgnustep-gui.so.%{ver}
148
149 # XXX: shared with WindowMaker - move to gnustep-dirs?
150 %dir %{_libdir}/GNUstep/Applications
151
152 %dir %{_libdir}/GNUstep/Applications/GSSpeechServer.app
153 %attr(755,root,root) %{_libdir}/GNUstep/Applications/GSSpeechServer.app/GSSpeechServer
154 %{_libdir}/GNUstep/Applications/GSSpeechServer.app/Resources
155 %{_libdir}/GNUstep/Applications/GSSpeechServer.app/stamp.make
156
157 %dir %{_libdir}/GNUstep/Bundles
158
159 %dir %{_libdir}/GNUstep/Bundles/AudioOutput.nssound
160 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/AudioOutput
161 %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/Resources
162 %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/stamp.make
163
164 %dir %{_libdir}/GNUstep/Bundles/GSPrinting
165 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle
166 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/GSLPR
167 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/Resources
168 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/stamp.make
169 %if %{with cups}
170 # R: cups-lib - separate?
171 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle
172 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
173 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/Resources
174 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/stamp.make
175 %endif
176
177 %dir %{_libdir}/GNUstep/Bundles/Sndfile.nssound
178 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/Sndfile.nssound/Sndfile
179 %{_libdir}/GNUstep/Bundles/Sndfile.nssound/Resources
180 %{_libdir}/GNUstep/Bundles/Sndfile.nssound/stamp.make
181
182 %dir %{_libdir}/GNUstep/Bundles/TextConverters
183 %dir %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle
184 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/RTFConverter
185 %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/Resources
186 %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/stamp.make
187
188 %dir %{_libdir}/GNUstep/Bundles/libgmodel.bundle
189 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgmodel.bundle/libgmodel
190 %{_libdir}/GNUstep/Bundles/libgmodel.bundle/Resources
191 %{_libdir}/GNUstep/Bundles/libgmodel.bundle/stamp.make
192
193 %dir %{_libdir}/GNUstep/ColorPickers
194
195 %dir %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle
196 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/NamedPicker
197 %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/Resources
198 %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/stamp.make
199
200 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle
201 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/StandardPicker
202 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources
203 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.tiff
204 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.plist
205 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/English.lproj
206 %lang(fr) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/French.lproj
207 %lang(es) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Spanish.lproj
208 %lang(sv) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
209 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/stamp.make
210
211 %dir %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle
212 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/WheelPicker
213 %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/Resources
214 %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/stamp.make
215
216 %{_libdir}/GNUstep/Images
217 %{_libdir}/GNUstep/KeyBindings
218
219 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui
220 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions
221 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}
222 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources
223 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/*.plist
224 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/English.lproj
225 %lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Esperanto.lproj
226 %lang(fr) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/French.lproj
227 %lang(de) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/German.lproj
228 %lang(it) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Italian.lproj
229 %lang(jbo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Lojban.lproj
230 %lang(es) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Spanish.lproj
231
232 %dir %{_libdir}/GNUstep/PostScript
233 %{_libdir}/GNUstep/PostScript/GSProlog.ps
234 %dir %{_libdir}/GNUstep/PostScript/PPD
235 %{_libdir}/GNUstep/PostScript/PPD/English.lproj
236
237 %dir %{_libdir}/GNUstep/Services
238
239 %dir %{_libdir}/GNUstep/Services/GSspell.service
240 %attr(755,root,root) %{_libdir}/GNUstep/Services/GSspell.service/GSspell
241 %{_libdir}/GNUstep/Services/GSspell.service/Resources
242
243 %{_libdir}/GNUstep/Sounds
244
245 %files devel
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_libdir}/libgnustep-gui.so
248 %{_includedir}/AppKit
249 %{_includedir}/Cocoa
250 %{_includedir}/GNUstepGUI
251 %{_includedir}/gnustep/gui
252
253 %docdir %{_datadir}/GNUstep/Documentation
254 %{_datadir}/GNUstep/Documentation/Developer/Gui/Additions
255 %{_datadir}/GNUstep/Documentation/Developer/Gui/General
256 %{_datadir}/GNUstep/Documentation/Developer/Gui/ProgrammingManual
257 %{_datadir}/GNUstep/Documentation/Developer/Gui/Reference
258 %{_infodir}/AppKit.info*
259
260 %{_datadir}/GNUstep/Makefiles/Additional/gui.make
This page took 0.053329 seconds and 2 git commands to generate.