]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- release 15 (by relup.sh)
[packages/gnustep-gui.git] / gnustep-gui.spec
1 #
2 # Conditional build:
3 %bcond_without  cups            # GSCUPS bundle
4 %bcond_without  magick          # ImageMagick support
5 %bcond_without  portaudio       # gsnd tool
6 #
7 Summary:        GNUstep GUI library package
8 Summary(pl.UTF-8):      Biblioteka GNUstep GUI
9 Name:           gnustep-gui
10 %define ver     0.24
11 Version:        %{ver}.0
12 Release:        15
13 License:        LGPL v2+ (library), GPL v3+ (applications)
14 Group:          Libraries
15 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
16 # Source0-md5:  bd289f0c7b2626d093ad92364069b9a7
17 Patch0:         %{name}-nocompressdocs.patch
18 Patch1:         %{name}-doc.patch
19 Patch2:         %{name}-giflib.patch
20 Patch3:         imagemagick7.patch
21 URL:            http://www.gnustep.org/
22 %{?with_magick:BuildRequires:   ImageMagick-devel}
23 BuildRequires:  aspell-devel
24 %{?with_cups:BuildRequires:     cups-devel}
25 BuildRequires:  flite-devel
26 BuildRequires:  gcc-objc
27 BuildRequires:  giflib-devel
28 BuildRequires:  gnustep-base-devel >= 1.13.0
29 BuildRequires:  gnustep-make-devel
30 BuildRequires:  libao-devel
31 BuildRequires:  libicns-devel
32 BuildRequires:  libicu-devel >= 4.0
33 BuildRequires:  libjpeg-devel
34 BuildRequires:  libpng-devel
35 BuildRequires:  libsndfile-devel
36 BuildRequires:  libtiff-devel
37 BuildRequires:  pkgconfig
38 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
39 BuildRequires:  zlib-devel
40 Requires:       gnustep-base >= 1.13.0
41 Conflicts:      gnustep-core
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 It is a library of graphical user interface classes written completely
46 in the Objective-C language; the classes are based upon the OpenStep
47 specification as release by NeXT Software, Inc. The library does not
48 completely conform to the specification and has been enhanced in a
49 number of ways to take advantage of the GNU system. These classes
50 include graphical objects such as buttons, text fields, popup lists,
51 browser lists, and windows; there are also many associated classes for
52 handling events, colors, fonts, pasteboards and images.
53
54 %description -l pl.UTF-8
55 To jest biblioteka klas graficznego interfejsu użytkownika napisana w
56 Objective-C. Klasy bazują na specyfikacji OpenStep wypuszczonej przez
57 NeXT Software. Biblioteka nie jest całkowicie zgodna ze specyfikacją i
58 została rozszerzona, aby wykorzystać możliwości systemu GNU. Klasy
59 zawierają graficzne obiekty takie jak przyciski, pola tekstowe, listy
60 rozwijane, listy przewijane i okienka; jest także wiele klas do
61 obsługi zdarzeń, kolorów, fontów i obrazków.
62
63 %package devel
64 Summary:        GNUstep GUI headers and libs
65 Summary(pl.UTF-8):      Pliki nagłówkowe GNUstep GUI
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       gnustep-base-devel >= 1.13.0
69 Conflicts:      gnustep-core
70
71 %description devel
72 Header files required to build applications against the GNUstep GUI
73 library.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe potrzebne do budowania aplikacji korzystających z
77 biblioteki GNUstep GUI.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p1
84 %patch3 -p1
85
86 %build
87 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
88 export GNUSTEP_FLATTENED=yes
89 # disable gsnd - not ready for current portaudio
90 %configure \
91         %{!?with_cups:--disable-cups} \
92         %{!?with_portaudio:--disable-gsnd} \
93         %{?with_magick:--enable-imagemagick} \
94         --enable-libgif \
95         --disable-ungif
96
97 # with __make -jN we can got non-deterministic errors
98 %{__make} -j1 \
99         messages=yes
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
104 export GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
105 export GNUSTEP_FLATTENED=yes
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %{__make} install -C Documentation \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
114         -type f -name .cvsignore | xargs rm -f
115
116 # not (yet?) supported by rpm-compress-doc
117 find $RPM_BUILD_ROOT%{_datadir}/GNUstep/Documentation \
118         -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc ChangeLog
129 %docdir %{_datadir}/GNUstep/Documentation
130 %dir %{_datadir}/GNUstep/Documentation/Developer
131 %dir %{_datadir}/GNUstep/Documentation/Developer/Gui
132 %{_datadir}/GNUstep/Documentation/Developer/Gui/ReleaseNotes
133 %{_datadir}/GNUstep/Documentation/User
134
135 %{_mandir}/man1/gclose.1*
136 %{_mandir}/man1/gcloseall.1*
137 %{_mandir}/man1/gopen.1*
138 %{_mandir}/man1/make_services.1*
139 %{_mandir}/man1/set_show_service.1*
140
141 %attr(755,root,root) %{_bindir}/GSSpeechServer
142 %attr(755,root,root) %{_bindir}/gclose
143 %attr(755,root,root) %{_bindir}/gcloseall
144 %attr(755,root,root) %{_bindir}/gopen
145 %attr(755,root,root) %{_bindir}/make_services
146 %attr(755,root,root) %{_bindir}/say
147 %attr(755,root,root) %{_bindir}/set_show_service
148 %attr(755,root,root) %{_libdir}/libgnustep-gui.so.*.*.*
149 %attr(755,root,root) %ghost %{_libdir}/libgnustep-gui.so.%{ver}
150
151 # XXX: shared with WindowMaker - move to gnustep-dirs?
152 %dir %{_libdir}/GNUstep/Applications
153
154 %dir %{_libdir}/GNUstep/Applications/GSSpeechServer.app
155 %attr(755,root,root) %{_libdir}/GNUstep/Applications/GSSpeechServer.app/GSSpeechServer
156 %{_libdir}/GNUstep/Applications/GSSpeechServer.app/Resources
157 %{_libdir}/GNUstep/Applications/GSSpeechServer.app/stamp.make
158
159 %dir %{_libdir}/GNUstep/Bundles
160
161 %dir %{_libdir}/GNUstep/Bundles/AudioOutput.nssound
162 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/AudioOutput
163 %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/Resources
164 %{_libdir}/GNUstep/Bundles/AudioOutput.nssound/stamp.make
165
166 %dir %{_libdir}/GNUstep/Bundles/GSPrinting
167 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle
168 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/GSLPR
169 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/Resources
170 %{_libdir}/GNUstep/Bundles/GSPrinting/GSLPR.bundle/stamp.make
171 %if %{with cups}
172 # R: cups-lib - separate?
173 %dir %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle
174 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
175 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/Resources
176 %{_libdir}/GNUstep/Bundles/GSPrinting/GSCUPS.bundle/stamp.make
177 %endif
178
179 %dir %{_libdir}/GNUstep/Bundles/Sndfile.nssound
180 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/Sndfile.nssound/Sndfile
181 %{_libdir}/GNUstep/Bundles/Sndfile.nssound/Resources
182 %{_libdir}/GNUstep/Bundles/Sndfile.nssound/stamp.make
183
184 %dir %{_libdir}/GNUstep/Bundles/TextConverters
185 %dir %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle
186 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/RTFConverter
187 %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/Resources
188 %{_libdir}/GNUstep/Bundles/TextConverters/RTFConverter.bundle/stamp.make
189
190 %dir %{_libdir}/GNUstep/Bundles/libgmodel.bundle
191 %attr(755,root,root) %{_libdir}/GNUstep/Bundles/libgmodel.bundle/libgmodel
192 %{_libdir}/GNUstep/Bundles/libgmodel.bundle/Resources
193 %{_libdir}/GNUstep/Bundles/libgmodel.bundle/stamp.make
194
195 %dir %{_libdir}/GNUstep/ColorPickers
196
197 %dir %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle
198 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/NamedPicker
199 %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/Resources
200 %{_libdir}/GNUstep/ColorPickers/NamedPicker.bundle/stamp.make
201
202 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle
203 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/StandardPicker
204 %dir %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources
205 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.tiff
206 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/*.plist
207 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/English.lproj
208 %lang(fr) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/French.lproj
209 %lang(es) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Spanish.lproj
210 %lang(sv) %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
211 %{_libdir}/GNUstep/ColorPickers/StandardPicker.bundle/stamp.make
212
213 %dir %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle
214 %attr(755,root,root) %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/WheelPicker
215 %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/Resources
216 %{_libdir}/GNUstep/ColorPickers/WheelPicker.bundle/stamp.make
217
218 %{_libdir}/GNUstep/Images
219 %{_libdir}/GNUstep/KeyBindings
220
221 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui
222 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions
223 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}
224 %dir %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources
225 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/*.plist
226 %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/English.lproj
227 %lang(eo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Esperanto.lproj
228 %lang(fr) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/French.lproj
229 %lang(de) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/German.lproj
230 %lang(it) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Italian.lproj
231 %lang(jbo) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Lojban.lproj
232 %lang(es) %{_libdir}/GNUstep/Libraries/gnustep-gui/Versions/%{ver}/Resources/Spanish.lproj
233
234 %dir %{_libdir}/GNUstep/PostScript
235 %{_libdir}/GNUstep/PostScript/GSProlog.ps
236 %dir %{_libdir}/GNUstep/PostScript/PPD
237 %{_libdir}/GNUstep/PostScript/PPD/English.lproj
238
239 %dir %{_libdir}/GNUstep/Services
240
241 %dir %{_libdir}/GNUstep/Services/GSspell.service
242 %attr(755,root,root) %{_libdir}/GNUstep/Services/GSspell.service/GSspell
243 %{_libdir}/GNUstep/Services/GSspell.service/Resources
244
245 %{_libdir}/GNUstep/Sounds
246
247 %files devel
248 %defattr(644,root,root,755)
249 %attr(755,root,root) %{_libdir}/libgnustep-gui.so
250 %{_includedir}/AppKit
251 %{_includedir}/Cocoa
252 %{_includedir}/GNUstepGUI
253 %{_includedir}/gnustep/gui
254
255 %docdir %{_datadir}/GNUstep/Documentation
256 %{_datadir}/GNUstep/Documentation/Developer/Gui/Additions
257 %{_datadir}/GNUstep/Documentation/Developer/Gui/General
258 %{_datadir}/GNUstep/Documentation/Developer/Gui/ProgrammingManual
259 %{_datadir}/GNUstep/Documentation/Developer/Gui/Reference
260 %{_infodir}/AppKit.info*
261
262 %{_datadir}/GNUstep/Makefiles/Additional/gui.make
This page took 0.125522 seconds and 3 git commands to generate.