]> git.pld-linux.org Git - packages/gnuastro.git/blob - gnuastro.spec
- updated to 0.17
[packages/gnuastro.git] / gnuastro.spec
1 # TODO: ds9, topcat (for Suggests)
2 #       https://sites.google.com/cfa.harvard.edu/saoimageds9
3 #       http://www.star.bris.ac.uk/~mbt/topcat/
4 #
5 # Conditional build:
6 %bcond_without  static_libs     # static library
7
8 Summary:        GNU Astronomy Utilities
9 Summary(pl.UTF-8):      Narzędzia astronomiczne GNU
10 Name:           gnuastro
11 Version:        0.17
12 Release:        1
13 License:        GPL v3+
14 Group:          Applications/Science
15 Source0:        https://ftp.gnu.org/gnu/gnuastro/%{name}-%{version}.tar.lz
16 # Source0-md5:  dc1a9d0dba6550cc8eded53ecfd7535a
17 Patch0:         %{name}-info.patch
18 Patch1:         ac.patch
19 URL:            http://www.gnu.org/software/gnuastro/
20 BuildRequires:  autoconf >= 2.69
21 BuildRequires:  automake
22 BuildRequires:  bzip2-devel
23 BuildRequires:  cfitsio-devel
24 BuildRequires:  curl-devel
25 BuildRequires:  ghostscript >= 9.10
26 BuildRequires:  gsl-devel >= 2.0
27 BuildRequires:  help2man
28 BuildRequires:  libgit2-devel
29 BuildRequires:  libjpeg-devel
30 BuildRequires:  libtiff-devel
31 BuildRequires:  libtool >= 2:2
32 BuildRequires:  lzip
33 BuildRequires:  rpm-build >= 4.6
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  wcslib-devel
36 BuildRequires:  xz-devel
37 BuildRequires:  zlib-devel
38 Suggests:       ghostscript >= 9.10
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 GNU Astronomy Utilities (Gnuastro) is an official GNU package of
43 programs and a library functions for astronomical data manipulation
44 and analysis. The programs are run on the operating system's
45 command-line enabling easy and efficient operation combined with other
46 installed programs in shell scripts or Makefiles. The libraries are
47 also usable in C and C++ programs.
48
49 %description -l pl.UTF-8
50 GNU Astronomy Utilities (Gnuastro) to oficjalny pakiet GNU zawierający
51 programy i funkcje biblioteczne do obróbki i analiz danych
52 astronomicznych. Programy są uruchamiane z wiersza poleceń systemu
53 operacyjnego, co pozwala na łatwe i wydajne operowanie w połączeniu z
54 innymi zainstalowanymi programami lub z poziomu plików Makefile.
55 Biblioteki mogą być używane w programach w C i C++.
56
57 %package devel
58 Summary:        Header files for Gnuastro library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Gnuastro
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       cfitsio-devel
63 Requires:       gsl-devel
64 Requires:       libgit2-devel
65 Requires:       libjpeg-devel
66 Requires:       libtiff-devel >= 4
67 Requires:       wcslib-devel
68 Requires:       xz-devel
69
70 %description devel
71 Header files for Gnuastro library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki Gnuastro.
75
76 %package static
77 Summary:        Static Gnuastro library
78 Summary(pl.UTF-8):      Statyczna biblioteka Gnuastro
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static Gnuastro library.
84
85 %description static -l pl.UTF-8
86 Statyczna biblioteka Gnuastro.
87
88 %package -n bash-completion-gnuastro
89 Summary:        Bash completion for gnuastro commands
90 Summary(pl.UTF-8):      Bashowe uzupełnianie składni poleceń gnuastro
91 Group:          Applications/Shells
92 Requires:       %{name} = %{version}-%{release}
93 Requires:       bash-completion >= 2.0
94 BuildArch:      noarch
95
96 %description -n bash-completion-gnuastro
97 Bash completion for gnuastro commands.
98
99 %description -n bash-completion-gnuastro -l pl.UTF-8
100 Bashowe uzupełnianie składni poleceń gnuastro.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106
107 %build
108 # regenerate for as-needed to work
109 %{__libtoolize}
110 %{__aclocal} -I bootstrapped/m4
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         --sysconfdir=%{_sysconfdir}/gnuastro \
116         %{!?with_static_libs:--disable-static}
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 # obsoleted by pkg-config
126 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgnuastro.la
127 # packaged as %doc
128 %{__rm} $RPM_BUILD_ROOT%{_docdir}/gnuastro/README
129
130 install -d $RPM_BUILD_ROOT%{bash_compdir}
131 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gnuastro/completion.bash $RPM_BUILD_ROOT%{bash_compdir}/gnuastro
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/postshell
137 -/sbin/ldconfig
138 -/usr/sbin/fix-info-dir -c %{_infodir}
139
140 %postun -p /sbin/postshell
141 -/sbin/ldconfig
142 -/usr/sbin/fix-info-dir -c %{_infodir}
143
144 %files
145 %defattr(644,root,root,755)
146 %doc AUTHORS ChangeLog NEWS README THANKS
147 %attr(755,root,root) %{_bindir}/astarithmetic
148 %attr(755,root,root) %{_bindir}/astbuildprog
149 %attr(755,root,root) %{_bindir}/astconvertt
150 %attr(755,root,root) %{_bindir}/astconvolve
151 %attr(755,root,root) %{_bindir}/astcosmiccal
152 %attr(755,root,root) %{_bindir}/astcrop
153 %attr(755,root,root) %{_bindir}/astfits
154 %attr(755,root,root) %{_bindir}/astmatch
155 %attr(755,root,root) %{_bindir}/astmkcatalog
156 %attr(755,root,root) %{_bindir}/astmknoise
157 %attr(755,root,root) %{_bindir}/astmkprof
158 %attr(755,root,root) %{_bindir}/astnoisechisel
159 %attr(755,root,root) %{_bindir}/astquery
160 %attr(755,root,root) %{_bindir}/astscript-ds9-region
161 %attr(755,root,root) %{_bindir}/astscript-fits-view
162 %attr(755,root,root) %{_bindir}/astscript-psf-scale-factor
163 %attr(755,root,root) %{_bindir}/astscript-psf-select-stars
164 %attr(755,root,root) %{_bindir}/astscript-psf-stamp
165 %attr(755,root,root) %{_bindir}/astscript-psf-subtract
166 %attr(755,root,root) %{_bindir}/astscript-psf-unite
167 %attr(755,root,root) %{_bindir}/astscript-radial-profile
168 %attr(755,root,root) %{_bindir}/astscript-sort-by-night
169 %attr(755,root,root) %{_bindir}/astsegment
170 %attr(755,root,root) %{_bindir}/aststatistics
171 %attr(755,root,root) %{_bindir}/asttable
172 %attr(755,root,root) %{_bindir}/astwarp
173 %attr(755,root,root) %{_libdir}/libgnuastro.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libgnuastro.so.15
175 %dir %{_sysconfdir}/gnuastro
176 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/ast*.conf
177 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/gnuastro.conf
178 %{_datadir}/gnuastro
179 %{_infodir}/gnuastro.info*
180 %{_infodir}/gnuastro-figures
181 %{_mandir}/man1/astarithmetic.1*
182 %{_mandir}/man1/astbuildprog.1*
183 %{_mandir}/man1/astconvertt.1*
184 %{_mandir}/man1/astconvolve.1*
185 %{_mandir}/man1/astcosmiccal.1*
186 %{_mandir}/man1/astcrop.1*
187 %{_mandir}/man1/astfits.1*
188 %{_mandir}/man1/astmatch.1*
189 %{_mandir}/man1/astmkcatalog.1*
190 %{_mandir}/man1/astmknoise.1*
191 %{_mandir}/man1/astmkprof.1*
192 %{_mandir}/man1/astnoisechisel.1*
193 %{_mandir}/man1/astquery.1*
194 %{_mandir}/man1/astscript-ds9-region.1*
195 %{_mandir}/man1/astscript-fits-view.1*
196 %{_mandir}/man1/astscript-psf-scale-factor.1*
197 %{_mandir}/man1/astscript-psf-select-stars.1*
198 %{_mandir}/man1/astscript-psf-stamp.1*
199 %{_mandir}/man1/astscript-psf-subtract.1*
200 %{_mandir}/man1/astscript-psf-unite.1*
201 %{_mandir}/man1/astscript-radial-profile.1*
202 %{_mandir}/man1/astscript-sort-by-night.1*
203 %{_mandir}/man1/astsegment.1*
204 %{_mandir}/man1/aststatistics.1*
205 %{_mandir}/man1/asttable.1*
206 %{_mandir}/man1/astwarp.1*
207
208 %files devel
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_libdir}/libgnuastro.so
211 %{_includedir}/gnuastro
212 %{_pkgconfigdir}/gnuastro.pc
213
214 %if %{with static_libs}
215 %files static
216 %defattr(644,root,root,755)
217 %{_libdir}/libgnuastro.a
218 %endif
219
220 %files -n bash-completion-gnuastro
221 %defattr(644,root,root,755)
222 %{bash_compdir}/gnuastro
This page took 0.060648 seconds and 4 git commands to generate.