]> git.pld-linux.org Git - packages/gnuastro.git/blob - gnuastro.spec
- release 2 (by relup.sh)
[packages/gnuastro.git] / gnuastro.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        GNU Astronomy Utilities
6 Summary(pl.UTF-8):      Narzędzia astronomiczne GNU
7 Name:           gnuastro
8 Version:        0.11
9 Release:        2
10 License:        GPL v3+
11 Group:          Applications/Science
12 Source0:        https://ftp.gnu.org/gnu/gnuastro/%{name}-%{version}.tar.lz
13 # Source0-md5:  5fcb6f89710d9047dabeaec6fe054b43
14 Patch0:         %{name}-info.patch
15 URL:            http://www.gnu.org/software/gnuastro/
16 BuildRequires:  autoconf >= 2.69
17 BuildRequires:  automake
18 BuildRequires:  cfitsio-devel
19 BuildRequires:  curl-devel
20 BuildRequires:  ghostscript >= 9.10
21 BuildRequires:  gsl-devel >= 2.0
22 BuildRequires:  help2man
23 BuildRequires:  libgit2-devel
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  libtiff-devel
26 BuildRequires:  libtool >= 2:2
27 BuildRequires:  lzip
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  wcslib-devel
30 BuildRequires:  xz-devel
31 Suggests:       ghostscript >= 9.10
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 GNU Astronomy Utilities (Gnuastro) is an official GNU package of
36 programs and a library functions for astronomical data manipulation
37 and analysis. The programs are run on the operating system's
38 command-line enabling easy and efficient operation combined with other
39 installed programs in shell scripts or Makefiles. The libraries are
40 also usable in C and C++ programs.
41
42 %description -l pl.UTF-8
43 GNU Astronomy Utilities (Gnuastro) to oficjalny pakiet GNU zawierający
44 programy i funkcje biblioteczne do obróbki i analiz danych
45 astronomicznych. Programy są uruchamiane z wiersza poleceń systemu
46 operacyjnego, co pozwala na łatwe i wydajne operowanie w połączeniu z
47 innymi zainstalowanymi programami lub z poziomu plików Makefile.
48 Biblioteki mogą być używane w programach w C i C++.
49
50 %package devel
51 Summary:        Header files for Gnuastro library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Gnuastro
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       cfitsio-devel
56 Requires:       gsl-devel
57 Requires:       libgit2-devel
58 Requires:       libjpeg-devel
59 Requires:       libtiff-devel >= 4
60 Requires:       wcslib-devel
61 Requires:       xz-devel
62
63 %description devel
64 Header files for Gnuastro library.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe biblioteki Gnuastro.
68
69 %package static
70 Summary:        Static Gnuastro library
71 Summary(pl.UTF-8):      Statyczna biblioteka Gnuastro
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static Gnuastro library.
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka Gnuastro.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84
85 %build
86 # regenerate for as-needed to work
87 %{__libtoolize}
88 %{__aclocal} -I bootstrapped/m4
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92 %configure \
93         --sysconfdir=%{_sysconfdir}/gnuastro \
94         %{!?with_static_libs:--disable-static}
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 # obsoleted by pkg-config
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgnuastro.la
105 # packaged as %doc
106 %{__rm} $RPM_BUILD_ROOT%{_docdir}/gnuastro/README
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/postshell
112 -/sbin/ldconfig
113 -/usr/sbin/fix-info-dir -c %{_infodir}
114
115 %postun -p /sbin/postshell
116 -/sbin/ldconfig
117 -/usr/sbin/fix-info-dir -c %{_infodir}
118
119 %files
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog NEWS README THANKS
122 %attr(755,root,root) %{_bindir}/astarithmetic
123 %attr(755,root,root) %{_bindir}/astbuildprog
124 %attr(755,root,root) %{_bindir}/astconvertt
125 %attr(755,root,root) %{_bindir}/astconvolve
126 %attr(755,root,root) %{_bindir}/astcosmiccal
127 %attr(755,root,root) %{_bindir}/astcrop
128 %attr(755,root,root) %{_bindir}/astfits
129 %attr(755,root,root) %{_bindir}/astmatch
130 %attr(755,root,root) %{_bindir}/astmkcatalog
131 %attr(755,root,root) %{_bindir}/astmknoise
132 %attr(755,root,root) %{_bindir}/astmkprof
133 %attr(755,root,root) %{_bindir}/astnoisechisel
134 %attr(755,root,root) %{_bindir}/astscript-sort-by-night
135 %attr(755,root,root) %{_bindir}/astsegment
136 %attr(755,root,root) %{_bindir}/aststatistics
137 %attr(755,root,root) %{_bindir}/asttable
138 %attr(755,root,root) %{_bindir}/astwarp
139 %attr(755,root,root) %{_libdir}/libgnuastro.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libgnuastro.so.9
141 %dir %{_sysconfdir}/gnuastro
142 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/ast*.conf
143 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/gnuastro.conf
144 %{_infodir}/gnuastro.info*
145 %{_infodir}/gnuastro-figures
146 %{_mandir}/man1/astarithmetic.1*
147 %{_mandir}/man1/astbuildprog.1*
148 %{_mandir}/man1/astconvertt.1*
149 %{_mandir}/man1/astconvolve.1*
150 %{_mandir}/man1/astcosmiccal.1*
151 %{_mandir}/man1/astcrop.1*
152 %{_mandir}/man1/astfits.1*
153 %{_mandir}/man1/astmatch.1*
154 %{_mandir}/man1/astmkcatalog.1*
155 %{_mandir}/man1/astmknoise.1*
156 %{_mandir}/man1/astmkprof.1*
157 %{_mandir}/man1/astnoisechisel.1*
158 %{_mandir}/man1/astscript-sort-by-night.1*
159 %{_mandir}/man1/astsegment.1*
160 %{_mandir}/man1/aststatistics.1*
161 %{_mandir}/man1/asttable.1*
162 %{_mandir}/man1/astwarp.1*
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libgnuastro.so
167 %{_includedir}/gnuastro
168 %{_pkgconfigdir}/gnuastro.pc
169
170 %if %{with static_libs}
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/libgnuastro.a
174 %endif
This page took 0.074482 seconds and 4 git commands to generate.