]> git.pld-linux.org Git - packages/gnuastro.git/blob - gnuastro.spec
- release 2 (by relup.sh)
[packages/gnuastro.git] / gnuastro.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        GNU Astronomy Utilities
6 Summary(pl.UTF-8):      Narzędzia astronomiczne GNU
7 Name:           gnuastro
8 Version:        0.5
9 Release:        2
10 License:        GPL v3+
11 Group:          Applications/Science
12 Source0:        http://ftp.gnu.org/gnu/gnuastro/%{name}-%{version}.tar.lz
13 # Source0-md5:  2ed4ed0357a373c19291b1c67fd8bd8f
14 Patch0:         %{name}-info.patch
15 URL:            http://www.gnu.org/software/gnuastro/
16 BuildRequires:  autoconf >= 2.69
17 BuildRequires:  automake
18 BuildRequires:  cfitsio-devel
19 BuildRequires:  curl-devel
20 BuildRequires:  ghostscript >= 9.10
21 BuildRequires:  gsl-devel
22 BuildRequires:  help2man
23 BuildRequires:  libgit2-devel
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  libtool >= 2:2
26 BuildRequires:  lzip
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  wcslib-devel
29 Suggests:       ghostscript >= 9.10
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 GNU Astronomy Utilities (Gnuastro) is an official GNU package of
34 programs and a library functions for astronomical data manipulation
35 and analysis. The programs are run on the operating system's
36 command-line enabling easy and efficient operation combined with other
37 installed programs in shell scripts or Makefiles. The libraries are
38 also usable in C and C++ programs.
39
40 %description -l pl.UTF-8
41 GNU Astronomy Utilities (Gnuastro) to oficjalny pakiet GNU zawierający
42 programy i funkcje biblioteczne do obróbki i analiz danych
43 astronomicznych. Programy są uruchamiane z wiersza poleceń systemu
44 operacyjnego, co pozwala na łatwe i wydajne operowanie w połączeniu z
45 innymi zainstalowanymi programami lub z poziomu plików Makefile.
46 Biblioteki mogą być używane w programach w C i C++.
47
48 %package devel
49 Summary:        Header files for Gnuastro library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Gnuastro
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       cfitsio-devel
54 Requires:       gsl-devel
55 Requires:       libgit2-devel
56 Requires:       wcslib-devel
57
58 %description devel
59 Header files for Gnuastro library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki Gnuastro.
63
64 %package static
65 Summary:        Static Gnuastro library
66 Summary(pl.UTF-8):      Statyczna biblioteka Gnuastro
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static Gnuastro library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka Gnuastro.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79
80 %build
81 # regenerate for as-needed to work
82 %{__libtoolize}
83 %{__aclocal} -I bootstrapped/m4
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure \
88         --sysconfdir=%{_sysconfdir}/gnuastro \
89         %{!?with_static_libs:--disable-static}
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 # obsoleted by pkg-config
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgnuastro.la
100 # packaged as %doc
101 %{__rm} $RPM_BUILD_ROOT%{_docdir}/gnuastro/README
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/postshell
107 -/sbin/ldconfig
108 -/usr/sbin/fix-info-dir -c %{_infodir}
109
110 %postun -p /sbin/postshell
111 -/sbin/ldconfig
112 -/usr/sbin/fix-info-dir -c %{_infodir}
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS ChangeLog NEWS README THANKS
117 %attr(755,root,root) %{_bindir}/astarithmetic
118 %attr(755,root,root) %{_bindir}/astbuildprog
119 %attr(755,root,root) %{_bindir}/astconvertt
120 %attr(755,root,root) %{_bindir}/astconvolve
121 %attr(755,root,root) %{_bindir}/astcosmiccal
122 %attr(755,root,root) %{_bindir}/astcrop
123 %attr(755,root,root) %{_bindir}/astfits
124 %attr(755,root,root) %{_bindir}/astmatch
125 %attr(755,root,root) %{_bindir}/astmkcatalog
126 %attr(755,root,root) %{_bindir}/astmknoise
127 %attr(755,root,root) %{_bindir}/astmkprof
128 %attr(755,root,root) %{_bindir}/astnoisechisel
129 %attr(755,root,root) %{_bindir}/aststatistics
130 %attr(755,root,root) %{_bindir}/asttable
131 %attr(755,root,root) %{_bindir}/astwarp
132 %attr(755,root,root) %{_libdir}/libgnuastro.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libgnuastro.so.3
134 %dir %{_sysconfdir}/gnuastro
135 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/ast*.conf
136 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/gnuastro.conf
137 %{_infodir}/gnuastro.info*
138 %{_infodir}/gnuastro-figures
139 %{_mandir}/man1/astarithmetic.1*
140 %{_mandir}/man1/astbuildprog.1*
141 %{_mandir}/man1/astconvertt.1*
142 %{_mandir}/man1/astconvolve.1*
143 %{_mandir}/man1/astcosmiccal.1*
144 %{_mandir}/man1/astcrop.1*
145 %{_mandir}/man1/astfits.1*
146 %{_mandir}/man1/astmatch.1*
147 %{_mandir}/man1/astmkcatalog.1*
148 %{_mandir}/man1/astmknoise.1*
149 %{_mandir}/man1/astmkprof.1*
150 %{_mandir}/man1/astnoisechisel.1*
151 %{_mandir}/man1/aststatistics.1*
152 %{_mandir}/man1/asttable.1*
153 %{_mandir}/man1/astwarp.1*
154
155 %files devel
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/libgnuastro.so
158 %{_includedir}/gnuastro
159 %{_pkgconfigdir}/gnuastro.pc
160
161 %if %{with static_libs}
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libgnuastro.a
165 %endif
This page took 0.073436 seconds and 4 git commands to generate.