]> git.pld-linux.org Git - packages/gnuastro.git/blob - gnuastro.spec
- updated to 0.7 (new soname)
[packages/gnuastro.git] / gnuastro.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        GNU Astronomy Utilities
6 Summary(pl.UTF-8):      Narzędzia astronomiczne GNU
7 Name:           gnuastro
8 Version:        0.7
9 Release:        1
10 License:        GPL v3+
11 Group:          Applications/Science
12 Source0:        http://ftp.gnu.org/gnu/gnuastro/%{name}-%{version}.tar.lz
13 # Source0-md5:  f0c852755e3ca6a3ade66d5b6fa580c8
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-sh.patch
16 URL:            http://www.gnu.org/software/gnuastro/
17 BuildRequires:  autoconf >= 2.69
18 BuildRequires:  automake
19 BuildRequires:  cfitsio-devel
20 BuildRequires:  curl-devel
21 BuildRequires:  ghostscript >= 9.10
22 BuildRequires:  gsl-devel
23 BuildRequires:  help2man
24 BuildRequires:  libgit2-devel
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libtiff-devel
27 BuildRequires:  libtool >= 2:2
28 BuildRequires:  lzip
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  wcslib-devel
31 Suggests:       ghostscript >= 9.10
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 GNU Astronomy Utilities (Gnuastro) is an official GNU package of
36 programs and a library functions for astronomical data manipulation
37 and analysis. The programs are run on the operating system's
38 command-line enabling easy and efficient operation combined with other
39 installed programs in shell scripts or Makefiles. The libraries are
40 also usable in C and C++ programs.
41
42 %description -l pl.UTF-8
43 GNU Astronomy Utilities (Gnuastro) to oficjalny pakiet GNU zawierający
44 programy i funkcje biblioteczne do obróbki i analiz danych
45 astronomicznych. Programy są uruchamiane z wiersza poleceń systemu
46 operacyjnego, co pozwala na łatwe i wydajne operowanie w połączeniu z
47 innymi zainstalowanymi programami lub z poziomu plików Makefile.
48 Biblioteki mogą być używane w programach w C i C++.
49
50 %package devel
51 Summary:        Header files for Gnuastro library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Gnuastro
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       cfitsio-devel
56 Requires:       gsl-devel
57 Requires:       libgit2-devel
58 Requires:       wcslib-devel
59
60 %description devel
61 Header files for Gnuastro library.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe biblioteki Gnuastro.
65
66 %package static
67 Summary:        Static Gnuastro library
68 Summary(pl.UTF-8):      Statyczna biblioteka Gnuastro
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static Gnuastro library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka Gnuastro.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81 %patch1 -p1
82
83 %build
84 # regenerate for as-needed to work
85 %{__libtoolize}
86 %{__aclocal} -I bootstrapped/m4
87 %{__autoconf}
88 %{__autoheader}
89 %{__automake}
90 %configure \
91         --sysconfdir=%{_sysconfdir}/gnuastro \
92         %{!?with_static_libs:--disable-static}
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 # obsoleted by pkg-config
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgnuastro.la
103 # packaged as %doc
104 %{__rm} $RPM_BUILD_ROOT%{_docdir}/gnuastro/README
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/postshell
110 -/sbin/ldconfig
111 -/usr/sbin/fix-info-dir -c %{_infodir}
112
113 %postun -p /sbin/postshell
114 -/sbin/ldconfig
115 -/usr/sbin/fix-info-dir -c %{_infodir}
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog NEWS README THANKS
120 %attr(755,root,root) %{_bindir}/astarithmetic
121 %attr(755,root,root) %{_bindir}/astbuildprog
122 %attr(755,root,root) %{_bindir}/astconvertt
123 %attr(755,root,root) %{_bindir}/astconvolve
124 %attr(755,root,root) %{_bindir}/astcosmiccal
125 %attr(755,root,root) %{_bindir}/astcrop
126 %attr(755,root,root) %{_bindir}/astfits
127 %attr(755,root,root) %{_bindir}/astmatch
128 %attr(755,root,root) %{_bindir}/astmkcatalog
129 %attr(755,root,root) %{_bindir}/astmknoise
130 %attr(755,root,root) %{_bindir}/astmkprof
131 %attr(755,root,root) %{_bindir}/astnoisechisel
132 %attr(755,root,root) %{_bindir}/astsegment
133 %attr(755,root,root) %{_bindir}/aststatistics
134 %attr(755,root,root) %{_bindir}/asttable
135 %attr(755,root,root) %{_bindir}/astwarp
136 %attr(755,root,root) %{_libdir}/libgnuastro.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libgnuastro.so.5
138 %dir %{_sysconfdir}/gnuastro
139 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/ast*.conf
140 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/gnuastro.conf
141 %{_infodir}/gnuastro.info*
142 %{_infodir}/gnuastro-figures
143 %{_mandir}/man1/astarithmetic.1*
144 %{_mandir}/man1/astbuildprog.1*
145 %{_mandir}/man1/astconvertt.1*
146 %{_mandir}/man1/astconvolve.1*
147 %{_mandir}/man1/astcosmiccal.1*
148 %{_mandir}/man1/astcrop.1*
149 %{_mandir}/man1/astfits.1*
150 %{_mandir}/man1/astmatch.1*
151 %{_mandir}/man1/astmkcatalog.1*
152 %{_mandir}/man1/astmknoise.1*
153 %{_mandir}/man1/astmkprof.1*
154 %{_mandir}/man1/astnoisechisel.1*
155 %{_mandir}/man1/astsegment.1*
156 %{_mandir}/man1/aststatistics.1*
157 %{_mandir}/man1/asttable.1*
158 %{_mandir}/man1/astwarp.1*
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libgnuastro.so
163 %{_includedir}/gnuastro
164 %{_pkgconfigdir}/gnuastro.pc
165
166 %if %{with static_libs}
167 %files static
168 %defattr(644,root,root,755)
169 %{_libdir}/libgnuastro.a
170 %endif
This page took 0.050319 seconds and 4 git commands to generate.