]> git.pld-linux.org Git - packages/gnuastro.git/blob - gnuastro.spec
- release 2 (rebuild with gsl 2.6)
[packages/gnuastro.git] / gnuastro.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        GNU Astronomy Utilities
6 Summary(pl.UTF-8):      Narzędzia astronomiczne GNU
7 Name:           gnuastro
8 Version:        0.10
9 Release:        2
10 License:        GPL v3+
11 Group:          Applications/Science
12 Source0:        https://ftp.gnu.org/gnu/gnuastro/%{name}-%{version}.tar.lz
13 # Source0-md5:  48d1081543ba19b5d1b59e6d29b3b349
14 Patch0:         %{name}-info.patch
15 URL:            http://www.gnu.org/software/gnuastro/
16 BuildRequires:  autoconf >= 2.69
17 BuildRequires:  automake
18 BuildRequires:  cfitsio-devel
19 BuildRequires:  curl-devel
20 BuildRequires:  ghostscript >= 9.10
21 BuildRequires:  gsl-devel >= 2.0
22 BuildRequires:  help2man
23 BuildRequires:  libgit2-devel
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  libtiff-devel
26 BuildRequires:  libtool >= 2:2
27 BuildRequires:  lzip
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  wcslib-devel
30 Suggests:       ghostscript >= 9.10
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 GNU Astronomy Utilities (Gnuastro) is an official GNU package of
35 programs and a library functions for astronomical data manipulation
36 and analysis. The programs are run on the operating system's
37 command-line enabling easy and efficient operation combined with other
38 installed programs in shell scripts or Makefiles. The libraries are
39 also usable in C and C++ programs.
40
41 %description -l pl.UTF-8
42 GNU Astronomy Utilities (Gnuastro) to oficjalny pakiet GNU zawierający
43 programy i funkcje biblioteczne do obróbki i analiz danych
44 astronomicznych. Programy są uruchamiane z wiersza poleceń systemu
45 operacyjnego, co pozwala na łatwe i wydajne operowanie w połączeniu z
46 innymi zainstalowanymi programami lub z poziomu plików Makefile.
47 Biblioteki mogą być używane w programach w C i C++.
48
49 %package devel
50 Summary:        Header files for Gnuastro library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Gnuastro
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       cfitsio-devel
55 Requires:       gsl-devel
56 Requires:       libgit2-devel
57 Requires:       wcslib-devel
58
59 %description devel
60 Header files for Gnuastro library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki Gnuastro.
64
65 %package static
66 Summary:        Static Gnuastro library
67 Summary(pl.UTF-8):      Statyczna biblioteka Gnuastro
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static Gnuastro library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka Gnuastro.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80
81 %build
82 # regenerate for as-needed to work
83 %{__libtoolize}
84 %{__aclocal} -I bootstrapped/m4
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure \
89         --sysconfdir=%{_sysconfdir}/gnuastro \
90         %{!?with_static_libs:--disable-static}
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 # obsoleted by pkg-config
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgnuastro.la
101 # packaged as %doc
102 %{__rm} $RPM_BUILD_ROOT%{_docdir}/gnuastro/README
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/postshell
108 -/sbin/ldconfig
109 -/usr/sbin/fix-info-dir -c %{_infodir}
110
111 %postun -p /sbin/postshell
112 -/sbin/ldconfig
113 -/usr/sbin/fix-info-dir -c %{_infodir}
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS ChangeLog NEWS README THANKS
118 %attr(755,root,root) %{_bindir}/astarithmetic
119 %attr(755,root,root) %{_bindir}/astbuildprog
120 %attr(755,root,root) %{_bindir}/astconvertt
121 %attr(755,root,root) %{_bindir}/astconvolve
122 %attr(755,root,root) %{_bindir}/astcosmiccal
123 %attr(755,root,root) %{_bindir}/astcrop
124 %attr(755,root,root) %{_bindir}/astfits
125 %attr(755,root,root) %{_bindir}/astmatch
126 %attr(755,root,root) %{_bindir}/astmkcatalog
127 %attr(755,root,root) %{_bindir}/astmknoise
128 %attr(755,root,root) %{_bindir}/astmkprof
129 %attr(755,root,root) %{_bindir}/astnoisechisel
130 %attr(755,root,root) %{_bindir}/astscript-sort-by-night
131 %attr(755,root,root) %{_bindir}/astsegment
132 %attr(755,root,root) %{_bindir}/aststatistics
133 %attr(755,root,root) %{_bindir}/asttable
134 %attr(755,root,root) %{_bindir}/astwarp
135 %attr(755,root,root) %{_libdir}/libgnuastro.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libgnuastro.so.8
137 %dir %{_sysconfdir}/gnuastro
138 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/ast*.conf
139 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/gnuastro.conf
140 %{_infodir}/gnuastro.info*
141 %{_infodir}/gnuastro-figures
142 %{_mandir}/man1/astarithmetic.1*
143 %{_mandir}/man1/astbuildprog.1*
144 %{_mandir}/man1/astconvertt.1*
145 %{_mandir}/man1/astconvolve.1*
146 %{_mandir}/man1/astcosmiccal.1*
147 %{_mandir}/man1/astcrop.1*
148 %{_mandir}/man1/astfits.1*
149 %{_mandir}/man1/astmatch.1*
150 %{_mandir}/man1/astmkcatalog.1*
151 %{_mandir}/man1/astmknoise.1*
152 %{_mandir}/man1/astmkprof.1*
153 %{_mandir}/man1/astnoisechisel.1*
154 %{_mandir}/man1/astscript-sort-by-night.1*
155 %{_mandir}/man1/astsegment.1*
156 %{_mandir}/man1/aststatistics.1*
157 %{_mandir}/man1/asttable.1*
158 %{_mandir}/man1/astwarp.1*
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libgnuastro.so
163 %{_includedir}/gnuastro
164 %{_pkgconfigdir}/gnuastro.pc
165
166 %if %{with static_libs}
167 %files static
168 %defattr(644,root,root,755)
169 %{_libdir}/libgnuastro.a
170 %endif
This page took 0.083895 seconds and 4 git commands to generate.