]> git.pld-linux.org Git - packages/gnuastro.git/blob - gnuastro.spec
- release 4 (by relup.sh)
[packages/gnuastro.git] / gnuastro.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        GNU Astronomy Utilities
6 Summary(pl.UTF-8):      Narzędzia astronomiczne GNU
7 Name:           gnuastro
8 Version:        0.11
9 Release:        4
10 License:        GPL v3+
11 Group:          Applications/Science
12 Source0:        https://ftp.gnu.org/gnu/gnuastro/%{name}-%{version}.tar.lz
13 # Source0-md5:  5fcb6f89710d9047dabeaec6fe054b43
14 Patch0:         %{name}-info.patch
15 Patch1:         ac.patch
16 URL:            http://www.gnu.org/software/gnuastro/
17 BuildRequires:  autoconf >= 2.69
18 BuildRequires:  automake
19 BuildRequires:  cfitsio-devel
20 BuildRequires:  curl-devel
21 BuildRequires:  ghostscript >= 9.10
22 BuildRequires:  gsl-devel >= 2.0
23 BuildRequires:  help2man
24 BuildRequires:  libgit2-devel
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libtiff-devel
27 BuildRequires:  libtool >= 2:2
28 BuildRequires:  lzip
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  wcslib-devel
31 BuildRequires:  xz-devel
32 Suggests:       ghostscript >= 9.10
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 GNU Astronomy Utilities (Gnuastro) is an official GNU package of
37 programs and a library functions for astronomical data manipulation
38 and analysis. The programs are run on the operating system's
39 command-line enabling easy and efficient operation combined with other
40 installed programs in shell scripts or Makefiles. The libraries are
41 also usable in C and C++ programs.
42
43 %description -l pl.UTF-8
44 GNU Astronomy Utilities (Gnuastro) to oficjalny pakiet GNU zawierający
45 programy i funkcje biblioteczne do obróbki i analiz danych
46 astronomicznych. Programy są uruchamiane z wiersza poleceń systemu
47 operacyjnego, co pozwala na łatwe i wydajne operowanie w połączeniu z
48 innymi zainstalowanymi programami lub z poziomu plików Makefile.
49 Biblioteki mogą być używane w programach w C i C++.
50
51 %package devel
52 Summary:        Header files for Gnuastro library
53 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Gnuastro
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       cfitsio-devel
57 Requires:       gsl-devel
58 Requires:       libgit2-devel
59 Requires:       libjpeg-devel
60 Requires:       libtiff-devel >= 4
61 Requires:       wcslib-devel
62 Requires:       xz-devel
63
64 %description devel
65 Header files for Gnuastro library.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe biblioteki Gnuastro.
69
70 %package static
71 Summary:        Static Gnuastro library
72 Summary(pl.UTF-8):      Statyczna biblioteka Gnuastro
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static Gnuastro library.
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka Gnuastro.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86
87 %build
88 # regenerate for as-needed to work
89 %{__libtoolize}
90 %{__aclocal} -I bootstrapped/m4
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         --sysconfdir=%{_sysconfdir}/gnuastro \
96         %{!?with_static_libs:--disable-static}
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 # obsoleted by pkg-config
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgnuastro.la
107 # packaged as %doc
108 %{__rm} $RPM_BUILD_ROOT%{_docdir}/gnuastro/README
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/postshell
114 -/sbin/ldconfig
115 -/usr/sbin/fix-info-dir -c %{_infodir}
116
117 %postun -p /sbin/postshell
118 -/sbin/ldconfig
119 -/usr/sbin/fix-info-dir -c %{_infodir}
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS ChangeLog NEWS README THANKS
124 %attr(755,root,root) %{_bindir}/astarithmetic
125 %attr(755,root,root) %{_bindir}/astbuildprog
126 %attr(755,root,root) %{_bindir}/astconvertt
127 %attr(755,root,root) %{_bindir}/astconvolve
128 %attr(755,root,root) %{_bindir}/astcosmiccal
129 %attr(755,root,root) %{_bindir}/astcrop
130 %attr(755,root,root) %{_bindir}/astfits
131 %attr(755,root,root) %{_bindir}/astmatch
132 %attr(755,root,root) %{_bindir}/astmkcatalog
133 %attr(755,root,root) %{_bindir}/astmknoise
134 %attr(755,root,root) %{_bindir}/astmkprof
135 %attr(755,root,root) %{_bindir}/astnoisechisel
136 %attr(755,root,root) %{_bindir}/astscript-sort-by-night
137 %attr(755,root,root) %{_bindir}/astsegment
138 %attr(755,root,root) %{_bindir}/aststatistics
139 %attr(755,root,root) %{_bindir}/asttable
140 %attr(755,root,root) %{_bindir}/astwarp
141 %attr(755,root,root) %{_libdir}/libgnuastro.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libgnuastro.so.9
143 %dir %{_sysconfdir}/gnuastro
144 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/ast*.conf
145 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gnuastro/gnuastro.conf
146 %{_infodir}/gnuastro.info*
147 %{_infodir}/gnuastro-figures
148 %{_mandir}/man1/astarithmetic.1*
149 %{_mandir}/man1/astbuildprog.1*
150 %{_mandir}/man1/astconvertt.1*
151 %{_mandir}/man1/astconvolve.1*
152 %{_mandir}/man1/astcosmiccal.1*
153 %{_mandir}/man1/astcrop.1*
154 %{_mandir}/man1/astfits.1*
155 %{_mandir}/man1/astmatch.1*
156 %{_mandir}/man1/astmkcatalog.1*
157 %{_mandir}/man1/astmknoise.1*
158 %{_mandir}/man1/astmkprof.1*
159 %{_mandir}/man1/astnoisechisel.1*
160 %{_mandir}/man1/astscript-sort-by-night.1*
161 %{_mandir}/man1/astsegment.1*
162 %{_mandir}/man1/aststatistics.1*
163 %{_mandir}/man1/asttable.1*
164 %{_mandir}/man1/astwarp.1*
165
166 %files devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libgnuastro.so
169 %{_includedir}/gnuastro
170 %{_pkgconfigdir}/gnuastro.pc
171
172 %if %{with static_libs}
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/libgnuastro.a
176 %endif
This page took 0.086954 seconds and 3 git commands to generate.