]> git.pld-linux.org Git - packages/gnu-efi.git/blob - gnu-efi.spec
- updated to 3.0l
[packages/gnu-efi.git] / gnu-efi.spec
1 Summary:        GNU-EFI - building EFI applications using the GNU toolchain
2 Summary(pl.UTF-8):      GNU-EFI - tworzenie aplikacji EFI przy użyciu narzędzi GNU
3 Name:           gnu-efi
4 # NOTE: don't use 3.1, it doesn't support EFI x86_64
5 Version:        3.0l
6 Release:        1
7 # efilib is on Intel's BSD-like license, HP's glue code is GPL'd
8 License:        GPL v2+, portions on Intel's BSD-like license (see README.*)
9 Group:          Development/Libraries
10 Source0:        http://downloads.sourceforge.net/gnu-efi/%{name}_%{version}.orig.tar.gz
11 # Source0-md5:  fe9db068d0615a5df0d2afef546f408f
12 Patch0:         %{name}-pciio.patch
13 URL:            http://gnu-efi.sourceforge.net/
14 BuildRequires:  binutils >= 3:2.17.50.0.14
15 BuildRequires:  gcc >= 6:4.1.1
16 Requires:       binutils >= 3:2.17.50.0.14
17 Requires:       gcc >= 6:4.1.1
18 ExclusiveArch:  %{ix86} %{x8664} ia64
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         specflags_ia64  -frename-registers
22
23 %description
24 GNU-EFI development environment allows to create EFI applications for
25 IA-64 and x86 platforms using the GNU toolchain.
26
27 %description -l pl.UTF-8
28 Środowisko programistyczne GNU-EFI umożliwia tworzenie aplikacji EFI
29 dla platform IA-64 i x86 przy użyciu narzędzi GNU.
30
31 %prep
32 %setup -q -n %{name}-3.0
33 %patch0 -p1
34
35 %build
36 %ifarch %{x8664}
37 CFADD=" -DEFI_FUNCTION_WRAPPER -mno-red-zone"
38 %else
39 %ifarch ia64
40 CFADD=" -mfixed-range=f32-f127"
41 %else
42 CFADD=
43 %endif
44 %endif
45 %{__make} -j1 \
46         ARCH=$(echo %{_target_base_arch} | sed -e 's/i386/ia32/') \
47         CC="%{__cc}" \
48         CFLAGS="%{rpmcflags} -fpic -Wall -fshort-wchar -fno-strict-aliasing -fno-merge-constants -fno-stack-protector$CFADD" \
49         OBJCOPY=objcopy
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         INSTALLROOT=$RPM_BUILD_ROOT%{_prefix}
56
57 %if "%{_lib}" != "lib"
58         mv -f $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}
59 %endif
60
61 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62 cp -a apps/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc ChangeLog README.*
70 %{_libdir}/libefi.a
71 %{_libdir}/libgnuefi.a
72 %{_libdir}/crt0-efi-*.o
73 %{_libdir}/elf_*_efi.lds
74 %{_includedir}/efi
75 %{_examplesdir}/%{name}-%{version}
This page took 0.066354 seconds and 3 git commands to generate.