]> git.pld-linux.org Git - packages/gnu-efi.git/blob - gnu-efi.spec
acb1e97443df43e343cbbb1cfa47ff64a3f5ef31
[packages/gnu-efi.git] / gnu-efi.spec
1 Summary:        GNU-EFI - building EFI applications using the GNU toolchain
2 Summary(pl.UTF-8):      GNU-EFI - tworzenie aplikacji EFI przy użyciu narzędzi GNU
3 Name:           gnu-efi
4 # NOTE: don't use early 3.1, it doesn't support EFI x86_64
5 Version:        3.0.2
6 Release:        1
7 Epoch:          1
8 # Intel and HP's BSD-like license, except setjmp code coming from GRUB
9 License:        BSD-like
10 Group:          Development/Libraries
11 Source0:        http://downloads.sourceforge.net/gnu-efi/%{name}-%{version}.tar.bz2
12 # Source0-md5:  a9db2cabc01a2674715bd6aea2911f01
13 URL:            http://gnu-efi.sourceforge.net/
14 BuildRequires:  binutils >= 3:2.17.50.0.14
15 BuildRequires:  gcc >= 6:4.1.1
16 Requires:       binutils >= 3:2.17.50.0.14
17 Requires:       gcc >= 6:4.1.1
18 ExclusiveArch:  %{ix86} %{x8664} arm aarch64 ia64
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         specflags_ia64  -frename-registers
22
23 %define         efi_arch        %(echo %{_target_base_arch} | sed -e 's/i386/ia32/')
24
25 %description
26 GNU-EFI development environment allows to create EFI applications for
27 IA-64 and x86 platforms using the GNU toolchain.
28
29 %description -l pl.UTF-8
30 Środowisko programistyczne GNU-EFI umożliwia tworzenie aplikacji EFI
31 dla platform IA-64 i x86 przy użyciu narzędzi GNU.
32
33 %prep
34 %setup -q
35
36 %build
37 CFLAGS="%{rpmcflags}" \
38 %{__make} -j1 \
39         ARCH=%{efi_arch} \
40         CC="%{__cc}" \
41         OBJCOPY=objcopy
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         ARCH=%{efi_arch} \
48         INSTALLROOT=$RPM_BUILD_ROOT \
49         PREFIX=%{_prefix} \
50         LIBDIR=%{_libdir}
51
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 cp -a apps/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc ChangeLog README.*
61 %{_libdir}/libefi.a
62 %{_libdir}/libgnuefi.a
63 %{_libdir}/crt0-efi-*.o
64 %{_libdir}/elf_*_efi.lds
65 %{_includedir}/efi
66 %{_examplesdir}/%{name}-%{version}
This page took 0.044339 seconds and 2 git commands to generate.