]> git.pld-linux.org Git - packages/gnu-efi.git/blob - gnu-efi.spec
- updated to 3.0.18
[packages/gnu-efi.git] / gnu-efi.spec
1 Summary:        GNU-EFI - building EFI applications using the GNU toolchain
2 Summary(pl.UTF-8):      GNU-EFI - tworzenie aplikacji EFI przy użyciu narzędzi GNU
3 Name:           gnu-efi
4 # NOTE: don't use early 3.1, it doesn't support EFI x86_64
5 Version:        3.0.18
6 Release:        1
7 Epoch:          1
8 # Intel and HP's BSD-like license, except setjmp code coming from GRUB
9 License:        BSD-like
10 Group:          Development/Libraries
11 Source0:        https://downloads.sourceforge.net/gnu-efi/%{name}-%{version}.tar.bz2
12 # Source0-md5:  0b93ad70dff96991dd87978fc4275bd1
13 Patch0:         %{name}-make.patch
14 URL:            https://sourceforge.net/projects/gnu-efi/
15 BuildRequires:  binutils >= 3:2.17.50.0.14
16 BuildRequires:  gcc >= 6:4.7
17 Requires:       binutils >= 3:2.17.50.0.14
18 Requires:       gcc >= 6:4.7
19 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 ia64 mips64el
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         efi_arch        %(echo %{_target_base_arch} | sed -e 's/i386/ia32/')
23
24 # no native binaries, only EFI code packaged
25 %define         _enable_debug_packages  0
26
27 %description
28 GNU-EFI development environment allows to create EFI applications for
29 IA-64, x86, ARM and MIPS platforms using the GNU toolchain.
30
31 %description -l pl.UTF-8
32 Środowisko programistyczne GNU-EFI umożliwia tworzenie aplikacji EFI
33 dla platform IA-64, x86, ARM i MIPS przy użyciu narzędzi GNU.
34
35 %prep
36 %setup -q
37 %patch0 -p1
38
39 %build
40 ARCHFLAGS=
41 %ifarch ia64
42 ARCHFLAGS=-frename-registers
43 %endif
44 # on x32: use x86_64 EFI ABI
45 CFLAGS="%{rpmcflags} $ARCHFLAGS" \
46 %{__make} -j1 \
47         ARCH=%{efi_arch} \
48 %ifarch x32
49         ARCH3264=-m64 \
50 %endif
51         CC="%{__cc}" \
52         OBJCOPY=objcopy
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         ARCH=%{efi_arch} \
59         INSTALLROOT=$RPM_BUILD_ROOT \
60         PREFIX=%{_prefix} \
61         LIBDIR=%{_libdir}
62
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 cp -a apps/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 # compiled example apps
67 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/gnuefi/apps
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc ChangeLog README.*
75 %{_libdir}/libefi.a
76 %{_libdir}/libgnuefi.a
77 %{_libdir}/crt0-efi-*.o
78 %{_libdir}/elf_*_efi.lds
79 %{_includedir}/efi
80 %{_pkgconfigdir}/gnu-efi.pc
81 %{_examplesdir}/%{name}-%{version}
This page took 0.024308 seconds and 3 git commands to generate.