]> git.pld-linux.org Git - packages/gnu-efi.git/blob - gnu-efi.spec
- ...and gcc
[packages/gnu-efi.git] / gnu-efi.spec
1 Summary:        GNU-EFI - building EFI applications using the GNU toolchain
2 Summary(pl.UTF-8):      GNU-EFI - tworzenie aplikacji EFI przy użyciu narzędzi GNU
3 Name:           gnu-efi
4 # NOTE: don't use 3.1, it doesn't support EFI x86_64
5 Version:        3.0d
6 Release:        1
7 # efilib is on Intel's BSD-like license, HP's glue code is GPL'd
8 License:        GPL v2+, portions on Intel's BSD-like license (see README.*)
9 Group:          Development/Libraries
10 Source0:        http://dl.sourceforge.net/gnu-efi/%{name}-%{version}.tar.gz
11 # Source0-md5:  29013d3cd15009942fb855ba3e1a8096
12 URL:            http://gnu-efi.sourceforge.net/
13 BuildRequires:  binutils >= 2.17.50.0.14
14 BuildRequires:  gcc >= 6:4.1.1
15 Requires:       binutils >= 2.17.50.0.14
16 Requires:       gcc >= 6:4.1.1
17 ExclusiveArch:  %{ix86} %{x8664} ia64
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         specflags_ia64  -frename-registers
21
22 %description
23 GNU-EFI development environment allows to create EFI applications for
24 IA-64 and x86 platforms using the GNU toolchain.
25
26 %description -l pl.UTF-8
27 Środowisko programistyczne GNU-EFI umożliwia tworzenie aplikacji EFI
28 dla platform IA-64 i x86 przy użyciu narzędzi GNU.
29
30 %prep
31 %setup -q
32
33 %build
34 %{__make} \
35         CC="%{__cc}" \
36         CFLAGS="%{rpmcflags} -fpic -Wall -fshort-wchar"
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} install \
42         INSTALLROOT=$RPM_BUILD_ROOT%{_prefix}
43
44 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
45 cp -a apps/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc ChangeLog README.*
53 %{_libdir}/lib*efi.a
54 %{_libdir}/crt0-efi-*.o
55 %{_libdir}/elf_*_efi.lds
56 %{_includedir}/efi
57 %{_examplesdir}/%{name}-%{version}
This page took 0.061413 seconds and 3 git commands to generate.