]> git.pld-linux.org Git - packages/gnu-efi.git/blob - gnu-efi.spec
- updated to 3.0k
[packages/gnu-efi.git] / gnu-efi.spec
1 Summary:        GNU-EFI - building EFI applications using the GNU toolchain
2 Summary(pl.UTF-8):      GNU-EFI - tworzenie aplikacji EFI przy użyciu narzędzi GNU
3 Name:           gnu-efi
4 # NOTE: don't use 3.1, it doesn't support EFI x86_64
5 Version:        3.0k
6 Release:        1
7 # efilib is on Intel's BSD-like license, HP's glue code is GPL'd
8 License:        GPL v2+, portions on Intel's BSD-like license (see README.*)
9 Group:          Development/Libraries
10 Source0:        http://downloads.sourceforge.net/gnu-efi/%{name}_%{version}.orig.tar.gz
11 # Source0-md5:  d9c9fe899db26bf6e571074759a67a99
12 URL:            http://gnu-efi.sourceforge.net/
13 BuildRequires:  binutils >= 3:2.17.50.0.14
14 BuildRequires:  gcc >= 6:4.1.1
15 Requires:       binutils >= 3:2.17.50.0.14
16 Requires:       gcc >= 6:4.1.1
17 ExclusiveArch:  %{ix86} %{x8664} ia64
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         specflags_ia64  -frename-registers
21
22 %description
23 GNU-EFI development environment allows to create EFI applications for
24 IA-64 and x86 platforms using the GNU toolchain.
25
26 %description -l pl.UTF-8
27 Środowisko programistyczne GNU-EFI umożliwia tworzenie aplikacji EFI
28 dla platform IA-64 i x86 przy użyciu narzędzi GNU.
29
30 %prep
31 %setup -q -n %{name}-3.0
32
33 %build
34 %ifarch %{x8664}
35 CFADD=" -DEFI_FUNCTION_WRAPPER -mno-red-zone"
36 %else
37 %ifarch ia64
38 CFADD=" -mfixed-range=f32-f127"
39 %else
40 CFADD=
41 %endif
42 %endif
43 %{__make} -j1 \
44         ARCH=$(echo %{_target_base_arch} | sed -e 's/i386/ia32/') \
45         CC="%{__cc}" \
46         CFLAGS="%{rpmcflags} -fpic -Wall -fshort-wchar -fno-strict-aliasing -fno-merge-constants -fno-stack-protector$CFADD" \
47         OBJCOPY=objcopy
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         INSTALLROOT=$RPM_BUILD_ROOT%{_prefix}
54
55 %if "%{_lib}" != "lib"
56         mv -f $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}
57 %endif
58
59 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60 cp -a apps/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc ChangeLog README.*
68 %{_libdir}/libefi.a
69 %{_libdir}/libgnuefi.a
70 %{_libdir}/crt0-efi-*.o
71 %{_libdir}/elf_*_efi.lds
72 %{_includedir}/efi
73 %{_examplesdir}/%{name}-%{version}
This page took 0.025059 seconds and 3 git commands to generate.