]> git.pld-linux.org Git - packages/gnu-efi.git/blob - gnu-efi.spec
42dbd89c95916a8029dc908b1e1dbdc5ac02a386
[packages/gnu-efi.git] / gnu-efi.spec
1 Summary:        GNU-EFI - building EFI applications using the GNU toolchain
2 Summary(pl.UTF-8):      GNU-EFI - tworzenie aplikacji EFI przy użyciu narzędzi GNU
3 Name:           gnu-efi
4 # NOTE: don't use early 3.1, it doesn't support EFI x86_64
5 Version:        3.0.15
6 Release:        1
7 Epoch:          1
8 # Intel and HP's BSD-like license, except setjmp code coming from GRUB
9 License:        BSD-like
10 Group:          Development/Libraries
11 Source0:        https://downloads.sourceforge.net/gnu-efi/%{name}-%{version}.tar.bz2
12 # Source0-md5:  192d94e995ddd4ebdce4903adfd06039
13 URL:            https://sourceforge.net/projects/gnu-efi/
14 BuildRequires:  binutils >= 3:2.17.50.0.14
15 BuildRequires:  gcc >= 6:4.1.1
16 Requires:       binutils >= 3:2.17.50.0.14
17 Requires:       gcc >= 6:4.1.1
18 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 ia64 mips64el
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         efi_arch        %(echo %{_target_base_arch} | sed -e 's/i386/ia32/')
22
23 # no native binaries, only EFI code packaged
24 %define         _enable_debug_packages  0
25
26 %description
27 GNU-EFI development environment allows to create EFI applications for
28 IA-64, x86, ARM and MIPS platforms using the GNU toolchain.
29
30 %description -l pl.UTF-8
31 Środowisko programistyczne GNU-EFI umożliwia tworzenie aplikacji EFI
32 dla platform IA-64, x86, ARM i MIPS przy użyciu narzędzi GNU.
33
34 %prep
35 %setup -q
36
37 %build
38 ARCHFLAGS=
39 %ifarch ia64
40 ARCHFLAGS=-frename-registers
41 %endif
42 # on x32: use x86_64 EFI ABI
43 CFLAGS="%{rpmcflags} $ARCHFLAGS" \
44 %{__make} -j1 \
45         ARCH=%{efi_arch} \
46 %ifarch x32
47         ARCH3264=-m64 \
48 %endif
49         CC="%{__cc}" \
50         OBJCOPY=objcopy
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         ARCH=%{efi_arch} \
57         INSTALLROOT=$RPM_BUILD_ROOT \
58         PREFIX=%{_prefix} \
59         LIBDIR=%{_libdir}
60
61 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62 cp -a apps/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc ChangeLog README.*
70 %{_libdir}/libefi.a
71 %{_libdir}/libgnuefi.a
72 %{_libdir}/crt0-efi-*.o
73 %{_libdir}/elf_*_efi.lds
74 %{_includedir}/efi
75 %{_examplesdir}/%{name}-%{version}
This page took 0.05381 seconds and 2 git commands to generate.