]> git.pld-linux.org Git - packages/gnu-efi.git/blob - gnu-efi.spec
- fixed build on x86_64
[packages/gnu-efi.git] / gnu-efi.spec
1 Summary:        GNU-EFI - building EFI applications using the GNU toolchain
2 Summary(pl.UTF-8):      GNU-EFI - tworzenie aplikacji EFI przy użyciu narzędzi GNU
3 Name:           gnu-efi
4 # NOTE: don't use 3.1, it doesn't support EFI x86_64
5 Version:        3.0d
6 Release:        1
7 # efilib is on Intel's BSD-like license, HP's glue code is GPL'd
8 License:        GPL v2+, portions on Intel's BSD-like license (see README.*)
9 Group:          Development/Libraries
10 Source0:        http://dl.sourceforge.net/gnu-efi/%{name}-%{version}.tar.gz
11 # Source0-md5:  29013d3cd15009942fb855ba3e1a8096
12 URL:            http://gnu-efi.sourceforge.net/
13 BuildRequires:  binutils >= 3:2.17.50.0.14
14 BuildRequires:  gcc >= 6:4.1.1
15 Requires:       binutils >= 3:2.17.50.0.14
16 Requires:       gcc >= 6:4.1.1
17 ExclusiveArch:  %{ix86} %{x8664} ia64
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         specflags_ia64  -frename-registers
21
22 %description
23 GNU-EFI development environment allows to create EFI applications for
24 IA-64 and x86 platforms using the GNU toolchain.
25
26 %description -l pl.UTF-8
27 Środowisko programistyczne GNU-EFI umożliwia tworzenie aplikacji EFI
28 dla platform IA-64 i x86 przy użyciu narzędzi GNU.
29
30 %prep
31 %setup -q
32
33 %build
34 %ifarch %{x8664}
35 WRAP="-DEFI_FUNCTION_WRAPPER"
36 %else
37 WRAP=
38 %endif
39 %{__make} -j1 \
40         ARCH="%{_target_base_arch}" \
41         CC="%{__cc}" \
42         CFLAGS="%{rpmcflags} -fpic -Wall -fshort-wchar $WRAP" \
43         OBJCOPY=objcopy
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         INSTALLROOT=$RPM_BUILD_ROOT%{_prefix}
50
51 %if "%{_lib}" != "lib"
52         mv -f $RPM_BUILD_ROOT%{_prefix}/{lib,%{_lib}}
53 %endif
54
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56 cp -a apps/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc ChangeLog README.*
64 %{_libdir}/libefi.a
65 %{_libdir}/libgnuefi.a
66 %{_libdir}/crt0-efi-*.o
67 %{_libdir}/elf_*_efi.lds
68 %{_includedir}/efi
69 %{_examplesdir}/%{name}-%{version}
This page took 0.046585 seconds and 3 git commands to generate.