]> git.pld-linux.org Git - packages/gnu-efi.git/blob - gnu-efi.spec
05ff178a4790b47a68eafb78947c749fb764c7ca
[packages/gnu-efi.git] / gnu-efi.spec
1 Summary:        GNU-EFI - building EFI applications using the GNU toolchain
2 Summary(pl.UTF-8):      GNU-EFI - tworzenie aplikacji EFI przy użyciu narzędzi GNU
3 Name:           gnu-efi
4 # NOTE: don't use early 3.1, it doesn't support EFI x86_64
5 Version:        3.0.3
6 Release:        2
7 Epoch:          1
8 # Intel and HP's BSD-like license, except setjmp code coming from GRUB
9 License:        BSD-like
10 Group:          Development/Libraries
11 Source0:        http://downloads.sourceforge.net/gnu-efi/%{name}-%{version}.tar.bz2
12 # Source0-md5:  15a4bcbc18a9a5e8110ed955970622e6
13 URL:            http://gnu-efi.sourceforge.net/
14 BuildRequires:  binutils >= 3:2.17.50.0.14
15 BuildRequires:  gcc >= 6:4.1.1
16 Requires:       binutils >= 3:2.17.50.0.14
17 Requires:       gcc >= 6:4.1.1
18 ExclusiveArch:  %{ix86} %{x8664} x32 arm aarch64 ia64
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         efi_arch        %(echo %{_target_base_arch} | sed -e 's/i386/ia32/')
22
23 %description
24 GNU-EFI development environment allows to create EFI applications for
25 IA-64 and x86 platforms using the GNU toolchain.
26
27 %description -l pl.UTF-8
28 Środowisko programistyczne GNU-EFI umożliwia tworzenie aplikacji EFI
29 dla platform IA-64 i x86 przy użyciu narzędzi GNU.
30
31 %prep
32 %setup -q
33
34 %build
35 ARCHFLAGS=
36 %ifarch ia64
37 ARCHFLAGS=-frename-registers
38 %endif
39 %ifarch x32
40 # use x86_64 EFI ABI
41 ARCHFLAGS=-m64
42 %endif
43 CFLAGS="%{rpmcflags} $ARCHFLAGS" \
44 %{__make} -j1 \
45         ARCH=%{efi_arch} \
46         CC="%{__cc}" \
47         OBJCOPY=objcopy
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         ARCH=%{efi_arch} \
54         INSTALLROOT=$RPM_BUILD_ROOT \
55         PREFIX=%{_prefix} \
56         LIBDIR=%{_libdir}
57
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59 cp -a apps/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc ChangeLog README.*
67 %{_libdir}/libefi.a
68 %{_libdir}/libgnuefi.a
69 %{_libdir}/crt0-efi-*.o
70 %{_libdir}/elf_*_efi.lds
71 %{_includedir}/efi
72 %{_examplesdir}/%{name}-%{version}
This page took 0.053359 seconds and 2 git commands to generate.