]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
1544d78473cdee567f4677d7ed87bb4b448f10ed
[packages/gnome-shell.git] / gnome-shell.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 %define         clutter_ver                     1.21.5
6 # max(ecal_req, eds_req)
7 %define         evolution_data_server_ver       3.33.1
8 %define         gcr_ver                         3.7.5
9 %define         gjs_ver                         1.65.1
10 %define         glib_ver                        1:2.57.2
11 %define         gnome_bluetooth_ver             3.9.0
12 %define         gnome_desktop_ver               3.36.0
13 %define         gsettings_desktop_schemas_ver   3.33.1
14 %define         gtk_ver                         3.15.0
15 %define         json_glib_ver                   0.13.90
16 %define         libsecret_ver                   0.18
17 %define         mutter_ver                      40
18 %define         NetworkManager_ver              1.10.4
19 %define         polkit_ver                      0.100
20 %define         pulseaudio_ver                  13
21 %define         startup_notification_ver        0.11
22
23 Summary:        Window manager and application launcher for GNOME
24 Summary(pl.UTF-8):      Zarządca okien i uruchamiania aplikacji dla GNOME
25 Name:           gnome-shell
26 Version:        40.0
27 Release:        1
28 License:        GPL v2+
29 Group:          X11/Window Managers
30 Source0:        https://download.gnome.org/sources/gnome-shell/40/%{name}-%{version}.tar.xz
31 # Source0-md5:  e5f8d7af0965417969cb9da0b4495090
32 URL:            https://wiki.gnome.org/Projects/GnomeShell
33 BuildRequires:  NetworkManager-devel >= %{NetworkManager_ver}
34 BuildRequires:  at-spi2-atk-devel
35 BuildRequires:  bash-completion-devel >= 2.0
36 BuildRequires:  clutter-devel >= %{clutter_ver}
37 BuildRequires:  evolution-data-server-devel >= %{evolution_data_server_ver}
38 BuildRequires:  gcr-devel >= %{gcr_ver}
39 BuildRequires:  gdk-pixbuf2-devel >= 2.0
40 BuildRequires:  gettext-tools >= 0.19.6
41 BuildRequires:  gjs-devel >= %{gjs_ver}
42 BuildRequires:  glib2-devel >= %{glib_ver}
43 BuildRequires:  gnome-autoar-devel
44 BuildRequires:  gnome-bluetooth-devel >= %{gnome_bluetooth_ver}
45 BuildRequires:  gnome-control-center-devel
46 # for cldr2json.py (through pygobject->gi)
47 BuildRequires:  gnome-desktop >= %{gnome_desktop_ver}
48 BuildRequires:  gobject-introspection-devel >= 1.50.0
49 BuildRequires:  gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_ver}
50 BuildRequires:  gstreamer-devel >= 1.0.0
51 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
52 BuildRequires:  gtk+3-devel >= %{gtk_ver}
53 BuildRequires:  gtk4-devel >= 4
54 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.15}
55 BuildRequires:  ibus-devel >= 1.5.2
56 BuildRequires:  json-glib-devel >= %{json_glib_ver}
57 BuildRequires:  libcanberra-devel
58 BuildRequires:  libcanberra-gtk3-devel
59 BuildRequires:  libsecret-devel >= %{libsecret_ver}
60 BuildRequires:  libsoup-devel
61 BuildRequires:  libxml2-devel >= 2.0
62 BuildRequires:  libxslt-progs
63 BuildRequires:  meson >= 0.53.0
64 BuildRequires:  mutter-devel >= %{mutter_ver}
65 BuildRequires:  ninja >= 1.5
66 BuildRequires:  pipewire-devel >= 0.3
67 BuildRequires:  pkgconfig >= 1:0.22
68 BuildRequires:  polkit-devel >= %{polkit_ver}
69 BuildRequires:  pulseaudio-devel >= %{pulseaudio_ver}
70 BuildRequires:  python3 >= 1:3
71 BuildRequires:  python3-pygobject3 >= 3
72 BuildRequires:  rpm-build >= 4.6
73 BuildRequires:  rpm-pythonprov
74 BuildRequires:  rpmbuild(macros) >= 1.752
75 BuildRequires:  sassc
76 BuildRequires:  sed >= 4.0
77 BuildRequires:  startup-notification-devel >= %{startup_notification_ver}
78 BuildRequires:  systemd-devel
79 BuildRequires:  systemd-units
80 BuildRequires:  tar >= 1:1.22
81 BuildRequires:  xorg-lib-libX11-devel
82 BuildRequires:  xorg-lib-libXfixes-devel
83 BuildRequires:  xz
84 Requires(post,postun):  glib2 >= %{glib_ver}
85 # gjs->gi->NMA.gir
86 Requires:       NetworkManager-libs >= %{NetworkManager_ver}
87 Requires:       adwaita-icon-theme
88 Requires:       at-spi2-atk >= 2.4.0
89 Requires:       clutter >= %{clutter_ver}
90 Requires:       evolution-data-server >= %{evolution_data_server_ver}
91 Requires:       gcr >= %{gcr_ver}
92 Requires:       gjs >= %{gjs_ver}
93 Requires:       glib2 >= %{glib_ver}
94 Requires:       gnome-bluetooth-libs >= %{gnome_bluetooth_ver}
95 Requires:       gnome-desktop >= %{gnome_desktop_ver}
96 Requires:       gnome-settings-daemon >= 3.8.0
97 Requires:       gsettings-desktop-schemas >= %{gsettings_desktop_schemas_ver}
98 Requires:       gtk+3 >= %{gtk_ver}
99 Requires:       ibus >= 1.5.2
100 Requires:       json-glib >= %{json_glib_ver}
101 Requires:       libsecret >= %{libsecret_ver}
102 Requires:       mutter >= %{mutter_ver}
103 Requires:       nautilus >= 3.8.0
104 Requires:       polkit >= %{polkit_ver}
105 Requires:       pulseaudio-libs >= %{pulseaudio_ver}
106 Requires:       startup-notification >= %{startup_notification_ver}
107 # gjs->gir->TelepathyGLib
108 Requires:       telepathy-glib >= 0.17.5
109 # gjs->gir->TelepathyLogger
110 Requires:       telepathy-logger-libs >= 0.2
111 Requires:       telepathy-mission-control
112 Suggests:       gnome-contacts >= 3.2.0
113 Suggests:       gnome-icon-theme-symbolic >= 3.8.0
114 Provides:       gdm-wm = 3.8.0
115 Obsoletes:      browser-plugin-gnome-shell < 3.32.2-1
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %description
119 GNOME Shell is the defining technology of the GNOME 3 desktop user
120 experience. It provides core interface functions like switching to
121 windows and launching applications. GNOME Shell takes advantage of the
122 capabilities of modern graphics hardware and introduces innovative
123 user interface concepts to provide a delightful and easy to use
124 experience.
125
126 %description -l pl.UTF-8
127 GNOME Shell to technologia definiująca doznania użytkownika środowiska
128 graficznego GNOME 3. Zapewnia podstawowe funkcje interfejsu, takie jak
129 przełączanie między oknami czy uruchamianie aplikacji. GNOME Shell
130 wykorzystuje mozliwości współczesnego sprzętu graficznego i wprowadza
131 innowacyjne koncepcje interfejsu użytkownika, zapewniające przyjemne
132 doznania i łatwość użycia.
133
134 %package -n bash-completion-gnome-shell
135 Summary:        Bash completion for GNOME Shell commands
136 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów poleceń GNOME Shell
137 Group:          Applications/Shells
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       bash-completion >= 2.0
140 BuildArch:      noarch
141
142 %description -n bash-completion-gnome-shell
143 Bash completion for GNOME Shell commands.
144
145 %description -n bash-completion-gnome-shell -l pl.UTF-8
146 Bashowe dopełnianie parametrów poleceń GNOME Shell.
147
148 %package devel
149 Summary:        Development files for GNOME Shell
150 Summary(pl.UTF-8):      Pliki programistyczne dla GNOME Shell
151 Group:          Development/Libraries
152 BuildArch:      noarch
153
154 %description devel
155 This package provides development files for GNOME Shell.
156
157 %description devel -l pl.UTF-8
158 Ten pakiet dostarcza pliki programistyczne dla GNOME Shell.
159
160 %package apidocs
161 Summary:        GNOME Shell API documentation
162 Summary(pl.UTF-8):      Dokumentacja API GNOME Shell
163 Group:          Documentation
164 Requires:       gtk-doc-common
165 BuildArch:      noarch
166
167 %description apidocs
168 This package provides GNOME Shell API documentation.
169
170 %description apidocs -l pl.UTF-8
171 Ten pakiet dostarcza dokumentację API GNOME Shell.
172
173 %prep
174 %setup -q
175
176 %{__sed} -i -e '/^libshew =/ s/ library/ shared_library/' subprojects/shew/src/meson.build
177
178 %build
179 %meson build \
180         %{?with_apidocs:-Dgtk_doc=true}
181
182 %meson_build -C build
183
184 %install
185 rm -rf $RPM_BUILD_ROOT
186 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/{extensions,search-providers}
187
188 %meson_install -C build
189
190 # evolution already ships this file
191 %{__rm} $RPM_BUILD_ROOT%{_desktopdir}/evolution-calendar.desktop
192
193 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell*.a
194
195 %find_lang %{name}
196
197 %clean
198 rm -rf $RPM_BUILD_ROOT
199
200 %post
201 %glib_compile_schemas
202
203 %postun
204 if [ "$1" = "0" ]; then
205         %glib_compile_schemas
206 fi
207
208 %files -f %{name}.lang
209 %defattr(644,root,root,755)
210 %doc NEWS README.md
211 %attr(755,root,root) %{_bindir}/gnome-extensions
212 %attr(755,root,root) %{_bindir}/gnome-extensions-app
213 %attr(755,root,root) %{_bindir}/gnome-shell
214 %attr(755,root,root) %{_bindir}/gnome-shell-extension-prefs
215 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
216 %attr(755,root,root) %{_bindir}/gnome-shell-perf-tool
217 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
218 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
219 %attr(755,root,root) %{_libexecdir}/gnome-shell-overrides-migration.sh
220 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
221 %attr(755,root,root) %{_libexecdir}/gnome-shell-portal-helper
222 %dir %{_libdir}/gnome-shell
223 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
224 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell-menu.so
225 %attr(755,root,root) %{_libdir}/gnome-shell/libgvc.so
226 %attr(755,root,root) %{_libdir}/gnome-shell/libshew-0.so
227 %attr(755,root,root) %{_libdir}/gnome-shell/libst-1.0.so
228 %{_libdir}/gnome-shell/Gvc-1.0.typelib
229 %{_libdir}/gnome-shell/Shell-0.1.typelib
230 %{_libdir}/gnome-shell/St-1.0.typelib
231 %dir %{_libdir}/gnome-shell/girepository-1.0
232 %{_libdir}/gnome-shell/girepository-1.0/Shew-0.typelib
233 %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
234 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Introspect.xml
235 %{_datadir}/dbus-1/services/org.gnome.Extensions.service
236 %{_datadir}/dbus-1/services/org.gnome.ScreenSaver.service
237 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
238 %{_datadir}/dbus-1/services/org.gnome.Shell.Extensions.service
239 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
240 %{_datadir}/dbus-1/services/org.gnome.Shell.Notifications.service
241 %{_datadir}/dbus-1/services/org.gnome.Shell.PortalHelper.service
242 %{_datadir}/dbus-1/services/org.gnome.Shell.Screencast.service
243 %{_datadir}/glib-2.0/schemas/00_org.gnome.shell.gschema.override
244 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
245 %{_datadir}/gnome-control-center/keybindings/*.xml
246 %{_datadir}/gnome-shell
247 %{_datadir}/metainfo/org.gnome.Extensions.metainfo.xml
248 %{_datadir}/xdg-desktop-portal/portals/gnome-shell.portal
249 %{_desktopdir}/org.gnome.Extensions.desktop
250 %{_desktopdir}/org.gnome.Shell.desktop
251 %{_desktopdir}/org.gnome.Shell.Extensions.desktop
252 %{_desktopdir}/org.gnome.Shell.PortalHelper.desktop
253 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.Devel.svg
254 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Extensions.svg
255 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Shell.Extensions.svg
256 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Extensions-symbolic.svg
257 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Shell.Extensions-symbolic.svg
258 %{_mandir}/man1/gnome-extensions.1*
259 %{_mandir}/man1/gnome-shell.1*
260 %{_sysconfdir}/xdg/autostart/gnome-shell-overrides-migration.desktop
261 %{systemduserunitdir}/org.gnome.Shell.target
262 %{systemduserunitdir}/org.gnome.Shell-disable-extensions.service
263 %{systemduserunitdir}/org.gnome.Shell@wayland.service
264 %{systemduserunitdir}/org.gnome.Shell@x11.service
265
266 %files -n bash-completion-gnome-shell
267 %defattr(644,root,root,755)
268 %{bash_compdir}/gnome-extensions
269
270 %files devel
271 %defattr(644,root,root,755)
272 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Extensions.xml
273 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.PadOsd.xml
274 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
275 %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
276 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
277 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
278
279 %if %{with apidocs}
280 %files apidocs
281 %defattr(644,root,root,755)
282 %{_gtkdocdir}/shell
283 %{_gtkdocdir}/st
284 %endif
This page took 0.058289 seconds and 2 git commands to generate.