]> git.pld-linux.org Git - packages/gnome-objc.git/blob - gnome-objc.spec
- updated gettext BR
[packages/gnome-objc.git] / gnome-objc.spec
1 Summary:        GNOME Objective C libraries
2 Summary(pl.UTF-8):      Biblioteki Objective C do GNOME
3 Name:           gnome-objc
4 Version:        1.0.40
5 Release:        8
6 License:        LGPL v2+
7 Group:          X11/Applications
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-objc/1.0/%{name}-%{version}.tar.gz
9 # Source0-md5:  5128635f4d8d143e5f9b4646456b3025
10 URL:            http://www.gnome.org/
11 BuildRequires:  automake
12 BuildRequires:  gcc-objc
13 BuildRequires:  gettext-tools
14 BuildRequires:  gnome-libs-devel
15 Requires:       gtk+ >= 1.2.1
16 Obsoletes:      gnome
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Basic libraries you must have installed to use GNOME programs that are
21 built with Objective C.
22
23 GNOME is the GNU Network Object Model Environment. That's a fancy name
24 but really GNOME is a nice GUI desktop environment. It makes using
25 your computer easy, powerful, and easy to configure.
26
27 %description -l pl.UTF-8
28 Pakiet ten zawiera biblioteki Objective C do GNOME.
29
30 GNOME jest graficznym interfejsem użytkownika łatwym w konfiguracji.
31 Uczyni z twojego komputera maszynę łatwą i przyjemną w obsłudze.
32
33 %package devel
34 Summary:        Header filesc, etc to develop Objective C GNOME applications
35 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do Objective C GNOME
36 Group:          X11/Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       gcc-objc
39
40 %description devel
41 Libraries, include files, etc you can use to develop Objective C GNOME
42 applications.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe itp. Jednym słowem wszystko czego potrzebujesz aby
46 samemu tworzyć aplikacje GNOME z użyciem Objective C.
47
48 %package static
49 Summary:        Static ibraries Objective C GNOME applications
50 Summary(pl.UTF-8):      Biblioteki statyczne do Objective C GNOME
51 Group:          X11/Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static libraries to develop Objective C GNOME applications.
56
57 %description static -l pl.UTF-8
58 Biblioteki statyczne do Objective C GNOME.
59
60 %prep
61 %setup -q
62
63 %build
64 OBJC="%{__cc}"; export OBJC
65 cp -f /usr/share/automake/config.* .
66 %{__gettextize}
67 %{__aclocal} -I macros
68 %configure2_13
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %find_lang %{name}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post   -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %files -f %{name}.lang
86 %defattr(644,root,root,755)
87 %attr(755,root,root) %{_libdir}/lib*.so.*.*
88
89 %files devel
90 %defattr(644,root,root,755)
91 %doc AUTHORS ChangeLog NEWS README
92 %attr(755,root,root) %{_bindir}/obgnome-config
93 %attr(755,root,root) %{_libdir}/lib*.so
94 %{_libdir}/lib*.la
95 %attr(755,root,root) %{_libdir}/*.sh
96 %{_includedir}/*
97
98 %files static
99 %defattr(644,root,root,755)
100 %{_libdir}/lib*.a
This page took 0.074976 seconds and 3 git commands to generate.