]> git.pld-linux.org Git - packages/gnome-keyring.git/blob - gnome-keyring.spec
BR: gcr-ui-devel
[packages/gnome-keyring.git] / gnome-keyring.spec
1 # TODO
2 #  Aug 14 13:19:00 haarber gnome-keyring-daemon[6524]: couldn't list keyrings at: /etc/certs: Error opening directory '/etc/certs': Permission denied
3 #
4 # Conditional build:
5 %bcond_with     p11_tests       # PKCS#11 tests
6 #
7 Summary:        Keep passwords and other user's secrets
8 Summary(pl.UTF-8):      Przechowywanie haseł i innych tajnych danych użytkowników
9 Name:           gnome-keyring
10 Version:        40.0
11 Release:        2
12 License:        LGPL v2+ (library), GPL v2+ (programs)
13 Group:          X11/Applications
14 Source0:        https://download.gnome.org/sources/gnome-keyring/40/%{name}-%{version}.tar.xz
15 # Source0-md5:  f404b61683a0ff54fb264b337772cff2
16 URL:            https://wiki.gnome.org/Projects/GnomeKeyring
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1:1.12
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gcr-devel >= 3.28.0
21 BuildRequires:  gcr-ui-devel >= 3.28.0
22 BuildRequires:  gettext-tools >= 0.19.8
23 BuildRequires:  glib2-devel >= 1:2.44.0
24 BuildRequires:  libcap-ng-devel
25 BuildRequires:  libgcrypt-devel >= 1.2.2
26 BuildRequires:  libselinux-devel
27 # for some test only
28 BuildRequires:  libtasn1-devel >= 0.3.4
29 BuildRequires:  libtool
30 BuildRequires:  libxslt-progs
31 BuildRequires:  p11-kit-devel >= 0.16
32 %{?with_p11_tests:BuildRequires:        p11-tests-devel >= 0.1}
33 BuildRequires:  pam-devel
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(macros) >= 1.592
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 Requires(post,postun):  glib2 >= 1:2.44.0
39 Requires:       filesystem >= 4.0-28
40 Requires:       gcr >= 3.28.0
41 Requires:       glib2 >= 1:2.44.0
42 Requires:       hicolor-icon-theme
43 Requires:       libgcrypt >= 1.2.2
44 Requires:       p11-kit >= 0.16
45 Conflicts:      rpm < 4.4.2-0.2
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 GNOME Keyring is a program that keeps password and other secrets for
50 users. It is run as a daemon in the session, similar to ssh-agent, and
51 other applications can locate it by an environment variable.
52
53 %description -l pl.UTF-8
54 GNOME Keyring to program do przechowywania haseł i innych tajnych
55 danych użytkowników. Działa jako demon w sesji, podobnie do
56 ssh-agenta, a inne aplikacje mogą znaleźć go poprzez zmienną
57 środowiskową.
58
59 %package -n pam-pam_gnome_keyring
60 Summary:        A PAM module for unlocking keyrings at login time
61 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów kluczy w czasie logowania
62 License:        LGPL v2+
63 Group:          Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Obsoletes:      gnome-keyring-pam < 2.30.1-2
66
67 %description -n pam-pam_gnome_keyring
68 A PAM module that can automatically unlock the "login" keyring when
69 the user logs in and start the keyring daemon.
70
71 %description -n pam-pam_gnome_keyring -l pl.UTF-8
72 Moduł PAM, który może automatycznie odblokowywać zbiór kluczy "login"
73 w czasie logowania użytkownika i uruchamiania demona keyring.
74
75 %prep
76 %setup -q
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         SSH_ADD="/usr/bin/ssh-add" \
86         SSH_AGENT="/usr/bin/ssh-agent" \
87         --disable-silent-rules \
88         %{!?with_p11_tests:--disable-p11-tests} \
89         --with-pam-dir=/%{_lib}/security
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install install-pam \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_gnome_keyring.la
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pkcs11/gnome-keyring-pkcs11.la
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/devel/*.la
101
102 %find_lang %{name}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post
108 %glib_compile_schemas
109
110 %postun
111 %glib_compile_schemas
112
113 %files -f %{name}.lang
114 %defattr(644,root,root,755)
115 %doc AUTHORS ChangeLog NEWS README
116 %attr(755,root,root) %{_bindir}/gnome-keyring
117 %attr(755,root,root) %{_bindir}/gnome-keyring-3
118 %attr(755,root,root) %{_bindir}/gnome-keyring-daemon
119 %attr(755,root,root) %{_libdir}/pkcs11/gnome-keyring-pkcs11.so
120 %dir %{_libdir}/%{name}
121 %dir %{_libdir}/%{name}/devel
122 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-gnome2-store-standalone.so
123 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-secret-store-standalone.so
124 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-ssh-store-standalone.so
125 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-xdg-store-standalone.so
126 %{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
127 %{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
128 %{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
129 %{_datadir}/GConf/gsettings/org.gnome.crypto.cache.convert
130 %{_datadir}/dbus-1/services/org.freedesktop.impl.portal.Secret.service
131 %{_datadir}/dbus-1/services/org.freedesktop.secrets.service
132 %{_datadir}/dbus-1/services/org.gnome.keyring.service
133 %{_datadir}/glib-2.0/schemas/org.gnome.crypto.cache.gschema.xml
134 %{_mandir}/man1/gnome-keyring.1*
135 %{_mandir}/man1/gnome-keyring-3.1*
136 %{_mandir}/man1/gnome-keyring-daemon.1*
137 %{_datadir}/p11-kit/modules/gnome-keyring.module
138 %{_datadir}/xdg-desktop-portal/portals/gnome-keyring.portal
139
140 %files -n pam-pam_gnome_keyring
141 %defattr(644,root,root,755)
142 %attr(755,root,root) /%{_lib}/security/pam_gnome_keyring.so
This page took 0.098495 seconds and 3 git commands to generate.