]> git.pld-linux.org Git - packages/gnome-keyring.git/blob - gnome-keyring.spec
Update to 3.10.1
[packages/gnome-keyring.git] / gnome-keyring.spec
1 # TODO
2 #  Aug 14 13:19:00 haarber gnome-keyring-daemon[6524]: couldn't list keyrings at: /etc/certs: Error opening directory '/etc/certs': Permission denied
3 #
4 # Conditional build:
5 %bcond_with     p11_tests       # PKCS#11 tests
6 #
7 Summary:        Keep passwords and other user's secrets
8 Summary(pl.UTF-8):      Przechowywanie haseł i innych tajnych danych użytkowników
9 Name:           gnome-keyring
10 Version:        3.10.1
11 Release:        1
12 License:        LGPL v2+ (library), GPL v2+ (programs)
13 Group:          X11/Applications
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-keyring/3.10/%{name}-%{version}.tar.xz
15 # Source0-md5:  a0fedbeb11a654975abed45865d3f82d
16 URL:            http://live.gnome.org/GnomeKeyring
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  cairo-devel
20 BuildRequires:  dbus-devel >= 1.2.0
21 BuildRequires:  docbook-dtd412-xml
22 BuildRequires:  gcr-devel >= 3.5.3
23 BuildRequires:  gettext-devel
24 BuildRequires:  glib2-devel >= 1:2.32.0
25 BuildRequires:  gtk+3-devel >= 3.0.0
26 BuildRequires:  intltool >= 0.40.0
27 BuildRequires:  libcap-ng-devel
28 BuildRequires:  libgcrypt-devel >= 1.2.2
29 BuildRequires:  libselinux-devel
30 BuildRequires:  libtasn1-devel >= 0.3.4
31 BuildRequires:  libtool
32 BuildRequires:  p11-kit-devel >= 0.16
33 %{?with_p11_tests:BuildRequires:        p11-tests-devel >= 0.1}
34 BuildRequires:  pam-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(macros) >= 1.592
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  xz
39 Requires(post,postun):  glib2 >= 1:2.32.0
40 Requires:       dbus >= 1.2.0
41 Requires:       gcr >= 3.5.3
42 Requires:       glib2 >= 1:2.32.0
43 Requires:       hicolor-icon-theme
44 Requires:       libtasn1 >= 0.3.4
45 Requires:       p11-kit >= 0.16
46 Conflicts:      rpm < 4.4.2-0.2
47 # sr@Latn vs. sr@latin
48 Conflicts:      glibc-misc < 6:2.7
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         _libexecdir     %{_libdir}/%{name}
52
53 %description
54 GNOME Keyring is a program that keeps password and other secrets for
55 users. It is run as a daemon in the session, similar to ssh-agent, and
56 other applications can locate it by an environment variable.
57
58 %description -l pl.UTF-8
59 GNOME Keyring to program do przechowywania haseł i innych tajnych
60 danych użytkowników. Działa jako demon w sesji, podobnie do
61 ssh-agenta, a inne aplikacje mogą znaleźć go poprzez zmienną
62 środowiskową.
63
64 %package -n pam-pam_gnome_keyring
65 Summary:        A PAM module for unlocking keyrings at login time
66 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów kluczy w czasie logowania
67 License:        LGPL v2+
68 Group:          Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Obsoletes:      gnome-keyring-pam
71
72 %description -n pam-pam_gnome_keyring
73 A PAM module that can automatically unlock the "login" keyring when
74 the user logs in and start the keyring daemon.
75
76 %description -n pam-pam_gnome_keyring -l pl.UTF-8
77 Moduł PAM, który może automatycznie odblokowywać zbiór kluczy "login"
78 w czasie logowania użytkownika i uruchamiania demona keyring.
79
80 %prep
81 %setup -q
82
83 %build
84 %{__glib_gettextize}
85 %{__intltoolize}
86 %{__libtoolize}
87 %{__aclocal}
88 %{__autoconf}
89 %{__autoheader}
90 %{__automake}
91 %configure \
92         --disable-silent-rules \
93         %{!?with_p11_tests:--disable-p11-tests} \
94         --with-pam-dir=/%{_lib}/security \
95         --with-root-certs=%{_sysconfdir}/certs \
96         --with-ca-certificates=%{_sysconfdir}/certs/ca-certificates.crt
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install install-pam \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_gnome_keyring.la
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pkcs11/gnome-keyring-pkcs11.la
107 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/devel/*.la
108
109 %find_lang %{name}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 %glib_compile_schemas
116
117 %postun
118 %glib_compile_schemas
119
120 %files -f %{name}.lang
121 %defattr(644,root,root,755)
122 %doc AUTHORS ChangeLog NEWS README
123 %attr(755,root,root) %{_bindir}/gnome-keyring
124 %attr(755,root,root) %{_bindir}/gnome-keyring-3
125 %attr(755,root,root) %{_bindir}/gnome-keyring-daemon
126 %dir %{_libdir}/pkcs11
127 %attr(755,root,root) %{_libdir}/pkcs11/gnome-keyring-pkcs11.so
128 %dir %{_libdir}/%{name}
129 %dir %{_libdir}/%{name}/devel
130 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-gnome2-store-standalone.so
131 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-secret-store-standalone.so
132 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-ssh-store-standalone.so
133 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-xdg-store-standalone.so
134 %{_sysconfdir}/xdg/autostart/gnome-keyring-gpg.desktop
135 %{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
136 %{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
137 %{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
138 %{_datadir}/GConf/gsettings/*.convert
139 %{_datadir}/dbus-1/services/org.freedesktop.secrets.service
140 %{_datadir}/dbus-1/services/org.gnome.keyring.service
141 %{_datadir}/glib-2.0/schemas/*.gschema.xml
142 %{_datadir}/p11-kit/modules/gnome-keyring.module
143 %{_mandir}/man1/gnome-keyring-daemon.1*
144
145 %files -n pam-pam_gnome_keyring
146 %defattr(644,root,root,755)
147 %attr(755,root,root) /%{_lib}/security/pam_gnome_keyring.so
This page took 0.041938 seconds and 3 git commands to generate.