]> git.pld-linux.org Git - packages/gnome-keyring.git/blob - gnome-keyring.spec
- deps cleanup, versioned Obsoletes, drop no longer used _libexecdir override
[packages/gnome-keyring.git] / gnome-keyring.spec
1 # TODO
2 #  Aug 14 13:19:00 haarber gnome-keyring-daemon[6524]: couldn't list keyrings at: /etc/certs: Error opening directory '/etc/certs': Permission denied
3 #
4 # Conditional build:
5 %bcond_with     p11_tests       # PKCS#11 tests
6 #
7 Summary:        Keep passwords and other user's secrets
8 Summary(pl.UTF-8):      Przechowywanie haseł i innych tajnych danych użytkowników
9 Name:           gnome-keyring
10 Version:        40.0
11 Release:        1
12 License:        LGPL v2+ (library), GPL v2+ (programs)
13 Group:          X11/Applications
14 Source0:        https://download.gnome.org/sources/gnome-keyring/40/%{name}-%{version}.tar.xz
15 # Source0-md5:  f404b61683a0ff54fb264b337772cff2
16 URL:            https://wiki.gnome.org/Projects/GnomeKeyring
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1:1.12
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gcr-devel >= 3.28.0
21 BuildRequires:  gettext-tools >= 0.19.8
22 BuildRequires:  glib2-devel >= 1:2.44.0
23 BuildRequires:  libcap-ng-devel
24 BuildRequires:  libgcrypt-devel >= 1.2.2
25 BuildRequires:  libselinux-devel
26 # for some test only
27 BuildRequires:  libtasn1-devel >= 0.3.4
28 BuildRequires:  libtool
29 BuildRequires:  libxslt-progs
30 BuildRequires:  p11-kit-devel >= 0.16
31 %{?with_p11_tests:BuildRequires:        p11-tests-devel >= 0.1}
32 BuildRequires:  pam-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(macros) >= 1.592
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 Requires(post,postun):  glib2 >= 1:2.44.0
38 Requires:       filesystem >= 4.0-28
39 Requires:       gcr >= 3.28.0
40 Requires:       glib2 >= 1:2.44.0
41 Requires:       hicolor-icon-theme
42 Requires:       libgcrypt >= 1.2.2
43 Requires:       p11-kit >= 0.16
44 Conflicts:      rpm < 4.4.2-0.2
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 GNOME Keyring is a program that keeps password and other secrets for
49 users. It is run as a daemon in the session, similar to ssh-agent, and
50 other applications can locate it by an environment variable.
51
52 %description -l pl.UTF-8
53 GNOME Keyring to program do przechowywania haseł i innych tajnych
54 danych użytkowników. Działa jako demon w sesji, podobnie do
55 ssh-agenta, a inne aplikacje mogą znaleźć go poprzez zmienną
56 środowiskową.
57
58 %package -n pam-pam_gnome_keyring
59 Summary:        A PAM module for unlocking keyrings at login time
60 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów kluczy w czasie logowania
61 License:        LGPL v2+
62 Group:          Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Obsoletes:      gnome-keyring-pam < 2.30.1-2
65
66 %description -n pam-pam_gnome_keyring
67 A PAM module that can automatically unlock the "login" keyring when
68 the user logs in and start the keyring daemon.
69
70 %description -n pam-pam_gnome_keyring -l pl.UTF-8
71 Moduł PAM, który może automatycznie odblokowywać zbiór kluczy "login"
72 w czasie logowania użytkownika i uruchamiania demona keyring.
73
74 %prep
75 %setup -q
76
77 %build
78 %{__libtoolize}
79 %{__aclocal}
80 %{__autoconf}
81 %{__autoheader}
82 %{__automake}
83 %configure \
84         SSH_ADD="/usr/bin/ssh-add" \
85         SSH_AGENT="/usr/bin/ssh-agent" \
86         --disable-silent-rules \
87         %{!?with_p11_tests:--disable-p11-tests} \
88         --with-pam-dir=/%{_lib}/security
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install install-pam \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_gnome_keyring.la
98 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pkcs11/gnome-keyring-pkcs11.la
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/devel/*.la
100
101 %find_lang %{name}
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post
107 %glib_compile_schemas
108
109 %postun
110 %glib_compile_schemas
111
112 %files -f %{name}.lang
113 %defattr(644,root,root,755)
114 %doc AUTHORS ChangeLog NEWS README
115 %attr(755,root,root) %{_bindir}/gnome-keyring
116 %attr(755,root,root) %{_bindir}/gnome-keyring-3
117 %attr(755,root,root) %{_bindir}/gnome-keyring-daemon
118 %attr(755,root,root) %{_libdir}/pkcs11/gnome-keyring-pkcs11.so
119 %dir %{_libdir}/%{name}
120 %dir %{_libdir}/%{name}/devel
121 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-gnome2-store-standalone.so
122 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-secret-store-standalone.so
123 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-ssh-store-standalone.so
124 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-xdg-store-standalone.so
125 %{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
126 %{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
127 %{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
128 %{_datadir}/GConf/gsettings/org.gnome.crypto.cache.convert
129 %{_datadir}/dbus-1/services/org.freedesktop.impl.portal.Secret.service
130 %{_datadir}/dbus-1/services/org.freedesktop.secrets.service
131 %{_datadir}/dbus-1/services/org.gnome.keyring.service
132 %{_datadir}/glib-2.0/schemas/org.gnome.crypto.cache.gschema.xml
133 %{_mandir}/man1/gnome-keyring.1*
134 %{_mandir}/man1/gnome-keyring-3.1*
135 %{_mandir}/man1/gnome-keyring-daemon.1*
136 %{_datadir}/p11-kit/modules/gnome-keyring.module
137 %{_datadir}/xdg-desktop-portal/portals/gnome-keyring.portal
138
139 %files -n pam-pam_gnome_keyring
140 %defattr(644,root,root,755)
141 %attr(755,root,root) /%{_lib}/security/pam_gnome_keyring.so
This page took 0.078099 seconds and 3 git commands to generate.