]> git.pld-linux.org Git - packages/gnome-keyring.git/blob - gnome-keyring.spec
- updated to 42.0
[packages/gnome-keyring.git] / gnome-keyring.spec
1 # TODO
2 #  Aug 14 13:19:00 haarber gnome-keyring-daemon[6524]: couldn't list keyrings at: /etc/certs: Error opening directory '/etc/certs': Permission denied
3 #
4 # Conditional build:
5 %bcond_with     p11_tests       # PKCS#11 tests
6 #
7 Summary:        Keep passwords and other user's secrets
8 Summary(pl.UTF-8):      Przechowywanie haseł i innych tajnych danych użytkowników
9 Name:           gnome-keyring
10 Version:        42.0
11 Release:        1
12 License:        LGPL v2+ (library), GPL v2+ (programs)
13 Group:          X11/Applications
14 Source0:        https://download.gnome.org/sources/gnome-keyring/42/%{name}-%{version}.tar.xz
15 # Source0-md5:  dd3a191a2f61a14ca67ad6e2a3e6287e
16 Patch0:         %{name}-missing.patch
17 URL:            https://wiki.gnome.org/Projects/GnomeKeyring
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake >= 1:1.12
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  gcr-devel >= 3.28.0
22 BuildRequires:  gcr-ui-devel >= 3.28.0
23 BuildRequires:  gettext-tools >= 0.19.8
24 BuildRequires:  glib2-devel >= 1:2.44.0
25 BuildRequires:  libcap-ng-devel
26 BuildRequires:  libgcrypt-devel >= 1.2.2
27 BuildRequires:  libselinux-devel
28 # for some test only
29 BuildRequires:  libtasn1-devel >= 0.3.4
30 BuildRequires:  libtool
31 BuildRequires:  libxslt-progs
32 BuildRequires:  p11-kit-devel >= 0.16
33 %{?with_p11_tests:BuildRequires:        p11-tests-devel >= 0.1}
34 BuildRequires:  pam-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(macros) >= 1.592
37 BuildRequires:  systemd-devel >= 1:209
38 BuildRequires:  tar >= 1:1.22
39 BuildRequires:  xz
40 Requires(post,postun):  glib2 >= 1:2.44.0
41 Requires:       filesystem >= 4.0-28
42 Requires:       gcr >= 3.28.0
43 Requires:       glib2 >= 1:2.44.0
44 Requires:       hicolor-icon-theme
45 Requires:       libgcrypt >= 1.2.2
46 Requires:       p11-kit >= 0.16
47 Conflicts:      rpm < 4.4.2-0.2
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 GNOME Keyring is a program that keeps password and other secrets for
52 users. It is run as a daemon in the session, similar to ssh-agent, and
53 other applications can locate it by an environment variable.
54
55 %description -l pl.UTF-8
56 GNOME Keyring to program do przechowywania haseł i innych tajnych
57 danych użytkowników. Działa jako demon w sesji, podobnie do
58 ssh-agenta, a inne aplikacje mogą znaleźć go poprzez zmienną
59 środowiskową.
60
61 %package -n pam-pam_gnome_keyring
62 Summary:        A PAM module for unlocking keyrings at login time
63 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów kluczy w czasie logowania
64 License:        LGPL v2+
65 Group:          Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Obsoletes:      gnome-keyring-pam < 2.30.1-2
68
69 %description -n pam-pam_gnome_keyring
70 A PAM module that can automatically unlock the "login" keyring when
71 the user logs in and start the keyring daemon.
72
73 %description -n pam-pam_gnome_keyring -l pl.UTF-8
74 Moduł PAM, który może automatycznie odblokowywać zbiór kluczy "login"
75 w czasie logowania użytkownika i uruchamiania demona keyring.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80
81 # paths to developer's home embedded, force regeneration
82 %{__rm} daemon/dbus/gkd-*-generated.[ch]
83
84 %build
85 %{__libtoolize}
86 %{__aclocal}
87 %{__autoconf}
88 %{__autoheader}
89 %{__automake}
90 %configure \
91         SSH_ADD="/usr/bin/ssh-add" \
92         SSH_AGENT="/usr/bin/ssh-agent" \
93         --disable-silent-rules \
94         %{!?with_p11_tests:--disable-p11-tests} \
95         --with-pam-dir=/%{_lib}/security
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install install-pam \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_gnome_keyring.la
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pkcs11/gnome-keyring-pkcs11.la
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/devel/*.la
107
108 %find_lang %{name}
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post
114 %glib_compile_schemas
115
116 %postun
117 %glib_compile_schemas
118
119 %files -f %{name}.lang
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog NEWS README
122 %attr(755,root,root) %{_bindir}/gnome-keyring
123 %attr(755,root,root) %{_bindir}/gnome-keyring-3
124 %attr(755,root,root) %{_bindir}/gnome-keyring-daemon
125 %attr(755,root,root) %{_libdir}/pkcs11/gnome-keyring-pkcs11.so
126 %dir %{_libdir}/%{name}
127 %dir %{_libdir}/%{name}/devel
128 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-gnome2-store-standalone.so
129 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-secret-store-standalone.so
130 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-ssh-store-standalone.so
131 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-xdg-store-standalone.so
132 %{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
133 %{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
134 %{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
135 %{_datadir}/GConf/gsettings/org.gnome.crypto.cache.convert
136 %{_datadir}/dbus-1/services/org.freedesktop.impl.portal.Secret.service
137 %{_datadir}/dbus-1/services/org.freedesktop.secrets.service
138 %{_datadir}/dbus-1/services/org.gnome.keyring.service
139 %{_datadir}/glib-2.0/schemas/org.gnome.crypto.cache.gschema.xml
140 %{_datadir}/p11-kit/modules/gnome-keyring.module
141 %{_datadir}/xdg-desktop-portal/portals/gnome-keyring.portal
142 %{systemduserunitdir}/gnome-keyring-daemon.service
143 %{systemduserunitdir}/gnome-keyring-daemon.socket
144 %{_mandir}/man1/gnome-keyring.1*
145 %{_mandir}/man1/gnome-keyring-3.1*
146 %{_mandir}/man1/gnome-keyring-daemon.1*
147
148 %files -n pam-pam_gnome_keyring
149 %defattr(644,root,root,755)
150 %attr(755,root,root) /%{_lib}/security/pam_gnome_keyring.so
This page took 0.120932 seconds and 3 git commands to generate.