]> git.pld-linux.org Git - packages/gnome-bluetooth.git/blob - gnome-bluetooth.spec
dc1e76a72a313fb016b7acd9d7f1d1518ffc6ec3
[packages/gnome-bluetooth.git] / gnome-bluetooth.spec
1 Summary:        GNOME Bluetooth Subsystem
2 Summary(pl.UTF-8):      Podsystem GNOME Bluetooth
3 Name:           gnome-bluetooth
4 Version:        3.8.1
5 Release:        1
6 License:        GPL v2+
7 Group:          X11/Applications
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-bluetooth/3.8/%{name}-%{version}.tar.xz
9 # Source0-md5:  a45c401daa15937a31c59d49943c59db
10 Source1:        61-%{name}-rfkill.rules
11 URL:            http://live.gnome.org/GnomeBluetooth
12 BuildRequires:  autoconf >= 2.52
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  docbook-dtd412-xml
15 BuildRequires:  gettext-devel >= 0.17
16 BuildRequires:  glib2-devel >= 1:2.30.0
17 BuildRequires:  gnome-common
18 BuildRequires:  gobject-introspection-devel >= 0.10.0
19 BuildRequires:  gtk+3-devel >= 3.0.0
20 BuildRequires:  intltool >= 0.40.0
21 BuildRequires:  libnotify-devel >= 0.7.0
22 BuildRequires:  libtool
23 BuildRequires:  libxml2-progs
24 BuildRequires:  pkgconfig
25 BuildRequires:  rpmbuild(macros) >= 1.592
26 BuildRequires:  xorg-lib-libX11-devel
27 BuildRequires:  xorg-lib-libXi-devel
28 BuildRequires:  yelp-tools
29 Requires(post,postun):  glib2 >= 1:2.26.0
30 Requires(post,postun):  gtk-update-icon-cache
31 Requires:       %{name}-libs = %{version}-%{release}
32 Requires:       bluez >= 4.22
33 Requires:       dbus(org.openobex.client)
34 Requires:       dconf
35 Requires:       hicolor-icon-theme
36 Requires:       udev-acl
37 Obsoletes:      bluez-gnome < 1.9
38 Obsoletes:      bluez-pin
39 Obsoletes:      nautilus-sendto-gnome-bluetooth
40 Obsoletes:      python-gnome-bluetooth
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 GNOME Bluetooth provides tools for controlling and communicating with
45 Bluetooth devices.
46
47 %description -l pl.UTF-8
48 GNOME Bluetooth dostarcza narzędzia do kontrolowania i komunikowania
49 się z urządzeniami Bluetooth.
50
51 %package libs
52 Summary:        GNOME Bluetooth subsystem shared libraries
53 Summary(pl.UTF-8):      Współdzielone biblioteki dla podsystemu GNOME Bluetooth
54 License:        LGPL v2+
55 Group:          X11/Libraries
56 Requires:       glib2 >= 1:2.30.0
57
58 %description libs
59 GNOME Bluetooth subsystem shared libraries.
60
61 %description libs -l pl.UTF-8
62 Współdzielone biblioteki dla podsystemu GNOME Bluetooth.
63
64 %package devel
65 Summary:        Header files for GNOME Bluetooth subsystem
66 Summary(pl.UTF-8):      Pliki nagłówkowe dla podsystemu GNOME Bluetooth
67 License:        LGPL v2+
68 Group:          X11/Development/Libraries
69 Requires:       %{name}-libs = %{version}-%{release}
70 Requires:       glib2-devel >= 1:2.30.0
71 Requires:       gtk+3-devel >= 3.0.0
72
73 %description devel
74 Header files for GNOME Bluetooth subsystem.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe dla podsystemu GNOME Bluetooth.
78
79 %package static
80 Summary:        Static GNOME Bluetooth library
81 Summary(pl.UTF-8):      Statyczna biblioteka GNOME Bluetooth
82 License:        LGPL v2+
83 Group:          X11/Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static GNOME Bluetooth library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka GNOME Bluetooth.
91
92 %package apidocs
93 Summary:        GNOME Bluetooth library API documentation
94 Summary(pl.UTF-8):      Dokumentacja API biblioteki GNOME Bluetooth
95 Group:          Documentation
96
97 %description apidocs
98 GNOME Bluetooth library API documentation.
99
100 %description apidocs -l pl.UTF-8
101 Dokumentacja API biblioteki GNOME Bluetooth.
102
103 %prep
104 %setup -q
105
106 %build
107 %{__gtkdocize}
108 %{__intltoolize}
109 %{__libtoolize}
110 %{__aclocal}
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         --disable-desktop-update \
116         --disable-icon-update \
117         --enable-introspection \
118         --disable-schemas-compile \
119         --disable-silent-rules \
120         --with-html-dir=%{_gtkdocdir}
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT/lib/udev/rules.d
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 install %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d
131
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la \
133         $RPM_BUILD_ROOT%{_libdir}/gnome-bluetooth/plugins/*.la
134
135 # workaround for (broken?) GnomeBluetoothApplet-1.0.typelib
136 ln -s %{_libdir}/gnome-bluetooth/libgnome-bluetooth-applet.so.0 $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth-applet.so.0
137
138 %find_lang %{name} --with-gnome --with-omf --all-name
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post
144 %update_icon_cache hicolor
145 %glib_compile_schemas
146
147 %postun
148 %update_icon_cache hicolor
149 %glib_compile_schemas
150
151 %post   libs -p /sbin/ldconfig
152 %postun libs -p /sbin/ldconfig
153
154 %files -f %{name}.lang
155 %defattr(644,root,root,755)
156 %doc AUTHORS ChangeLog NEWS README
157 %attr(755,root,root) %{_bindir}/bluetooth-sendto
158 %attr(755,root,root) %{_bindir}/bluetooth-wizard
159 %{_desktopdir}/bluetooth-sendto.desktop
160 %{_desktopdir}/bluetooth-wizard.desktop
161 %{_datadir}/gnome-bluetooth
162 %dir %{_libdir}/gnome-bluetooth/plugins
163 %attr(755,root,root) %{_libdir}/gnome-bluetooth/plugins/*.so
164 %{_iconsdir}/hicolor/*/*/*.png
165 %{_iconsdir}/hicolor/*/*/*.svg
166 %{_mandir}/man1/bluetooth-sendto.1*
167 %{_mandir}/man1/bluetooth-wizard.1*
168 /lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
169
170 %files libs
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libgnome-bluetooth.so.*.*.*
173 %attr(755,root,root) %ghost %{_libdir}/libgnome-bluetooth.so.11
174 %dir %{_libdir}/gnome-bluetooth
175 %attr(755,root,root) %{_libdir}/gnome-bluetooth/libgnome-bluetooth-applet.so
176 %attr(755,root,root) %{_libdir}/gnome-bluetooth/libgnome-bluetooth-applet.so.0
177 %attr(755,root,root) %{_libdir}/gnome-bluetooth/libgnome-bluetooth-applet.so.*.*.*
178 %attr(755,root,root) %{_libdir}/libgnome-bluetooth-applet.so.0
179 %{_libdir}/gnome-bluetooth/GnomeBluetoothApplet-1.0.typelib
180 %{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
181
182 %files devel
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libgnome-bluetooth.so
185 %{_includedir}/gnome-bluetooth
186 %{_pkgconfigdir}/gnome-bluetooth-1.0.pc
187 %{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
188
189 %files apidocs
190 %defattr(644,root,root,755)
191 %{_gtkdocdir}/gnome-bluetooth
This page took 0.034292 seconds and 2 git commands to generate.