]> git.pld-linux.org Git - packages/gnome-abrt.git/blob - gnome-abrt.spec
- rel 3; fix python 3.5 build
[packages/gnome-abrt.git] / gnome-abrt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # "make check" run (some pylint false positive?)
4
5 Summary:        A utility for viewing problems that have occurred with the system
6 Summary(pl.UTF-8):      Narzędzie do przeglądania problemów, które wystąpiły w systemie
7 Name:           gnome-abrt
8 Version:        1.2.0
9 Release:        3
10 License:        GPL v2+
11 Group:          Applications/System
12 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
13 # Source0-md5:  9b2d3e364e735f6a7401a84462951232
14 Patch0:         %{name}-pylint.patch
15 Patch1:         %{name}-python.patch
16 URL:            https://github.com/abrt/abrt/wiki/ABRT-Project
17 BuildRequires:  abrt-gui-devel >= 2.1.7
18 BuildRequires:  asciidoc
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  gettext-tools >= 0.17
22 BuildRequires:  gtk+3-devel >= 3.0
23 BuildRequires:  intltool >= 0.35.0
24 BuildRequires:  libreport-gtk-devel >= 2.0.20
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 %{?with_tests:BuildRequires:    pylint}
28 BuildRequires:  python3-devel >= 1:3.4
29 %{?with_tests:BuildRequires:    python3-libreport}
30 BuildRequires:  python3-pygobject3-devel >= 3.0
31 BuildRequires:  rpmbuild(macros) >= 1.596
32 BuildRequires:  sed >= 4.0
33 BuildRequires:  xmlto
34 BuildRequires:  xorg-lib-libX11-devel
35 Requires(post,postun):  gtk-update-icon-cache
36 Requires:       abrt-dbus
37 Requires:       abrt-gui-libs >= 2.1.7
38 Requires:       hicolor-icon-theme
39 Requires:       python3-dbus
40 Requires:       python3-libreport
41 Requires:       python3-pygobject3 >= 3.0
42 Requires:       python3-pyinotify
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 A GNOME application allows users to browse through detected problems
47 and provides them with convenient way for managing these problems.
48
49 %description -l pl.UTF-8
50 Aplikacja GNOME pozwalająca użytkownikom przeglądać wykryte problemy i
51 zapewniająca wygodny sposób zarządzania tymi problemami.
52
53 %prep
54 %setup -q
55 %patch0 -p1
56 %patch1 -p1
57
58 %{__sed} -i -e 's#-pedantic##g' configure.ac
59 %{__sed} -i -e '1s,#!/usr/bin/env python,#!/usr/bin/python,' src/gnome-abrt
60
61 %build
62 %{__libtoolize}
63 %{__aclocal}
64 %{__autoconf}
65 %{__automake}
66 %configure \
67         --disable-silent-rules \
68         %{!?with_tests:--with-nopylint}
69
70 %{__make}
71
72 %{?with_tests:%{__make} check}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/gnome_abrt/wrappers/*.la
80 %py_postclean
81
82 # just a copy of cs
83 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cs_CZ
84
85 %find_lang %{name}
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post
91 %update_icon_cache hicolor
92
93 %postun
94 %update_icon_cache hicolor
95
96 %files -f %{name}.lang
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_bindir}/gnome-abrt
99 %dir %{py3_sitedir}/gnome_abrt
100 %{py3_sitedir}/gnome_abrt/*.py
101 %{py3_sitedir}/gnome_abrt/__pycache__
102 %dir %{py3_sitedir}/gnome_abrt/url
103 %{py3_sitedir}/gnome_abrt/url/*.py
104 %{py3_sitedir}/gnome_abrt/url/__pycache__
105 %dir %{py3_sitedir}/gnome_abrt/wrappers
106 %{py3_sitedir}/gnome_abrt/wrappers/__init__.py
107 %{py3_sitedir}/gnome_abrt/wrappers/__pycache__
108 %attr(755,root,root) %{py3_sitedir}/gnome_abrt/wrappers/_wrappers.so
109 %{_datadir}/gnome-abrt
110 %{_datadir}/appdata/gnome-abrt.appdata.xml
111 %{_desktopdir}/gnome-abrt.desktop
112 %{_iconsdir}/hicolor/*x*/apps/gnome-abrt.png
113 %{_iconsdir}/hicolor/*x*/status/gnome-abrt.png
114 %{_iconsdir}/hicolor/symbolic/apps/gnome-abrt-symbolic.svg
115 %{_mandir}/man1/gnome-abrt.1*
This page took 0.038817 seconds and 4 git commands to generate.