]> git.pld-linux.org Git - packages/gmock.git/blob - gmock.spec
d508073ab43bb28d126562449fa8cccf8352874a
[packages/gmock.git] / gmock.spec
1 Summary:        Google C++ Mocking Framework
2 Summary(pl.UTF-8):      Szkielet Google Mock dla C++
3 Name:           gmock
4 Version:        1.7.0
5 Release:        4
6 License:        BSD
7 Group:          Development/Libraries
8 #Source0Download: https://github.com/google/googlemock/releases
9 #Source0:       https://github.com/google/googlemock/archive/release-%{version}/%{name}-%{version}.tar.gz
10 Source0:        https://googlemock.googlecode.com/files/%{name}-%{version}.zip
11 # Source0-md5:  073b984d8798ea1594f5e44d85b20d66
12 Patch0:         install.patch
13 URL:            https://github.com/google/googlemock
14 BuildRequires:  autoconf >= 2.59
15 BuildRequires:  automake >= 1:1.9
16 BuildRequires:  gtest-devel >= 1.7.0
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtool >= 2:1.5
19 BuildRequires:  python >= 2.3
20 BuildRequires:  sed >= 4.0
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %if %{_host_cpu} == "x32"
25 %define build_arch %{_target_platform}
26 %else
27 %define build_arch %{_host}
28 %endif
29
30 %description
31 Inspired by jMock, EasyMock, and Hamcrest, and designed with C++'s
32 specifics in mind, Google C++ Mocking Framework (or Google Mock for
33 short) is a library for writing and using C++ mock classes.
34
35 Google Mock:
36 - lets you create mock classes trivially using simple macros,
37 - supports a rich set of matchers and actions,
38 - handles unordered, partially ordered, or completely ordered
39   expectations,
40 - is extensible by users, and
41 - works on Linux, Mac OS X, Windows, Windows Mobile, minGW, and
42   Symbian.
43
44 %description -l pl.UTF-8
45 Google C++ Mocking Framework (w skrócie Google Mock) to zainspirowana
46 przez jMock, EasyMock i Hamcrest, zaprojektowana z myślą o specyfice
47 C++ biblioteka do pisania i wykorzystywania klas "mock" w C++.
48
49 Google Mock:
50 - pozwala tworzyć klasy "mock" w sposób trywialny przy użyciu makr;
51 - obsługuje bogaty zbiór dopasowań i akcji;
52 - obsługuje oczekiwania nieuporządkowane, częściowo uporządkowane
53   lub w pełni uporządkowane;
54 - jest rozszerzalna dla użytkownika;
55 - działa na Linuksie, Mac OS X, Windows, Windows Mobile, minGW oraz
56   Symbianie.
57
58 %package devel
59 Summary:        Google C++ Mocking Framework
60 Summary(pl.UTF-8):      Szkielet Google Mock dla C++
61 Group:          Development/Libraries
62 Requires:       gtest-devel >= 1.7.0-2
63 Requires:       libstdc++-devel
64 Provides:       %{name} = %{version}-%{release}
65 Obsoletes:      gmock < 1.6.0-3
66
67 %description devel
68 Inspired by jMock, EasyMock, and Hamcrest, and designed with C++'s
69 specifics in mind, Google C++ Mocking Framework (or Google Mock for
70 short) is a library for writing and using C++ mock classes.
71
72 Google Mock:
73 - lets you create mock classes trivially using simple macros,
74 - supports a rich set of matchers and actions,
75 - handles unordered, partially ordered, or completely ordered
76   expectations,
77 - is extensible by users, and
78 - works on Linux, Mac OS X, Windows, Windows Mobile, minGW, and
79   Symbian.
80
81 %description devel -l pl.UTF-8
82 Google C++ Mocking Framework (w skrócie Google Mock) to zainspirowana
83 przez jMock, EasyMock i Hamcrest, zaprojektowana z myślą o specyfice
84 C++ biblioteka do pisania i wykorzystywania klas "mock" w C++.
85
86 Google Mock:
87 - pozwala tworzyć klasy "mock" w sposób trywialny przy użyciu makr;
88 - obsługuje bogaty zbiór dopasowań i akcji;
89 - obsługuje oczekiwania nieuporządkowane, częściowo uporządkowane
90   lub w pełni uporządkowane;
91 - jest rozszerzalna dla użytkownika;
92 - działa na Linuksie, Mac OS X, Windows, Windows Mobile, minGW oraz
93   Symbianie.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 grep -rl bin/env scripts | xargs %{__sed} -i -e '1s,^#!.*python,#!%{__python},'
100
101 %build
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         --host=%{build_arch} \
109         --build=%{build_arch}
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 %{__make} -j1 install \
115         INSTALL="%{__install} -p" \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %{__rm} $RPM_BUILD_ROOT%{_datadir}/gmock/generator/{README.cppclean,LICENSE,README}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files devel
124 %defattr(644,root,root,755)
125 %doc CHANGES CONTRIBUTORS LICENSE README
126 %attr(755,root,root) %{_bindir}/gmock-config
127 %{_includedir}/%{name}
128 %{_npkgconfigdir}/gmock.pc
129 %dir %{_datadir}/%{name}
130 %dir %{_datadir}/%{name}/generator
131 %attr(755,root,root) %{_datadir}/%{name}/generator/gmock_gen.py
132 %dir %{_datadir}/%{name}/generator/cpp
133 %attr(755,root,root) %{_datadir}/%{name}/generator/cpp/*.py
134 %{_prefix}/src/%{name}
This page took 0.094406 seconds and 2 git commands to generate.