]> git.pld-linux.org Git - packages/gmock.git/blob - gmock.spec
7a676b071cb9b8c5e2df9c3a8bd1c26fae85094d
[packages/gmock.git] / gmock.spec
1 Summary:        Google C++ Mocking Framework
2 Summary(pl.UTF-8):      Szkielet Google Mock dla C++
3 Name:           gmock
4 Version:        1.7.0
5 Release:        1
6 License:        BSD
7 Group:          Development/Libraries
8 #Source0Download: http://code.google.com/p/googlemock/downloads/list
9 Source0:        https://googlemock.googlecode.com/files/%{name}-%{version}.zip
10 # Source0-md5:  073b984d8798ea1594f5e44d85b20d66
11 Patch0:         install.patch
12 URL:            http://code.google.com/p/googlemock/
13 BuildRequires:  autoconf >= 2.59
14 BuildRequires:  automake >= 1:1.9
15 BuildRequires:  gtest-devel >= 1.7.0
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool >= 2:1.5
18 BuildRequires:  python >= 2.3
19 BuildRequires:  sed >= 4.0
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Inspired by jMock, EasyMock, and Hamcrest, and designed with C++'s
25 specifics in mind, Google C++ Mocking Framework (or Google Mock for
26 short) is a library for writing and using C++ mock classes.
27
28 Google Mock:
29 - lets you create mock classes trivially using simple macros,
30 - supports a rich set of matchers and actions,
31 - handles unordered, partially ordered, or completely ordered
32   expectations,
33 - is extensible by users, and
34 - works on Linux, Mac OS X, Windows, Windows Mobile, minGW, and
35   Symbian.
36
37 %description -l pl.UTF-8
38 Google C++ Mocking Framework (w skrócie Google Mock) to zainspirowana
39 przez jMock, EasyMock i Hamcrest, zaprojektowana z myślą o specyfice
40 C++ biblioteka do pisania i wykorzystywania klas "mock" w C++.
41
42 Google Mock:
43 - pozwala tworzyć klasy "mock" w sposób trywialny przy użyciu makr;
44 - obsługuje bogaty zbiór dopasowań i akcji;
45 - obsługuje oczekiwania nieuporządkowane, częściowo uporządkowane
46   lub w pełni uporządkowane;
47 - jest rozszerzalna dla użytkownika;
48 - działa na Linuksie, Mac OS X, Windows, Windows Mobile, minGW oraz
49   Symbianie.
50
51 %package devel
52 Summary:        Google C++ Mocking Framework
53 Summary(pl.UTF-8):      Szkielet Google Mock dla C++
54 Group:          Development/Libraries
55 Requires:       gtest-devel >= 1.7.0
56 Requires:       libstdc++-devel
57 Provides:       %{name} = %{version}-%{release}
58 Obsoletes:      gmock < 1.6.0-3
59
60 %description devel
61 Inspired by jMock, EasyMock, and Hamcrest, and designed with C++'s
62 specifics in mind, Google C++ Mocking Framework (or Google Mock for
63 short) is a library for writing and using C++ mock classes.
64
65 Google Mock:
66 - lets you create mock classes trivially using simple macros,
67 - supports a rich set of matchers and actions,
68 - handles unordered, partially ordered, or completely ordered
69   expectations,
70 - is extensible by users, and
71 - works on Linux, Mac OS X, Windows, Windows Mobile, minGW, and
72   Symbian.
73
74 %description devel -l pl.UTF-8
75 Google C++ Mocking Framework (w skrócie Google Mock) to zainspirowana
76 przez jMock, EasyMock i Hamcrest, zaprojektowana z myślą o specyfice
77 C++ biblioteka do pisania i wykorzystywania klas "mock" w C++.
78
79 Google Mock:
80 - pozwala tworzyć klasy "mock" w sposób trywialny przy użyciu makr;
81 - obsługuje bogaty zbiór dopasowań i akcji;
82 - obsługuje oczekiwania nieuporządkowane, częściowo uporządkowane
83   lub w pełni uporządkowane;
84 - jest rozszerzalna dla użytkownika;
85 - działa na Linuksie, Mac OS X, Windows, Windows Mobile, minGW oraz
86   Symbianie.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 grep -rl bin/env scripts | xargs %{__sed} -i -e '1s,^#!.*python,#!%{__python},'
93
94 %build
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %{__autoheader}
99 %{__automake}
100 %configure \
101         --host=%{_host} \
102         --build=%{_host}
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 %{__make} -j1 install \
108         INSTALL="%{__install} -p" \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 %{__rm} $RPM_BUILD_ROOT%{_datadir}/gmock/generator/{README.cppclean,LICENSE,README}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files devel
117 %defattr(644,root,root,755)
118 %doc CHANGES CONTRIBUTORS LICENSE README
119 %attr(755,root,root) %{_bindir}/gmock-config
120 %{_includedir}/%{name}
121 %{_npkgconfigdir}/gmock.pc
122 %dir %{_datadir}/%{name}
123 %dir %{_datadir}/%{name}/generator
124 %attr(755,root,root) %{_datadir}/%{name}/generator/gmock_gen.py
125 %dir %{_datadir}/%{name}/generator/cpp
126 %attr(755,root,root) %{_datadir}/%{name}/generator/cpp/*.py
127 %{_prefix}/src/%{name}
This page took 0.0419 seconds and 2 git commands to generate.