]> git.pld-linux.org Git - packages/gmock.git/blob - gmock.spec
0bd2953f09f35c33d6306721d38b883b74ded40a
[packages/gmock.git] / gmock.spec
1 Summary:        Google C++ Mocking Framework
2 Name:           gmock
3 Version:        1.6.0
4 Release:        1
5 License:        BSD
6 Group:          Development/Libraries
7 Source0:        https://googlemock.googlecode.com/files/%{name}-%{version}.zip
8 # Source0-md5:  f547f47321ca88d3965ca2efdcc2a3c1
9 Patch0:         install.patch
10 URL:            http://code.google.com/p/googlemock/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  gtest-devel >= 1.5.0
14 BuildRequires:  libtool
15 BuildRequires:  python
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Inspired by jMock, EasyMock, and Hamcrest, and designed with C++'s
20 specifics in mind, Google C++ Mocking Framework (or Google Mock for
21 short) is a library for writing and using C++ mock classes.
22
23 Google Mock:
24
25  o lets you create mock classes trivially using simple macros,
26  o supports a rich set of matchers and actions,
27  o handles unordered, partially ordered, or completely ordered
28    expectations,
29  o is extensible by users, and
30  o works on Linux, Mac OS X, Windows, Windows Mobile, minGW, and
31    Symbian.
32
33 %prep
34 %setup -q
35 %patch0 -p1
36
37 %build
38 %{__aclocal}
39 %{__autoconf}
40 %{__automake}
41 %{__autoheader}
42 %configure
43
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} -j1 install \
50         INSTALL="%{__install} -p" \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post -p /sbin/ldconfig
57 %postun -p /sbin/ldconfig
58
59 %files
60 %defattr(644,root,root,755)
61 %doc CHANGES CONTRIBUTORS COPYING README
62 %attr(755,root,root) %{_bindir}/gmock-config
63 %{_includedir}/%{name}
64 %{_npkgconfigdir}/*
65 %dir %{_datadir}/%{name}/generator
66 %attr(755,root,root) %{_datadir}/%{name}/generator/gmock_gen.py
67 %dir %{_datadir}/%{name}/generator/cpp
68 %attr(755,root,root) %{_datadir}/%{name}/generator/cpp/*.py
69 %{_prefix}/src/%{name}
This page took 0.068864 seconds and 2 git commands to generate.