]> git.pld-linux.org Git - packages/gmetadom.git/blob - gmetadom.spec
- dropped .la file, release 15
[packages/gmetadom.git] / gmetadom.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml           # OCaml binding
4 %bcond_without  ocaml_opt       # native optimized binaries
5 #
6 %ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7 %undefine       with_ocaml_opt
8 %endif
9
10 %define         ocaml_ver       1:3.09.3
11 Summary:        gdome2 binding for various programming languages
12 Summary(pl.UTF-8):      Wiązania gdome2 dla różnych języków programowania
13 Name:           gmetadom
14 Version:        0.2.6
15 Release:        15
16 License:        LGPL v2.1+
17 Group:          Libraries
18 Source0:        http://downloads.sourceforge.net/gmetadom/%{name}-%{version}.tar.gz
19 # Source0-md5:  7bfb5d9c6f20ffa5e790b63d1f8cb481
20 Patch0:         %{name}-gcc43.patch
21 URL:            http://gmetadom.sourceforge.net/
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake
24 BuildRequires:  gdome2-devel >= 0.8.0
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool >= 2:1.5
27 %{?with_ocaml:BuildRequires:    ocaml >= %{ocaml_ver}}
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpmbuild(macros) >= 1.198
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 gdome2 binding for various programming languages. gdome2 is a fast,
34 light and complete DOM level2 implementation based on libxml2.
35
36 %description -l pl.UTF-8
37 Wiązania gdome2 dla różnych języków programowania. gdome2 jest szybką,
38 lekką i kompletną implementacją DOM poziom 2 opartą o libxml2.
39
40 %package -n ocaml-gdome2
41 Summary:        gdome2 binding for OCaml
42 Summary(pl.UTF-8):      Wiązania gdome2 dla OCamla
43 Group:          Libraries
44 Requires:       gdome2 >= 0.8.0
45 %requires_eq    ocaml-runtime
46
47 %description -n ocaml-gdome2
48 gdome2 binding for OCaml. gdome2 is a fast, light and complete DOM
49 level2 implementation based on libxml2.
50
51 This package contains files needed to run bytecode executables using
52 this library.
53
54 %description -n ocaml-gdome2 -l pl.UTF-8
55 Wiązania gdome2 dla OCamla. gdome2 jest szybką, lekką i kompletną
56 implementacją DOM poziom 2 opartą o libxml2.
57
58 Pakiet ten zawiera binaria potrzebne do uruchamiania programów
59 używających tej biblioteki.
60
61 %package -n ocaml-gdome2-devel
62 Summary:        gdome2 binding for OCaml - development part
63 Summary(pl.UTF-8):      Wiązania gdome2 dla OCamla - cześć programistyczna
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       ocaml-gdome2 = %{version}-%{release}
67 %requires_eq    ocaml
68
69 %description -n ocaml-gdome2-devel
70 gdome2 binding for OCaml. gdome2 is a fast, light and complete DOM
71 level2 implementation based on libxml2.
72
73 This package contains files needed to develop OCaml programs using
74 this library.
75
76 %description -n ocaml-gdome2-devel -l pl.UTF-8
77 Wiązania gdome2 dla OCamla. gdome2 jest szybką, lekką i kompletną
78 implementacją DOM poziom 2 opartą o libxml2.
79
80 Pakiet ten zawiera pliki niezbędne do tworzenia programów używających
81 tej biblioteki.
82
83 %package -n gdome2-cpp_smart
84 Summary:        gdome2 binding for C++/smart pointers
85 Summary(pl.UTF-8):      Wiązania gdome2 dla C++/mądre wskaźniki
86 Group:          Libraries
87 Requires:       gdome2 >= 0.8.0
88
89 %description -n gdome2-cpp_smart
90 gdome2 binding for C++ with smart pointers. gdome2 is a fast, light
91 and complete DOM level2 implementation based on libxml2.
92
93 %description -n gdome2-cpp_smart -l pl.UTF-8
94 Wiązania gdome2 dla C++ z mądrymi wskaźnikami. gdome2 jest szybką,
95 lekką i kompletną implementacją DOM poziom 2 opartą o libxml2.
96
97 %package -n gdome2-cpp_smart-devel
98 Summary:        gdome2 binding for C++/smart pointers - development part
99 Summary(pl.UTF-8):      Wiązania gdome2 dla C++/mądre wskaźniki - cześć programistyczna
100 Group:          Development/Libraries
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       gdome2-cpp_smart = %{version}-%{release}
103 Requires:       gdome2-devel >= 0.8.0
104 Requires:       libstdc++-devel
105
106 %description -n gdome2-cpp_smart-devel
107 gdome2 binding for C++ with smart pointers. gdome2 is a fast, light
108 and complete DOM level2 implementation based on libxml2.
109
110 This package contains header files needed to develop programs using
111 gdome2-cpp_smart.
112
113 %description -n gdome2-cpp_smart-devel -l pl.UTF-8
114 Wiązania gdome2 dla C++ z mądrymi wskaźnikami. gdome2 jest szybką,
115 lekką i kompletną implementacją DOM poziom 2 opartą o libxml2.
116
117 Pakiet ten zawiera pliki nagłówkowe niezbędne do rozwijania programów
118 korzystających z gdome2-cpp_smart.
119
120 %package -n gdome2-cpp_smart-static
121 Summary:        gdome2 binding for C++/smart pointers - static libraries
122 Summary(pl.UTF-8):      Wiązania gdome2 dla C++/mądre wskaźniki - biblioteki statyczne
123 Group:          Development/Libraries
124 Requires:       gdome2-cpp_smart-devel = %{version}-%{release}
125
126 %description -n gdome2-cpp_smart-static
127 gdome2 binding for C++ with smart pointers. gdome2 is a fast, light
128 and complete DOM level2 implementation based on libxml2.
129
130 This package contains static libraries needed to develop programs
131 using gdome2-cpp_smart.
132
133 %description -n gdome2-cpp_smart-static -l pl.UTF-8
134 Wiązania gdome2 dla C++ z mądrymi wskaźnikami. gdome2 jest szybką,
135 lekką i kompletną implementacją DOM poziom 2 opartą o libxml2.
136
137 Pakiet ten zawiera statyczne biblioteki niezbędne do rozwijania
138 programów korzystających z gdome2-cpp_smart.
139
140 %prep
141 %setup -q
142 %patch0 -p1
143
144 # clean up CVS dirs in xml tree
145 find -name CVS | xargs rm -rf
146
147 %build
148 %{__libtoolize}
149 %{__aclocal}
150 %{__autoconf}
151 %{__automake}
152
153 %configure \
154         --with-modules="gdome_cpp_smart%{?with_ocaml: gdome_caml}"
155
156 %{__make} -j1
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 install -d $RPM_BUILD_ROOT%{_examplesdir}/ocaml-gdome2-%{version}
165 install src/gdome_caml/examples/*.ml $RPM_BUILD_ROOT%{_examplesdir}/ocaml-gdome2-%{version}
166
167 # obsoleted by pkg-config
168 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgmetadom_gdome_cpp_smart.la
169
170 %if %{with ocaml}
171 # .mli packaged as %doc
172 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/gdome2/*.{ml,mli}
173 # findlib-specific file, useless with rpm
174 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/dllmlgdome.so.owner
175 %endif
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post   -n gdome2-cpp_smart -p /sbin/ldconfig
181 %postun -n gdome2-cpp_smart -p /sbin/ldconfig
182
183 %files
184 %defattr(644,root,root,755)
185 %doc xml/DOM/* AUTHORS ChangeLog HISTORY LICENSE
186 %dir %{_includedir}/gmetadom
187
188 %if %{with ocaml}
189 %files -n ocaml-gdome2
190 %defattr(644,root,root,755)
191 %dir %{_libdir}/ocaml/gdome2
192 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllmlgdome.so
193
194 %files -n ocaml-gdome2-devel
195 %defattr(644,root,root,755)
196 %doc src/gdome_caml/ocaml/gdome.mli
197 %{_libdir}/ocaml/gdome2/META
198 %{_libdir}/ocaml/gdome2/*.cmi
199 %{_libdir}/ocaml/gdome2/gdomeInit.cmo
200 %{_libdir}/ocaml/gdome2/mlgdomevalue.h
201 %{_libdir}/ocaml/gdome2/mlgdome.cma
202 %{_libdir}/ocaml/gdome2/mlogdome.cma
203 %if %{with ocaml_opt}
204 %{_libdir}/ocaml/gdome2/gdomeInit.cmx
205 %{_libdir}/ocaml/gdome2/gdomeInit.o
206 %{_libdir}/ocaml/gdome2/mlgdome.a
207 %{_libdir}/ocaml/gdome2/mlgdome.cmxa
208 %{_libdir}/ocaml/gdome2/mlogdome.a
209 %{_libdir}/ocaml/gdome2/mlogdome.cmxa
210 %endif
211 %{_libdir}/ocaml/gdome2/libmlgdome.a
212 %{_examplesdir}/ocaml-gdome2-%{version}
213 %endif
214
215 %files -n gdome2-cpp_smart
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_libdir}/libgmetadom_gdome_cpp_smart.so.*.*.*
218 %attr(755,root,root) %ghost %{_libdir}/libgmetadom_gdome_cpp_smart.so.0
219
220 %files -n gdome2-cpp_smart-devel
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_libdir}/libgmetadom_gdome_cpp_smart.so
223 %{_includedir}/gmetadom
224 %{_pkgconfigdir}/gdome2-cpp-smart.pc
225
226 %files -n gdome2-cpp_smart-static
227 %defattr(644,root,root,755)
228 %{_libdir}/libgmetadom_gdome_cpp_smart.a
This page took 0.109403 seconds and 3 git commands to generate.