]> git.pld-linux.org Git - packages/glusterfs.git/blob - glusterfs.spec
- Release rc1.2. Seems to work.
[packages/glusterfs.git] / glusterfs.spec
1 # TODO: Decide what to do with -static
2 #       Obsolete it, fix build ?
3 # TODO: Conditional builds + packages for:
4 # Berkeley-DB        : yes
5 # mod_glusterfs      : yes (2.2)
6 %bcond_without  ibverbs         # ib-verbs transport
7 #
8 Summary:        Clustered File Storage that can scale to peta bytes
9 Summary(pl.UTF-8):      Klastrowy system przechowywania plików skalujący się do petabajtów
10 Name:           glusterfs
11 Version:        2.0.0
12 %define          _rc        rc1
13 %define          _version        %{version}%{_rc}
14 Release:        0.%{_rc}.2
15 License:        GPL v3+
16 Group:          Applications/System
17 Source0:        http://ftp.zresearch.com/pub/gluster/glusterfs/2.0/%{version}/%{name}-%{_version}.tar.gz
18 # Source0-md5:  6f6943fbb958c3f386ce3f152cf7ccdd
19 Source1:        glusterfsd.init
20 URL:            http://gluster.org/glusterfs.php
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  bison
24 BuildRequires:  flex
25 BuildRequires:  libfuse-devel >= 2.6
26 BuildRequires:  libtool
27 %{?with_ibverbs:BuildRequires:  libibverbs-devel >= 1.0.4}
28 BuildRequires:  rpmbuild(macros) >= 1.228
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 GlusterFS is a clustered file-system capable of scaling to several
33 peta-bytes. It aggregates various storage bricks over Infiniband RDMA
34 or TCP/IP interconnect into one large parallel network file system.
35 GlusterFS is one of the most sophisticated file system in terms of
36 features and extensibility. It borrows a powerful concept called
37 Translators from GNU Hurd kernel. Much of the code in GlusterFS is in
38 userspace and easily manageable.
39
40 %description -l pl.UTF-8
41 GlusterFS to klastrowy system plików skalujący się do petabajtów.
42 Scala różne kawałki miejsca po łączach Infiniband RDMA lub TCP/IP
43 w jeden duży, równoległy sieciowy system plików. GlusterFS to
44 jeden z najbardziej wyszukanych systemów plików jeśli chodzi o
45 możliwości i rozszerzalność. Zapożycza potężną ideę o nazwie
46 Translators z jądra GNU Hurd. Duża część kodu GlusterFS działa w
47 przestrzeni użytkownika i jest łatwo zarządzalna.
48
49 %package common
50 Summary:        GlusterFS Library and Translators
51 Summary(pl.UTF-8):      Biblioteka i translatory GlusterFS-a
52 Group:          Libraries
53
54 %description common
55 GlusterFS is a clustered file-system capable of scaling to several
56 peta-bytes. It aggregates various storage bricks over Infiniband RDMA
57 or TCP/IP interconnect into one large parallel network file system.
58 GlusterFS is one of the most sophisticated file system in terms of
59 features and extensibility. It borrows a powerful concept called
60 Translators from GNU Hurd kernel. Much of the code in GlusterFS is in
61 userspace and easily manageable.
62
63 This package includes libglusterfs and glusterfs translator modules
64 common to both GlusterFS server and client framework.
65
66 %description common -l pl.UTF-8
67 GlusterFS to klastrowy system plików skalujący się do petabajtów.
68 Scala różne kawałki miejsca po łączach Infiniband RDMA lub TCP/IP
69 w jeden duży, równoległy sieciowy system plików. GlusterFS to
70 jeden z najbardziej wyszukanych systemów plików jeśli chodzi o
71 możliwości i rozszerzalność. Zapożycza potężną ideę o nazwie
72 Translators z jądra GNU Hurd. Duża część kodu GlusterFS działa w
73 przestrzeni użytkownika i jest łatwo zarządzalna.
74
75 Ten pakiet zawiera libglusterfs i moduły translatorów glusterfs
76 wspólne dla klienta jak i serwera GlusterFS-a.
77
78 %package devel
79 Summary:        GlusterFS development files
80 Summary(pl.UTF-8):      Pliki programistyczne GlusterFS-a
81 Group:          Development/Libraries
82 Requires:       %{name}-common = %{version}-%{release}
83
84 %description devel
85 This package provides the development files for GlusterFS library.
86
87 %description devel -l pl.UTF-8
88 Ten pakiet udostępnia pliki programistyczne biblioteki GlusterFS-a.
89
90 # %package static
91 # Summary:      Static GlusterFS library
92 # Summary(pl.UTF-8):    Statyczna biblioteka GlusterFS-a
93 # Group:                Development/Libraries
94 # Requires:     %{name}-devel = %{version}-%{release}
95 #
96 # %description static
97 # Static GlusterFS library.
98
99 # %description static -l pl.UTF-8
100 # Statyczna biblioteka GlusterFS-a.
101
102 %package transport-ibverbs
103 Summary:        InfiniBand "verbs" transport plugins for GlusterFS
104 Summary(pl.UTF-8):      Wtyczki transportu "verbs" InfiniBand dla GlusterFS-a
105 Group:          Libraries
106 Requires:       %{name}-common = %{version}-%{release}
107 Requires:       libibverbs >= 1.0.4
108
109 %description transport-ibverbs
110 InfiniBand "verbs" transport plugins for GlusterFS.
111
112 %description transport-ibverbs -l pl.UTF-8
113 Wtyczki transportu "verbs" InfiniBand dla GlusterFS-a.
114
115 %package server
116 Summary:        GlusterFS Server
117 Summary(pl.UTF-8):      Serwer GlusterFS-a
118 Group:          Daemons
119 Requires:       %{name}-common = %{version}-%{release}
120 Requires(post,preun):   /sbin/chkconfig
121 Requires:       rc-scripts
122
123 %description server
124 This package provides the glusterfs server daemon.
125
126 %description server -l pl.UTF-8
127 Ten pakiet zawiera część serwerową GlusterFS-a.
128
129 %package client
130 Summary:        GlusterFS Client
131 Summary(pl.UTF-8):      Klient GlusterFS
132 Group:          Applications/System
133 Requires:       %{name}-common = %{version}-%{release}
134 Requires:       libfuse >= 2.6
135
136 %description client
137 This package provides the FUSE based GlusterFS client.
138
139 %description client -l pl.UTF-8
140 Ten pakiet udostępnia opartego na FUSE klienta GlusterFS-a.
141
142 %prep
143 %setup -q -n %{name}-%{_version}
144 %{__sed} -i -e 's|-avoidversion|-avoid-version|g'  */*/*/Makefile.am  */*/*/*/Makefile.am
145
146 cp -l doc/examples/README README.examples
147
148 %build
149 %{__libtoolize}
150 %{__aclocal}
151 %{__autoconf}
152 %{__automake}
153 %configure \
154         %{!?with_ibverbs:--disable-ibverbs}
155 %{__make}
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/glusterfsd
165
166 rm -r $RPM_BUILD_ROOT%{_docdir}/glusterfs/examples
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   common  -p /sbin/ldconfig
172 %postun common  -p /sbin/ldconfig
173
174 %files common
175 %defattr(644,root,root,755)
176 %doc AUTHORS ChangeLog COPYING INSTALL NEWS README README.examples doc/*.vol.sample doc/examples/*.vol
177 %dir %{_sysconfdir}/%{name}
178 %attr(755,root,root) %{_libdir}/libglusterfs.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libglusterfs.so.0
180 %attr(755,root,root) %{_libdir}/libglusterfsclient.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libglusterfsclient.so.0
182
183 %dir %{_libdir}/glusterfs
184 %attr(755,root,root) %{_libdir}/glusterfs/glusterfs-booster.so
185 %dir %{_libdir}/glusterfs/%{_version}
186 %dir %{_libdir}/glusterfs/%{_version}/auth
187 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/auth/addr.so
188 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/auth/login.so
189
190 %dir %{_libdir}/glusterfs/%{_version}/scheduler
191 ## %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/scheduler/{alu,nufa,random,rr,switch}.so*
192
193 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/scheduler/alu.so
194 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/scheduler/nufa.so
195 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/scheduler/random.so
196 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/scheduler/rr.so
197 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/scheduler/switch.so
198
199 %dir %{_libdir}/glusterfs/%{_version}/transport
200 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/transport/ib-verbs.so
201 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/transport/socket.so
202
203 %dir %{_libdir}/glusterfs/%{_version}/xlator
204 %dir %{_libdir}/glusterfs/%{_version}/xlator/cluster
205 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/xlator/cluster/*.so
206
207 %dir %{_libdir}/glusterfs/%{_version}/xlator/debug
208 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/xlator/debug/*.so
209 %dir %{_libdir}/glusterfs/%{_version}/xlator/encryption
210 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/xlator/encryption/*.so
211 %dir %{_libdir}/glusterfs/%{_version}/xlator/features
212 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/xlator/features/*.so
213 %dir %{_libdir}/glusterfs/%{_version}/xlator/mount
214 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/xlator/mount/fuse.so
215 %dir %{_libdir}/glusterfs/%{_version}/xlator/performance
216 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/xlator/performance/*.so
217 %dir %{_libdir}/glusterfs/%{_version}/xlator/protocol
218 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/xlator/protocol/*.so
219 %dir %{_libdir}/glusterfs/%{_version}/xlator/storage
220 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/xlator/storage/*.so
221
222 %{_mandir}/man8/*.8*
223
224 %dir /var/log/glusterfs
225
226 %files devel
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_libdir}/libglusterfs.so
229 %{_libdir}/libglusterfs.la
230 #%{_includedir}/*.h
231
232 # %files static
233 # %defattr(644,root,root,755)
234 # %{_libdir}/libglusterfs.a
235
236 %if %{with ibverbs}
237 %files transport-ibverbs
238 %defattr(644,root,root,755)
239 %attr(755,root,root) %{_libdir}/glusterfs/%{_version}/transport/ib-verbs.so
240 %endif
241
242 %files server
243 %defattr(644,root,root,755)
244 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
245 %attr(754,root,root) /etc/rc.d/init.d/glusterfsd
246 %attr(755,root,root) %{_sbindir}/glusterfsd
247
248 %files client
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{_sbindir}/glusterfs
251 %attr(755,root,root) /sbin/mount.glusterfs
This page took 0.039133 seconds and 3 git commands to generate.