]> git.pld-linux.org Git - packages/glslang.git/blob - glslang.spec
up to 7.12.3352
[packages/glslang.git] / glslang.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 #
5
6 Summary:        Khronos reference front-end for GLSL and ESSL
7 Summary(pl.UTF-8):      Wzorcowy frontend GLSL i ESSL z projektu Khronos
8 Name:           glslang
9 Version:        7.12.3352
10 Release:        1
11 License:        BSD-like
12 Group:          Applications/Graphics
13 Source0:        https://github.com/KhronosGroup/glslang/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  b31bc89ffa86dbb5ab638c9c2a412302
15 Patch0:         runtests.patch
16 URL:            https://github.com/KhronosGroup/glslang
17 BuildRequires:  cmake >= 2.8.11
18 BuildRequires:  bison
19 BuildRequires:  libstdc++-devel >= 6:4.7
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 An OpenGL and OpenGL ES shader front end and validator.
24
25 %description -l pl.UTF-8
26 Frontend i walidator shaderów OpenGL i OpenGL ES.
27
28 %package devel
29 Summary:        Khronos reference front-end libraries for GLSL and ESSL
30 Summary(pl.UTF-8):      Wzorcowe biblioteki frontendowe GLSL i ESSL z projektu Khronos
31 Group:          Development/Libraries
32
33 %description devel
34 A front-end libraries for programmatic parsing of GLSL/ESSL into an
35 AST.
36
37 %description devel -l pl.UTF-8
38 Biblioteki frontendowe do programowej analizy GLSL/ESSL do postaci
39 AST.
40
41 %prep
42 %setup -q
43 %patch0 -p1
44
45 %build
46 install -d build
47 cd build
48 %cmake ..
49 %{__make}
50 cd ..
51
52 %if %{with tests}
53 cd Test
54 ./runtests
55 cd ..
56 %endif
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} -C build install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 install build/StandAlone/libglslang-default-resource-limits.so $RPM_BUILD_ROOT%{_libdir}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README-spirv-remap.txt
72 %attr(755,root,root) %{_bindir}/glslangValidator
73 %attr(755,root,root) %{_bindir}/spirv-remap
74 %attr(755,root,root) %{_libdir}/libHLSL.so
75 %attr(755,root,root) %{_libdir}/libSPIRV.so
76 %attr(755,root,root) %{_libdir}/libSPVRemapper.so
77 %attr(755,root,root) %{_libdir}/libglslang-default-resource-limits.so
78 %attr(755,root,root) %{_libdir}/libglslang.so
79
80 %files devel
81 %defattr(644,root,root,755)
82 %doc README.md
83 %{_libdir}/libOGLCompiler.a
84 %{_libdir}/libOSDependent.a
85 %{_includedir}/SPIRV
86 %{_includedir}/glslang
This page took 0.060697 seconds and 3 git commands to generate.