]> git.pld-linux.org Git - packages/glslang.git/blob - glslang.spec
Merge remote-tracking branch 'origin/SPIRV-1.3'
[packages/glslang.git] / glslang.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build with tests
4
5 Summary:        Khronos reference front-end for GLSL and ESSL
6 Summary(pl.UTF-8):      Wzorcowy frontend GLSL i ESSL z projektu Khronos
7 Name:           glslang
8 Version:        7.12.3352
9 Release:        1
10 License:        BSD-like
11 Group:          Applications/Graphics
12 #Source0Download: https://github.com/KhronosGroup/glslang/releases
13 Source0:        https://github.com/KhronosGroup/glslang/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  b31bc89ffa86dbb5ab638c9c2a412302
15 Patch0:         runtests.patch
16 Patch1:         %{name}-system-spirv.patch
17 URL:            https://github.com/KhronosGroup/glslang
18 BuildRequires:  cmake >= 2.8.11
19 BuildRequires:  bison
20 BuildRequires:  libstdc++-devel >= 6:4.7
21 %{?with_tests:BuildRequires:    spirv-tools-devel}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 An OpenGL and OpenGL ES shader front end and validator.
26
27 %description -l pl.UTF-8
28 Frontend i walidator shaderów OpenGL i OpenGL ES.
29
30 %package devel
31 Summary:        Khronos reference front-end libraries for GLSL and ESSL
32 Summary(pl.UTF-8):      Wzorcowe biblioteki frontendowe GLSL i ESSL z projektu Khronos
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 A front-end libraries for programmatic parsing of GLSL/ESSL into an
38 AST.
39
40 %description devel -l pl.UTF-8
41 Biblioteki frontendowe do programowej analizy GLSL/ESSL do postaci
42 AST.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47 %patch1 -p1
48
49 %build
50 install -d build
51 cd build
52 %cmake ..
53 %{__make}
54 cd ..
55
56 %if %{with tests}
57 cd Test
58 ./runtests
59 cd ..
60 %endif
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} -C build install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc README-spirv-remap.txt
74 %attr(755,root,root) %{_bindir}/glslangValidator
75 %attr(755,root,root) %{_bindir}/spirv-remap
76 %attr(755,root,root) %{_libdir}/libHLSL.so
77 %attr(755,root,root) %{_libdir}/libSPIRV.so
78 %attr(755,root,root) %{_libdir}/libSPVRemapper.so
79 %attr(755,root,root) %{_libdir}/libglslang.so
80 %attr(755,root,root) %{_libdir}/libglslang-default-resource-limits.so
81
82 %files devel
83 %defattr(644,root,root,755)
84 %doc README.md
85 %{_libdir}/libOGLCompiler.a
86 %{_libdir}/libOSDependent.a
87 %{_includedir}/SPIRV
88 %{_includedir}/glslang
This page took 0.097948 seconds and 3 git commands to generate.