]> git.pld-linux.org Git - packages/glog.git/blob - glog.spec
- pl, complete ac/am/lt regeneration, added -static
[packages/glog.git] / glog.spec
1 Summary:        A C++ application logging library
2 Summary(pl.UTF-8):      Biblioteka do logowania dla aplikacji w C++
3 Name:           glog
4 Version:        0.3.3
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 #Source0Download: http://code.google.com/p/google-glog/downloads/list
9 Source0:        http://google-glog.googlecode.com/files/%{name}-%{version}.tar.gz
10 # Source0-md5:  a6fd2c22f8996846e34c763422717c18
11 URL:            http://code.google.com/p/google-glog
12 BuildRequires:  autoconf >= 2.57
13 BuildRequires:  automake
14 BuildRequires:  gflags-devel
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.5
17 BuildRequires:  libunwind-devel
18 BuildRequires:  pkgconfig
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Google glog is a library that implements application-level logging.
23 This library provides logging APIs based on C++-style streams and
24 various helper macros.
25
26 %description -l pl.UTF-8
27 Google glog to biblioteka implementująca logowanie na poziomie
28 aplikacji. Zapewnia API do logowania oparte na strumieniach w stylu
29 C++ oraz różne makra pomocnicze
30
31 %package devel
32 Summary:        Development files for glog library
33 Summary(pl.UTF-8):      Pliki programistyczne biblioteki glog
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       gflags-devel
37 Requires:       libstdc++-devel
38
39 %description devel
40 This package contains the header files for developing applications
41 that use glog library.
42
43 %description devel -l pl.UTF-8
44 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
45 wykorzystujących bibliotekę glog.
46
47 %package static
48 Summary:        Static glog library
49 Summary(pl.UTF-8):      Statyczna biblioteka glog
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static glog library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka glog.
58
59 %prep
60 %setup -q
61
62 %build
63 %{__libtoolize}
64 %{__aclocal} -I m4
65 %{__autoconf}
66 %{__autoheader}
67 %{__automake}
68 %configure
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libglog.la
78 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS COPYING ChangeLog README
89 %attr(755,root,root) %{_libdir}/libglog.so.*.*.*
90 %attr(755,root,root) %ghost %{_libdir}/libglog.so.0
91
92 %files devel
93 %defattr(644,root,root,755)
94 %doc doc/designstyle.css doc/glog.html
95 %attr(755,root,root) %{_libdir}/libglog.so
96 %{_includedir}/glog
97 %{_pkgconfigdir}/libglog.pc
98
99 %files static
100 %defattr(644,root,root,755)
101 %{_libdir}/libglog.a
This page took 0.067804 seconds and 3 git commands to generate.