]> git.pld-linux.org Git - packages/glog.git/blob - glog.spec
6a46ef77b1f4702d820e8b1d65109d17d022f21d
[packages/glog.git] / glog.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # gtest/gmock based tests [signalhandler_unittest broken on x32 as of 0.4.0]
4
5 Summary:        A C++ application logging library
6 Summary(pl.UTF-8):      Biblioteka do logowania dla aplikacji w C++
7 Name:           glog
8 Version:        0.4.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://github.com/google/glog/releases
13 Source0:        https://github.com/google/glog/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  0daea8785e6df922d7887755c3d100d0
15 Patch0:         %{name}-gflags.patch
16 Patch1:         avoid-inline-asm.patch
17 URL:            https://github.com/google/glog
18 BuildRequires:  autoconf >= 2.57
19 BuildRequires:  automake
20 BuildRequires:  gflags-devel
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:1.5
23 BuildRequires:  pkgconfig
24 %if %{with tests}
25 BuildRequires:  gmock-devel
26 BuildRequires:  gtest-devel
27 %else
28 BuildConflicts: gmock-devel
29 BuildConflicts: gtest-devel
30 %endif
31 %ifarch %{ix86} %{x8664} x32 %{arm} hppa ia64 mips ppc ppc64 sh
32 BuildRequires:  libunwind-devel
33 %endif
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Google glog is a library that implements application-level logging.
38 This library provides logging APIs based on C++-style streams and
39 various helper macros.
40
41 %description -l pl.UTF-8
42 Google glog to biblioteka implementująca logowanie na poziomie
43 aplikacji. Zapewnia API do logowania oparte na strumieniach w stylu
44 C++ oraz różne makra pomocnicze
45
46 %package devel
47 Summary:        Development files for glog library
48 Summary(pl.UTF-8):      Pliki programistyczne biblioteki glog
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       gflags-devel
52 Requires:       libstdc++-devel
53
54 %description devel
55 This package contains the header files for developing applications
56 that use glog library.
57
58 %description devel -l pl.UTF-8
59 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
60 wykorzystujących bibliotekę glog.
61
62 %package static
63 Summary:        Static glog library
64 Summary(pl.UTF-8):      Statyczna biblioteka glog
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static glog library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka glog.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77 %patch1 -p1
78
79 %build
80 %if %{with tests}
81 install -d gmock
82 cd gmock
83 %cmake $(pkg-config --variable=srcdir gmock) \
84         -DBUILD_SHARED_LIBS=OFF
85 %{__make}
86 cd ..
87 LDFLAGS="%{rpmldflags} -L$(pwd)/gmock"
88 %endif
89 %{__libtoolize}
90 %{__aclocal} -I m4
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure
95
96 %{__make}
97
98 %if %{with tests}
99 %{__make} check
100 %endif
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libglog.la
108 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS COPYING ChangeLog README.md
119 %attr(755,root,root) %{_libdir}/libglog.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libglog.so.0
121
122 %files devel
123 %defattr(644,root,root,755)
124 %doc doc/designstyle.css doc/glog.html
125 %attr(755,root,root) %{_libdir}/libglog.so
126 %{_includedir}/glog
127 %{_pkgconfigdir}/libglog.pc
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/libglog.a
This page took 0.048544 seconds and 2 git commands to generate.