]> git.pld-linux.org Git - packages/glib.git/blob - glib.spec
- make -j1
[packages/glib.git] / glib.spec
1 #
2 # Conditional build:
3 #
4 %bcond_without  static_libs     # don't build static library
5 #
6 Summary:        Useful routines for 'C' programming
7 Summary(cs.UTF-8):      Šikovná knihovna s funkcemi pro pomocné programy
8 Summary(da.UTF-8):      Nyttige biblioteksfunktioner
9 Summary(de.UTF-8):      Eine nützliche Library von Dienstprogramm-Funktionen
10 Summary(fi.UTF-8):      Kirjasto, jossa on työkalufunktioita
11 Summary(fr.UTF-8):      Bibliothèque de fonctions utilitaires
12 Summary(pl.UTF-8):      Biblioteka zawierająca wiele użytecznych funkcji C
13 Summary(tr.UTF-8):      Yararlı ufak yordamlar kitaplığı
14 Name:           glib
15 Version:        1.2.10
16 Release:        14
17 Epoch:          1
18 License:        LGPL
19 Group:          Libraries
20 Source0:        ftp://ftp.gtk.org/pub/gtk/v1.2/%{name}-%{version}.tar.gz
21 #Source0-md5:   6fe30dad87c77b91b632def29dd69ef9
22 Source1:        http://developer.gnome.org/doc/API/%{name}-docs.tar.gz
23 #Source1-md5:   cae06bf952176ab008100b7b954242f8
24 Patch0:         %{name}-info.patch
25 Patch1:         %{name}-ac25.patch
26 Patch2:         %{name}-am18.patch
27 Patch3:         %{name}-link.patch
28 Patch4:         %{name}-gcc34.patch
29 Patch5:         %{name}-slist_remove.patch
30 URL:            http://www.gtk.org/
31 BuildRequires:  autoconf >= 2.13
32 BuildRequires:  automake >= 1.4
33 BuildRequires:  libtool >= 1:1.4.2-9
34 BuildRequires:  texinfo
35 Obsoletes:      libglib1.2
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         specflags       -fno-strict-aliasing
39
40 %description
41 GLib, is a library which includes support routines for C such as
42 lists, trees, hashes, memory allocation, and many other things. GLIB
43 includes also generally useful data structures used by GIMP and many
44 other.
45
46 %description -l cs.UTF-8
47 Šikovná knihovna s funkcemi pro pomocné programy. Vývojové knihovny a
48 hlavičky jsou v balíčku glib-devel.
49
50 %description -l da.UTF-8
51 Nyttigt bibliotek med forskellige funktioner. Udviklings- biblioteker
52 og headerfiler er i glib-devel pakken.
53
54 %description -l de.UTF-8
55 Eine nützliche Library von Dienstprogramm-Funktionen.
56 Entwicklungs-Libraries und Header befinden sich in glib-devel.
57
58 %description -l fi.UTF-8
59 Kirjasto, jossa on työkalufunktioita. Kehitysversiot ja
60 header-tiedostot ovat glib-devel-paketissa.
61
62 %description -l pl.UTF-8
63 Glib jest zestawem bibliotek zawierających funkcje do obsługi list,
64 drzewek, funkcji mieszających, funkcji do alokacji pamięci i wielu
65 innych podstawowych funkcji i różnych struktur danych używanych przez
66 program GIMP i wiele innych.
67
68 %description -l tr.UTF-8
69 Yararlı yordamlar kitaplığı. Geliştirme kitaplıkları ve başlık
70 dosyaları glib-devel paketinde yer almaktadır.
71
72 %package devel
73 Summary:        Glib heades files, documentation
74 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do glib
75 Group:          Development/Libraries
76 Requires:       %{name} = %{epoch}:%{version}-%{release}
77 Obsoletes:      libglib1.2-devel
78
79 %description devel
80 Header files for the support library for the GIMP's X libraries, which
81 are available as public libraries. GLIB includes generally useful data
82 structures.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe i dokumentacja do glib przydatna przy pisaniu
86 programów wykorzystujących tę bibliotekę.
87
88 %package static
89 Summary:        Static glib libraries
90 Summary(pl.UTF-8):      Biblioteki statyczne do glib
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
93
94 %description static
95 Static glib libraries.
96
97 %description static -l pl.UTF-8
98 Biblioteki statyczne do glib.
99
100 %prep
101 %setup -q -a1
102 %patch0 -p1
103 %patch1 -p1
104 %patch2 -p1
105 %patch3 -p1
106 %patch4 -p1
107 %patch5 -p1
108
109 %build
110 rm -f acinclude.m4
111 %{__libtoolize}
112 %{__aclocal}
113 %{__autoconf}
114 %{__automake}
115 %configure \
116         --enable-debug=%{?debug:yes}%{!?debug:minimum} \
117         --enable-threads \
118         %{!?with_static_libs:--disable-static}
119
120 %{__make} -j1 all check
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT \
127         m4datadir=%{_aclocaldir} \
128         pkgconfigdir=%{_pkgconfigdir}
129
130 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %post devel
139 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
140
141 %postun devel
142 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
143
144 %files
145 %defattr(644,root,root,755)
146 %doc AUTHORS ChangeLog NEWS README
147 %attr(755,root,root) %{_libdir}/libg*.so.*.*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %doc glib/*.html
152 %attr(755,root,root) %{_bindir}/glib-config
153 %attr(755,root,root) %{_libdir}/lib*.so
154 %{_libdir}/lib*.la
155 %{_libdir}/glib
156 %{_includedir}/*
157 %{_pkgconfigdir}/*
158 %{_aclocaldir}/*
159 %{_infodir}/glib.info*
160 %{_mandir}/man1/glib-config.1*
161
162 %if %{with static_libs}
163 %files static
164 %defattr(644,root,root,755)
165 %{_libdir}/lib*.a
166 %endif
This page took 0.048307 seconds and 4 git commands to generate.