]> git.pld-linux.org Git - packages/glib.git/blob - glib.spec
- added "Conflicts: glibc <= 2.0.7" for prevent install glib
[packages/glib.git] / glib.spec
1 Summary:        Useful routines for 'C' programming
2 Summary(pl):    Biblioteka zawieraj±ca wiele u¿ytecznych funkcji C
3 Name:           glib
4 Version:        1.2.0
5 Release:        1
6 Copyright:      LGPL
7 Group:          Libraries
8 Group(pl):      Biblioteki
9 Source:         ftp://ftp.gimp.org/pub/gtk/v1.1/%{name}-%{version}.tar.gz
10 Patch0:         glib-info.patch
11 URL:            http://www.gtk.org/
12 BuildRoot:      /tmp/%{name}-%{version}-root
13 Conflicts:      glibc <= 2.0.7
14
15 %description
16 GLib, is a library which includes support routines for C such as lists,
17 trees, hashes, memory allocation, and many other things. GLIB includes
18 also generally useful data structures used by GIMP and many other.
19
20 %description -l pl
21 Glib jest zestawem bibliotek zawieraj±cych funkcje do obs³ugi list, drzewek,
22 funkcji mieszaj±cych, dunkcji do alokacji pamiêci i wielu innych
23 podstawowych funkcji i ró¿nch struktór danych u¿ywanych przez program GIMP i
24 wiele innch.
25
26 %package devel
27 Summary:        Glib heades files, documentation
28 Summary(pl):    Pliki nag³ówkowe i dokumentacja do glib
29 Group:          Development/Libraries
30 Group(pl):      Programowanie/Biblioteki
31 Prereq:         /sbin/install-info
32 Requires:       %{name} = %{version}
33 Requires:       autoconf >= 2.13
34 Requires:       automake >= 1.4
35 Requires:       libtool  >= 1.2d
36
37 %description devel
38 Header files for the support library for the GIMP's X libraries, which are
39 available as public libraries. GLIB includes generally useful data
40 structures.
41
42 %description -l pl devel
43 Pliki nag³owkowe i dokumentacja do glib przydatna przy pisaniu programów
44 wykorzystuj±cych biblioteki glib.
45
46 %package static
47 Summary:        Static glib libraries
48 Summary(pl):    Biblioteki statyczne do glib
49 Group:          Development/Libraries
50 Group(pl):      Programowanie/Biblioteki
51 Requires:       %{name}-devel = %{version}
52
53 %description static
54 Static glib libraries.
55
56 %description -l pl static
57 Biblioteki statyczne do glib.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62
63 %build
64 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
65 ./configure \
66         --prefix=/usr \
67         --enable-threads
68 make
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 make install DESTDIR=$RPM_BUILD_ROOT
73
74 strip $RPM_BUILD_ROOT/usr/lib/lib*.so.*.*
75
76 gzip -9nf $RPM_BUILD_ROOT/usr/info/glib* 
77
78 gzip -9fn $RPM_BUILD_ROOT/usr/man/man1/*
79 bzip2 -9  AUTHORS ChangeLog NEWS README
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %post devel
85 /sbin/install-info /usr/info/glib.info.gz /etc/info-dir
86
87 %preun devel
88 if [ "$1" = "0" ]; then
89         /sbin/install-info --delete /usr/info/glib.info.gz /etc/info-dir
90 fi
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %attr(755,root,root) /usr/lib/libg*.so.*.*
97
98 %files devel
99 %defattr(644,root,root,755)
100 %doc {AUTHORS,ChangeLog,NEWS,README}.bz2
101
102 %attr(755,root,root) /usr/lib/lib*.so
103
104 /usr/lib/glib
105 /usr/include/*
106 /usr/share/aclocal/*
107
108 /usr/info/glib.info*
109
110 %attr(755,root,root) /usr/bin/*
111 /usr/man/man1/glib-config.1.gz
112
113 %files static
114 %attr(644,root,root) /usr/lib/lib*.a
115
116 %changelog
117 * Sat Feb 27 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
118   [1.2.0-1]
119 - changed Group fields to Libraries, Development/Libraries and
120   prefix to /usr (glib is not X11 library),
121 - added "Conflicts: glibc <= 2.0.7" for prevent install glib
122   with proper version glibc.
123
124 * Wed Feb 24 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
125   [1.1.16-1]
126 - removed man group from man pages.
127
128 * Mon Jan 18 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
129   [1.1.13-1d]
130 - added Group(pl) and changed all Group fields,
131 - added "Requires: autoconf >= 2.13, automake >= 1.4, libtool >= 1.2d"
132   for devel subpackage.
133
134 * Sat Jan 01 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
135   [1.1.11-1]
136 - standarized {un}registering info pages (added glib-info.patch).
137
138 * Sat Dec 19 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
139   [1.1.9-1]
140 - added gzipping man pages,
141 - /sbin/install-info moved to Prereq in devel,
142 - standarized {un}registering info pages,
143 - added --enable-threads ./confogure parameter.
144 - added using LDFLAGS="-s" to ./configure enviroment.
145
146 * Tue Nov 24 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
147   [1.1.5-1]
148 - added pl translation,
149 - added /usr/X11R6/man/man1/glib-config.1 and glib info to devel,
150 - changes in Summary and %description.
151
152 * Fri Sep 18 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
153   [1.1.2-2]
154 - changed prefix to /usr/X11R6.
155
156 * Mon Aug  10 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
157   [1.1.2-1]
158 - added -q %setup parameter,
159 - added using %%{name} and %%{version} macros in Source,
160 - Buildroot changed to /tmp/%%{name}-%%{version}-root,
161 - added static subpackage,
162 - added stripping shared libs,
163 - build against GNU libc-2.1.
164
165 * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
166 - Split out glib package
This page took 0.050593 seconds and 4 git commands to generate.